Installation on Lenovo Ideapad L340 Gaming - Blackscreen

Yes, i followed your commands from post 10.

So currently every time you boot it just goes to grub rescue?

Everytime I boot without manually going into Bios boot menu, yes.

Edit: I have to boot quite often, since after it freezes I have to shut it off.

I’ll let someone with more experience maybe help you since it is luks and btrfs.

How are you shutting it off? By cutting power to it (holding down the power button)? If so, there could be filesystem corruption.

Use the magic SysRQ key to safely reboot when your system freezes.

1 Like

You have messed your (booting) system badly.
I guess you can’t boot to windows as well, since it seems (you should have left fstab without censoring UUIDs) have somehow deleted the $ESP/efi folder, or something similar.
With more info it will be clear.

Edit:
Post your complete fstab and this

efibootmgr -v
ls /boot/boot
1 Like

Windows is running fine, as far as I can tell from booting into it. I cannot tell if the system also freezes after some time, since I just started it. I turned it off, whilest holding shift, and am now back on linux, with tty mode this time so I don’t have to force it off again.

$ ls /boot/boot
grub
initramfs-linux-fallback.img
initramfs-linux.img
intel-ucode.img
vmlinuz-linux

fstab: https://bin.disroot.org/?a487006b424a9b05#4ku1tBE5oDehy3hsiFxQcahjQw8xf1DsWtjCgXoj7SY7

/e: efibootmgr -v returns the same as above, EFI variables are not supported on this system.

I have to force shut it off, no key combination whatsoever works.

You haven’t installed it in UEFI mode then? @petsam

Don’t use pastebin for these small output, only for long logs, please.

Check and post again

lsblk -f
findmnt /
findmnt /boot
# after the above, run again
lsblk -f
ls /boot

Your system is installed in BIOS mode, not UEFI.
If you want you can keep your system as is (after repairing).
If you want to have it in UEFI mode, you need to re-install properly (boot installer in UEFI mode, select the vfat/fat partition as /boot/efi, etc., as in EnOS installation instructions).

Creating another flash drive, again with popsicle since the dd’ed once won’t work, and then going through another setup process with uefi, everything seems to be fine for now. I may have overlooked that detail at my first go, but I cannot know for sure.

This has been a lot of hazzle, given that I wanted to go for EOS because I didn’t want to go through another lenghty terminal install. Now I’ve spent hours in the terminal, trying to make up for my own failures / incompetence. Thank you all for taking your time.

1 Like

Make sure you have booted in UEFI.

@xtc
If you are using manually partitioning then you would normally use the Windows efi partition that already exists and during the manual partitioning process inside the installer you would edit it and not format it but flag it as /boot/efi and flag it as /boot in the manual partitioning process as well as setting up your other partitions which also need to be flagged.

The installer shows at the top of on the left whether it’s efi in the partitioning window. It’s easy to overlook things when not used to the methods.

If there is anything you don’t understand about the install process just ask. We are here to help and there is always someone that can assist.

I hope that the ISO boots properly for you as i know that was an issue in the beginning.

1 Like

Thanks for the advice. I know that I could recycle the efi partition, but I did infact create a new one by choice. Since I use linux as my daily driver, I want things to be bundled from here and not supplied by windows. I may or may not get rid of Windows completely. I know there is no real benefit of making a new partition, but it just feels more clean.

The thing about the installer was more about the drive. Since I had to manually select the device in the BIOS boot menu, I think I just have overlook that there are in fact two entries for the flash drive. One without prefix, the second one like “UEFI: GENERIC FLASH DRIVE”. I already fell for something like that during my first install of arch in a VM. So to anyone reading this, pay good attention to the boot selection, if you are having issues.

I am now running EOS with no issues, I am quite pleased so far.

1 Like

I have a number of dual boot with Windows and if you use the automatic partitioning and installing on another disc it creates it’s own efi partition and you still have the Windows efi. Nothing wrong with that either. But if you do manual partitioning you can select the original Windows efi and use it or you could recreate it. Obviously the boot order matters as grub controls the boot for both EOS and Windows. Glad you got it figured out and installed correctly in UEFI mode hopefully. This will show it’s installed in efi or bios.

test -d /sys/firmware/efi && echo efi || echo bios

Some vendors’ UEFI implementations that are closely focused/targeted on Windows, let Windows delete Linux entries, or other issues, depending on various reasons.
Creating a separate partition for a Linux ESP is not a bad idea. IMHO I would say it’s a good habit, just to be on the safe side. :wink:

I usually do that but I’ve also used the Windows efi. I myself on any of my equipment haven’t had any issues in that respect but I agree with you because all vendors UEFI implementation don’t always adhere to the specifications and there are other issues sometimes that cause problems for sure.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.