Installation is failiing pacstrap error

Hi , I am kinda Arch - Endeavour-Os newbie and really wanted to try it out . Have used it before but only KDE version and that too with built in installer and am not aware of intricacies of installation and where everything is store . Primary use is coding , browsing and mild media consumption .

Wanted to install the Awesome - wm but since it’s not provided as community version , tried installing the community Bsp-wm version and it fails claiming “Failed to run PacStrap”. - attached error log .

So i google around and try to change the key ring after a hard reboot ( guess reboot is required after a failed installation). This time around it downloads stuff but fails to make changes to root system , there was an error log but i failed to write down the link , i could try to reproduce if needed.

Edit : this is with GPT partition . Error log where download happens but installation fails due to invalid key issue
2023-01-28 - 11:38:50 [6]: [PYTHON JOB]: “pacstrap: ==> ERROR: Failed to install packages to new root”

So again i reboot and try installing the i3 - wm edition but unfortunately something always goes wrong during downloading / installation phase .

So in the end i ended up installing the offline version , xfce DE version . All good during this process and system boots up happily !

But , unfortunately I can’t update my system when typing ‘yay’ or ‘sudo pacman -Sy’ or cannot install any new package / software .
It downloads all the content but after Key-ring verification process it says Gcc / Firefox /Nvidia and couple of other packages are corrupted or invalid signature . (aka pgp signature ) . I am pretty sure that’s certainly not the case , doubt any one is trying to send me malicious packages probably some networking issue .

Again i google it and try to update the key ring with :
“sudo pacman -S archlinux-keyring” , which gives me a warning that key-rings are already installed and it will dl 1.6 Mb of data , anyways I proceed with Y es and it still gives same error when updating , asking whether i should keep or deleted the corrupted project , I ended up not deleting the packages since it was just wasting server bandwidth each time .

So in next step removed everything from “/etc/pacman.d/gnupg” , followed by “pacman-key --init” , “pacman-key --populate archlinux” with Endeavour variant (don’t remember the exact command atm) , and lastly “refreshed” them . Still got the same error . I could disable this check by toggling it to never but feel it’s not sure that’s a safe way to do this .

Lastly tried to change the mirror with reflector to bunch of different countries and few entries from Official Arch wiki for Indian mirrors. Still getting corrupted PGP keys error . I am at loss of steps . Any guidance would be helpful .

I am looking to install the Bsp-wm / Awesome wm community version and if not possible , solve the keyring error so i can do that manually after installation of Os.

Thanks !

Welcome to the forum! :smile:

Looks like mirrors are not OK.
Try updating the Arch mirrorlist before starting the actual install.
You may need to select different countries to have fully working mirrors.
Usually German and US mirrors work well worldwide.

Hi , Thank you very much for the warm welcome :grinning: .
It seems there are two mirror lists in the pacman.d/ directory
1 mirrorlist.
I am unsure which one to update but since the only bold letters are Arch I think it’s the first one .

So I ran reflector and selected only two countries Germany and US based on rate and https . So there are 9 German and 1 Us server links in the mirrorlist.

After that ran eos-reflector from the welcome script dialogue , which updated the list at the end but just to be safe un-commented 3 servers listed under Germany at the beginning.

Followed by yay / sudo pacman -Sy . And it still gives the same error.

Extra steps added India mirrors from the forums , well it updates the mirrorlist , but system update gives same error.

Tried different combination of countries both in mirrorlist and endv-mirrorlist , with same error.

On a side note tried installing Arch (heh) from scratch and funnily enough ‘pacstrap base linux’ gave the same pgp key error. It seems problem truly lies in Arch-keyring .I am not sure what could be the problem here or how to proceed further .

Yes, looks like the Arch mirrors and/or the Arch keyring are not properly set up.

Keyring issues should be solved by this:

Please note that it is enough to use only one of the mirror ranking programs (reflector, reflector-simple or rate-mirrors) for Arch mirrors. I’d recommend to test which one is giving the best result.

1 Like

looks like a real “bad luck” condition… like installed keyring is installed from an outdated server and ranked mirrors does not match the same state…

1 Like

Good news everyone :slight_smile: Turns out it was a Ram issue , took them out rubbed the metal with some rubber and everything is working like charm .

I was experiencing random freeze in my old Ubuntu installation and thought well why not try the fancy sleek Endeavour . I guess for some reason system was working with the ram but just enough that it would think it was getting corrupted package !! Man i got lucky ! Installed it multiple times with no error and can update properly .

Running my shiny new Endeavour :smiley: gotta learn new os and some tiling shortcuts , thank you very much .

1 Like