Install problem with AMD Radeon RX 5600 XT

Hello!
I’ve seen other old threads talking about issues with newer AMD graphics cards. I recently acquired a used AMD Radeon RX 5600 XT. It runs perfect in Windows. The reason I bought it was so I could switch back to Linux and I wanted to try Endeavouros. The computer is a Dell Precision T5610 with dual Intel Xeon E5-2650 v2 CPUs. I previously had an Nvidia Geforce GTX 1060 and was able to run Manjaro no problem. I have tried ubuntu, Manjaro and Endeavouros and none of their “live cd” installers can get to the GUI to even try installing the OS.
With Endeavouros, if I choose the fallback (nomodset) boot option, it starts to load then stops with an error loading into Xorg.

Welcome to your endeavour
VERSION=2022.04.08
Last login: Mon Jun 27 20:13:38 on tty1

X.Org X Server 1.21.1.3
X Protocol Version 11, Revision 0
Current Operating System: Linux EndeavourOS 5.17.1-arch1-1 #1 SMP PREEMPT Mon, 28 Mar 2022 20:55:33 +0000 x86_64
Kernel command line: initrd=arch\boot\x86_64\initramfs-linux.img archisobasedir=arch archisolabel=EOS_202204 cow_spacesize=10G module_blacklist=nvidia,nvidia_modeset,nvidia_uvm,nvidia_drm nomodeset nvme_load=yes

Current version of pixman: 0.40.0
Before reporting problens, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Tine: Tue Jun 28 00:13:54 2022
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
(EE)
Fatal server error:
(EE) no screens found (EE)
(EE) Please consult the The X.Org Foundation support
at http://wiki.x.org for help.
(EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
(EE)
(EE) Server terminated with error (1), Closing log file.

Not sure how to get around this… any help is appreciated.

amdgpu needs modesetting, so it is expected to not work with nomodeset

You can’t use nomodeset. Also are you using the latest ISO that was just released?

Thank you for the replies!
I used EndeavourOS_Apollo_22_1.iso downloaded today.
if I choose the default option I get this


it just hangs there and does not continue and I have to reboot the machine.
(edit to add more info)
This “hang” during boot happens with Manjaro and Ubuntu, both the latest.
Its something with my setup but I don’t know what…
Would removing the video card and installing a temporary one be something to try?
would it mess things up if I installed while I had an old card and then swapped in the new AMD card?

There is a newer ISO just released. The 5600 XT should boot fine on amdgpu. I suggest downloading the new ISO and trying it.

Edit: As was mentioned you have nomodeset in the default grub command line. It will fail with that. I really suggest trying the latest ISO and let us know then if still having an issue.

I understand that the nomodset will not work. Thank you I will not attempt that again. Downloading the new ISO now. Will report back with results.

Ok tried with EndeavourOS_Artemis-22_6.iso
Same thing.
just hangs at “Triggering uevents”
Just as a test, I also tried archlinux-2022.06.01-x86_64.iso
When I tried to boot base arch installer, it gets a step farther.


Not sure why this error… all of the USB ports work and are clean.
not sure which ports are considered 7 and 8.

What did you have on this system before? It would be nice to see the hardware output. Are you able to boot on anything else in order to do that?

Edit: If you can boot it on Manjaro live ISO and run

inxi -Faz 
lsusb

Edit: Just like to see what the command line looks like that it boots with on Manjaro.

You could try this kernel parameter in the default grub command line.

ehci_hcd.ignore_oc=1

Edit: This tells it to ignore the over-current condition.

Edit2: From what i am reading it looks like there is a bad usb device possibly or bad port. Can be caused by dust and humidity also or bad component on the board such as a capacitor.

This is my main PC and currently running Windows 10. I had switched it back to Windows a few months back and planned to try either Manjaro or Endeavour again once I got the AMD card. I can try adding the parameter but I am not sure how to add it.

From what I’m reading it doesn’t seem to matter anyway. But you could try it temporarily on boot. Just boot on the live ISO and press e for edit at the menu and then add this in the grub command line at the end of the line. Then press enter to continue booting. See what happens.

ehci_hcd.ignore_oc=1

If it’s possible to boot on a live ISO of manjaro you could run those commands and give the output since you say it worked.

You do have secure boot disabled?

yes Secure Boot is disabled.
I attempted to add the kernel parameter but I found that I cannot type the “_” underscore character when at that screen after I press E so I was unable to try booting with it.
I tried adding it at the Manjaro installer boot menu, they have the option to edit the boot parameters but it still did not boot.
Also of note.
You asked about the hardware, the motherboard chipset is PCIe 3.0 but the card is PCIe 4.0. I would not think this is an issue but just thought I’d mention.
I appreciate your attention but I am giving up for tonight.
Will try again tomorrow.

Your PC Owner’s Manual says there is a Diagnostc capability.
You could try testing HW components. Maybe it will find any problem with the USB.
You could also try another USB drive, as it is not uncommon some of them to be incompatible.

Also, confirm proper BIOS settings, as sometimes a reset happens and resets them.

Maybe you should also check if there is a UEFI Bios update for your board.

1 Like

OK, update.
The motherboard BIOS has had the latest BIOS available from dell for a while. There are no new versions.
I’ve updated the vBIOS on the card.
I’ve tried all of my USB drives, two of which are brand new USB 2.0 and 3.0.
I even tried booting from Manjaro that was installed on an SSD on my laptop and that freezes immediately.
The next thing I want to try is removing the AMD RX 5600 XT and then attempting to boot from that same SSD.
I’ll try that a bit later.
Edit: OH I forgot to mention that I all of the self diagnostics check out good. No problems found.

1 Like

Did you try other usb ports to boot from? You can try disabling iommu in the bios and add a kernel parameter iommu=soft. You may need to try other parameters if this doesn’t work.

I also notice the pxe on boot? You should disable pxe boot in your Bios if it’s enabled.

I have tried booting from all of the USB ports. I have not tried disabling IOMMU. Is that the Intel VT-d?
Should I just disable virtualization support altogether?

You can use a kernel parameter on boot. Boot on the live ISO and press e for edit at the menu and add it to the default command line. You can try different ones.

iommu=soft

Edit: you could try some other kernel parameters such as

amdgpu.dpm=0