Install EndeavourOS on Mac-M1 or Mac-M2?

Moderator’s note.

This new Topic was created to give this question better visibility.



will there be release for Apple silicon?

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Here is a old topic on mac-m1

Here is another link that might be useful.

If you have any questions, feel free to start a new Topic with your questions.



I got a M2. Is M1 also working for M2?


(not for bare metal install)

ONLY for Parallels ,UTM and VMware

ATM Asahi linux should only be use for bare metal installs
" "
. . . . . . . . . . . . . . . . . . . . . . .
Welcome to Endeavouros forum

:pray: English no great . best way i can explain. Hope it help you

Paralllels work best imo.

1st install Base Arch ( use archboot )
" "

Download iso

pick iso you want

Open Parallels ,select archboot iso from where you save it. set up VM then boot iso.

(follow simple on screen text )

( if still no sure scroll down near bottom for how to video "

Once base Arch installed use Endeavouros arm install script .

info here ""

(Btw i no install Parallels tools )

if you try install + try Endeavouros I hope you enjoy your experience

EDit or if want use iso to manual install base Arch :blush:

EDit>2 prob best select (N) when it ask you if want install eos-arm kernel when you update system. until they update it. choice your…


thank you very much
Have a nice week!


I updated to the eos-arm kernel and I could no longer boot into the graphical login.

if boot to tty just install linux-aarch64-headers , linux-aarch64 from pacman or yay.

or add iso ( archboot) to vm. then arch-chroot fix that way

or revert last work snapshot ( if you use parallels snapshot)

side note i do post before


also in defence of EOS. AFAIK eos-arm kernel only for supported hardware .


eos-arm kernel is specifically compiled for the PineBook Pro.



just idea … remove endeavouros from 1st in pacman .conf in arm

( yes get warn yad )

but usr no get offer to install eos-arm kernel. ( think i right )

EDit > or put warn on M1 / M+ post for install

( if people read !! that different story )

We also have to keep in mind that we don’t provide an officially supported installation for EOS ARM on Apple silicon. Not because we don’t want to, but just because of the simple fact that the team doesn’t have an Apple M1 or M2 in the fleet.
Considering that most Mac users buy a Mac for the Apple experience and its branding, we cannot justify the costs a Mac purchase brings in for a relatively small project like ours and I’m not even talking about the amount of work it would bring on a project that leans on two persons.
In the end, we are still an enthusiast project with a very supportive community to back us in donating work and/or money.

1 Like

Understood. I am not installing directly to the hardware. I am running it inside of a VM with Fusion.

1 Like

i do small test . it boot ok ( no perfect) on eos-arm kernel. still as @Pudge say

so use / try your choice . fast look at build if update 6.2.7-1 will run better .

my advice is use linux-aarch64 ATM as @Bryanpwo point out


Good to know.


1 Like

How did you get that to work? I tried a fresh built and when yay switched the kernel to eos-arm, it stopped the VM from booting.

Fusion give more trouble than worth … just my opinion :innocent:

1 Like