Install drivers that are DX11 compatible

So my friend just installed endeavour, they’ve been setting it up and they’ve run into driver issues on most games. They have a 1050, so it should be new enough. The games have worked fine on other distros, it’s just endeavour.

They’ve tried reinstalling nvidia drivers, and they have drm enabled. Nothing else either of us can think of.

1 Like

Welcome! :partying_face:

Start by reading this, especially 2. Requirements

If you have all that and still have problems, ask further :upside_down_face:

They’ve installed all of the packages listed on the guide and they still get the error.

  1. Which specific games?
  2. Which specific error?
  3. Steam or Wine?
  4. Which version of engine (Proton / Wine / GE)?
  1. Farming simulator 2022, brick rigs


  1. Steam proton
  2. Experimental

Untick Experimental use just latest normal one (experimental implies it have problems)
This error have nothing to do with system, and everything with game :slight_smile:

See, latest Arch report was good with Proton 6.3-8

Just in case, return result of:

pacman -Q | grep -Ei "vulkan|nvidia"
1 Like

Selecting 6.3-8 doesn’t work.

Here’s all of the output from the command.

Nothing that should prevent it from working.
Maybe try changing this file to select other api, try Vulkan then DX12

Are there any errors in journal?

journalctl -p3 -xb

What about other games, which errors they have?

FS22 has the same error even when changed to vulkan or dx12, the journal doesn’t seem to have anything.

Other games are basically the exact same error, something about could not init 3d system.

Oh i can think of only one thing then, is it laptop with Optimus (Nvidia / Intel) by chance?

If so - to force Nvidia card when gaming.

They’re on a desktop with no integrated graphics.

All right, i give up. It doesn’t make any sense…
@BONK do you have idea?

1 Like

I don’t do Nvidia lol… :v:


Well, i doubt it’s Nvidia problem

Oh also, something I forgot to mention. The database linked in the guide posted earlier says that nvidia drivers for the 1050 should be version 510, but they’re only able to get up to 495.

Nah, that’s correct for now i believe

Maybe we can see

inxi -Ga
1 Like
  Device-1: NVIDIA GP107 [GeForce GTX 1050] driver: nvidia v: 495.46
    alternate: nouveau,nvidia_drm bus-ID: 08:00.0 chip-ID: 10de:1c81
    class-ID: 0300
  Display: x11 server: X.Org driver: loaded: nvidia
    unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.0x11.3")
    s-diag: 1055mm (41.6")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102
    size: 477x268mm (18.8x10.6") diag: 547mm (21.5")
  Monitor-2: DP-0 res: 1920x1080 dpi: 93 size: 527x296mm (20.7x11.7")
    diag: 604mm (23.8")
  OpenGL: renderer: NVIDIA GeForce GTX 1050/PCIe/SSE2
    v: 4.6.0 NVIDIA 495.46 direct render: Yes```

Nvidia is installed correctly. What game platform is this running on? Looks like it’s using wine?

proton 6.3-8