Include MemTest86+ on the LiveISO

It would be great if the LiveISO would include MemTest too.

Typically when you need to use LiveISO anytime after the initial install, it’s about fixing stuff. And then it pays to have some diagnostic tools included already.

looks like it is only configured for Legacy Boot, not for UEFI (at least that was my experience last week when testing a friend’s memory with a EndeavourOS stick with 22_10 that I had flying around. It showed on his old legacy boot system but did not on my modern UEFI only system.

Would definitely be great to have it in UEFI, too. Memtest86+ itself supports UEFI boot only since version 6.0 from October 2022:

1 Like

@joekamprad can we UEFI it?


I hear it could be possible… but no clue how

1 Like

I’ve found that:

For UEFI use package memtest86±efi:

menuentry "Memtest86+" {
 linux /boot/memtest86+/memtest.efi
1 Like

looks like for grub?

virtually… it works on systemd-boot


Lets check with an ISO :wink:


not that easy to add… to ISO as archiso does everything in a certain way… but should be possible…

    # Add other aditional/extra files to ${install_dir}/boot/
    if [[ -e "${pacstrap_dir}/boot/memtest86+/memtest.efi" ]]; then
        install -d -m 0755 -- "${isofs_dir}/boot/memtest86+/"
        install -m 0644 -- "${pacstrap_dir}/boot/memtest86+/memtest.efi" "${isofs_dir}/boot/memtest86+/memtest.efi"
        install -m 0644 -- "${pacstrap_dir}/usr/share/licenses/common/GPL2/license.txt" "${isofs_dir}/boot/memtest86+/"

so seems already in the mkarchiso script…
but only for grub usage …
may by a reason :wink:

Seems not that easy to get in


there is this name for memtest

yay -Ss memtest
extra/memtest86+ 6.20-1
    Advanced memory diagnostic tool legacy BIOS version
extra/memtest86+-efi 6.20-1 [installé]
    Advanced memory diagnostic tool EFI version
extra/memtest86+-iso 6.20-1
    Advanced memory diagnostic tool ISO image
extra/memtest86-efi 1:10.6build2000-1
    A free, thorough, stand alone memory test as an EFI application
1 Like

yea on installed system you can add an bootentry and use it:
sudo pacman -Syu memtest86+-efi
copy memtest.efi in a place the efi system can read… in case of default EndeavourOS under /efi
sudo mkdir /efi/EFI/memtest
sudo cp -a /boot/memtest86+/memtest.efi /efi/EFI/memtest/memtest.efi

create a bootloader entry:

sudo nano /efi/loader/entries/memtest.conf

title memtest86+ (Test your RAM)
efi /EFI/memtest/memtest.efi
#options smp

This should be all needed
But only tested in a vm … will see if the same works on real hardware now…

Seems to work also looks like keyboard is not recognized fully… but related to wireless keyboard with wired it works like it should.

And i see a main issue because it will not read the file the package installs… so it will not get updated automatically…
would neeed a hook… and a script…
Or changing the package to handle… or… yea creating a hook service package for systemd-boot ?


If I remember I had nothing to do when I installed memtest86±efi, my boot partition is mounted on /boot.

Tried once where in aur once of a time …efi itself is an entrance sysdboot should recognize or greub

yea if esp is mountet under /boot the efi file is inside esp…
But eos default is /efi for systemd-boot installs.

Gave up on adding it with systemd-boot (ISO) with grub (ISO) can show it in boot… and it works without any extra config needed…


probably need some manual? memtest86-efi --install ? i use /boot but you can use /efi scriptwise idk :slight_smile:

cat /boot/efi/loader/entries/memtest.conf                                            
title  Memtest86+
efi     /tools/memtest.efi

my EFI is mounted at /boot/efi but the way forward is easy. All I had to do in preparation was sudo pacman -S memtest86+-efi and sudo cp /boot/memtest86+/memtest.efi /boot/efi/tools/memtest.efi

That EndeavourOS uses /efi as mountpoint for EFI instead of /boot makes manually copying stuff necessary (my using /boot/efi also does …). Almost all tools install themselves to /boot
systemd-boot can’t use stuff outside of the EFI partition.

1 Like

I only talk about issue adding it to archiso, if using systemd-boot on real installs there is no issue.

not sure how the EFI partition situation is handled on the ISO, but I guess this limitation is also there:

i know that yes… i was already able to copy the memtest efi file in the right path to be inside EFI partition but the entry is still not shown up at all.
The conf file is also present. only no menu entry is there.

memtestx86-efi -i ?