Impossible to install (Nvidia/Qt=Available desktop QSize)

I’m trying to install EOS on an old PC that I’ve previously been using as an HTPC. It’s been working perfectly well with an old Nvidia card (GT 9600) that kind of worked but it was too old to get drivers working properly for hardware acceleration so it would decode on the CPU rather than the GPU. Today I got an Nvidia GT 1030, put it in and booted from a Ventoy flash drive with the option to use Nvidia drivers. This GPU is supported by the newer drivers. Everything looked perfectly normal until I clicked on the installer, then ‘Online’.

The enormous installer displays: “The screen is too small to display the installer.”

It’s worth noting that this is on a 46 inch TV running at 1920x1080. So… Not small.

I had the R2 ISO on the Ventoy flash drive. I went to see if there was an updated ISO in case it was a known bug that had been fixed, there was - R3. I downloaded that and booted from it. The same problem occurred.

My first thought was that it was a Calamares - not an EndeavourOS problem - problem so I went looking there. I found one or two people mentioning netbooks with their limited resolutions but this obviously doesn’t apply to me.

Then I decided to see if any other software has any similar problems. When I went into the launcher and Development->Qt (anything) the problem occurs.

The short version is: Anything Qt based will display with comically enormous proportions when the Nvidia option is selected at boot.

I then rebooted and selected the normal option (without Nvidia drivers) and everything looked as it should be: The installer was sized correctly and all Qt applications were in their correct proportions.

But I want the Nvidia drivers as I know for a fact that this card works fantastically well for hardware decoding of anything I throw at it, like 4K HEVC. I know this because I’ve already been using the exact same card in a different computer for the past three years. This is also on Linux, albeit Manjaro mainly, but also EOS. However, these are VMs running on a server whereas I’m trying to get this working on bare metal. Plus, the card is passive, so it’s completely silent.

This should have been a five minute installation and another five to set up the rest. But I can’t even install the OS at all.

eos-log-tool.logs (Nvidia option)

eos-log-tool.logs (Normal non-Nvidia option)

Notice how the Nvidia log says:

Available desktop QSize(640, 349) minimum size QSize(800, 520)
… Proposed window size: 800 520


requirement 6 “screen” satisfied? false mandatory? false

Screenshots of the attempted Nvidia install with shots of Qt applications to show the problem. I also include Firefox to show it’s unaffected:

Nvidia GT 1030 doesn’t support latest proprietary nvidia driver, you either need to use nouveau driver or somehow compile old enough driver for your card with AUR…

Perhaps @joekamprad can give some further advice.

P.S. That’s all because Nvidia makes proprietary drivers…and makes it obsolete with passing time…

You can easily install the nvidia drivers after completing the install. Install with the open source drivers and then use nvidia-inst after installing to switch to the proprietary drivers.

It does according to nvidia.


Ok…My bad, looking at it quickly i’ve made some assumptions.

Just to make sure, it’s GT, not GTX

1 Like

Yeah, I thought the same as you so I looked it up.


btw, i wonder if this will automatically trigger same behaviour in qt post-install…that looks really weird.

Possibly, but it will be a lot easier to test and tweak post-install then on the ISO. At least, I would prefer to handle it that way if it was me.

Yes, it’s GT 1030. Plus, as I say, I’ve been using it on another (Manjaro) system for the past three years.

While I know I can install the Nvidia drivers after the fact - shouldn’t this way ‘just work’?

What about other people who are new who think EOS won’t work for them because of this?

Why are Qt applications enormous?

I’ve been searching for all the error messages and combinations I could think of but I can’t find anyone else who’s had this issue. I must be somewhat unique…

Regardless, I’m going to get some food now since I’ve been at this for a while. Then I’ll install without Nvidia drivers and install them later and see what happens.

I’ll report back later.

Yeah that’s exactly why i assumed, Manjaro has older drivers packed in repos :wink:

It doesn’t seem to be an issue facing other Nvidia users so it is hard to say what is going on.

Since none of us have a GT 1030 to test with, there isn’t much we can do to fix it unless we discover what the issue it.

I should probably mention that if I remember correctly from those three years ago, I installed the Nvidia drivers after I first installed Manjaro.

1 Like

Unfortunately I don’t have the faintest idea what’s going wrong.
Could be related to the used qt theming setup in combination with your hardware and the nvidia driver… but this is very vague…

I could send you a link for some testing ISO using KDE for the livesession already… simply to see what happens if you boot this up with nvidia option ?

You can send me a PM if you would lime to try that.


I’ve had food and now back to this again. Reinstalling now but…

While I was booting the ISO, I noticed some messages coming up and it was taking longer than usual. When I squinted, I could just about make out the word ‘fault’ three or four times. Now, I have to reiterate this is an HTPC, so even though the screen size is quite large, it’s a fair distance away from where I sit and the text at bootup is quite small. So I’m exploring the possibility of there being a problem with the new card. I rebooted a few times with my camera at the ready but I never saw it again. Maybe I was just seeing things?


A pity - I have two of these. I’m so funny…

But wouldn’t any Pascal card be comparable? That would cover any card listed here:

It works fine here on a GTX 1080.

So that’s why I’m exploring whether or not I have a faulty card or if I was just seeing things during that one single time I was booting up.

However, that would not explain why only Qt applications were monstrously huge while everything else was perfectly normal. I would imagine a hardware fault would some sort of an all-or-nothing kind of situation.

you can share the bootlog from the live session: journalctl -b -0 | eos-sendlog but this can include some hardware related data klike serials uuids and stuff (general warning) should not be bad as it is the live ISO booting but if you mind send the url in PM instead of posting it public.

While I suppose it is possible that is an issue with hardware, that doesn’t seem like the most likely scenario.

However, it is possible it is a driver or software issue that only impacts a very small portion of devices or maybe only the GT 1030. It is hard to say. That is why I would install and then switch to the driver so you can try a few different things.

OK, comedy time!

I’ve reinstalled completely fresh. Then I installed the Nvidia drivers:

What you’re about to see is breathtaking. (This is after driver installation and reboot - I did not touch anything…)

The screenshots are off to the side for some reason but the whole of the screen is full - not with the black around it as in you see here.

Yeah, I think I should. This is perplexing but also funny.

What does env | grep -i qt show?

@joekamprad @dalto
It looks a lot like specifically fonts in qt are forced to be huge, unlike just scaling or something.