I'm not sure how to enable transparency on GNOME terminal

I’m quite new to EndeavourOS and Linux itself, and I wanted to make the terminal have some transparency, similar to how you could have a transparent terminal in the Windows Terminal app. I tried finding a solution on these forums, but I couldn’t find one ;-;. If someone could help me out that would be awesome :slight_smile:

If this is the stock gnome-terminal, then you can’t. You need to install gnome-terminal-transparency (Aur package). It will automatically remove the current gnome-terminal package.

5 Likes

The gnome terminal doesn’t support transparency.

You need to install gnome-terminal-transparency or gnome-terminal-fedora

4 Likes

Thank you!

1 Like

This happened while installing gnome-terminal-transparency. All I did was yay gnome-terminal-transparency and let it do its thing:

gnome-terminal-3.42.1/src/meson.build:172:0: ERROR: gnome.genmarshal keyword argument 'sources' was of type array[File] but should have been array[str] that cannot be empty

Am I making a simple mistake of some kind?

:point_up:

1 Like

I got a similar error installing gnome-terminal-fedora using yay -s gnome-terminal-fedora

gnome-terminal-3.42.2/src/meson.build:172:0: ERROR: gnome.genmarshal keyword argument 'sources' was of type array[File] but should have been array[str] that cannot be empty

Capital S…or just yay?

Did you use

yay -S gnome-terminal-fedora

or

yay -s gnome-terminal-fedora

You have to do -S

1 Like

You might post the error you are receiving on the AUR page and perhaps the maintainer can help.

1 Like

I did both for safe measure, and ended up getting the same result. I also used the “Add/Remove Software” app with AUR support to see if that would work, but I ended up getting the same errors.

:question:

1 Like

I did

yay -S gnome-terminal-fedora

I think he is referring to pamac

1 Like

I don’t have time to look at it deeply right now but I tried to quickly build both gnome-terminal-transparency and gnome-terminal-fedora and recieved the same error as you.

I don’t think it is something obvious you are doing wrong.

1 Like

If you don’t mind using a different GTK terminal, you may do what I like to do and install tilix terminal ( Github ). It’s essentially just like Gnome Terminal, but also includes transparency, overlay scrollbar, tiling, as well as other various features (absent in Gnome Terminal) that in my opinion make it overall a better choice if you use the terminal a lot. And it’s already in the Arch repos, so no need to grab something from the AUR if you don’t have to.

sudo pacman -S tilix

Then go to Preferences > Profiles > Color tab. To change transparency, just edit the transparency slider to your liking and you’re good to go. Hope this was helpful.

5 Likes

Thanks for the help!

1 Like

The solution to adding transparency to gnome terminal. . . Is to install tilix??

3 Likes

LOL - it is one potential solution.

:rofl:

That’s a general theme I’m noticing with GNOME: most issues with GNOME are solved by using something other than GNOME.

rofl

5 Likes