I3wm Feb 2021 feedback and noobs questions

Thought it would be good to have a thread to report questions or bugs about the recent update on EOS i3wm. So here it is. I had very few issues.

  1. I did not manage to install flawlessly and run xfce along i3w. I know it is not recommended to install two DE/wm at the same time but xfce and i3wm worked well together in the November version.

Just thought I mention it. First time I installed xfce and then followed the EOS wiki to install i3wm after the fact… I booted in i3 session and clicked mod+enter to open a terminal I got an error message and a background voice reading some kind of error message, a robot voice, really weird stuff.

Second try, I used the online installer selecting both i3wm and xfce. I still got problems with opening terminal and windows a bit buggy and error message ( something with DBUS, freedesktop, sorry failed to record this, was late night…). Did anyone manage to install them both?

I moved on already and installed only i3wm using the online installer then everything works flawlessly, it is really nice. Also the colors and status bar, really awesome!

Summarizing, I have a thinkpad t490s, xfce and i3wm worked side by side in November but not with the current version. I am running now only i3wm but am reluctant to try installing xfce alongside due to the problems I encountered above.

  1. can’t figure out the resize window keybinding, previously we used mod+r to go into resize mode then use arrows. Has this changed or could someone let me know what line I need to add in the config file, couldn’t find it. Appreciate it!

  2. no bug, sorry for the dumb question but how do you set battery/power suspend settings like in xfce, suspend after 20min after inactive desktop etc. in i3wm

:pray: i no install new EOS i3 … i found this (MOD+ f1 give you keybindings)

power management i use xfce power manager ( if that help )


# resize window (you can also use the mouse for that):
mode "resize" {
        # These bindings trigger as soon as you enter the resize mode

        # Pressing left will shrink the window’s width.
        # Pressing right will grow the window’s width.
        # Pressing up will shrink the window’s height.
        # Pressing down will grow the window’s height.
        bindsym j resize shrink width 10 px or 10 ppt
        bindsym k resize grow height 10 px or 10 ppt
        bindsym l resize shrink height 10 px or 10 ppt
        bindsym ntilde resize grow width 10 px or 10 ppt

        # same bindings, but for the arrow keys
        bindsym Left resize shrink width 10 px or 10 ppt
        bindsym Down resize grow height 10 px or 10 ppt
        bindsym Up resize shrink height 10 px or 10 ppt
        bindsym Right resize grow width 10 px or 10 ppt

        # back to normal: Enter or Escape
        bindsym Return mode "default"
        bindsym Escape mode "default"
}

bindsym $mod+r mode "resize"

https://github.com/endeavouros-team/i3-EndeavourOS/blob/master/.config/i3/config
edit…
might be old config :innocent:

3 Likes

You are the best, thanks so much! :smiley:

it works, but seems this was removed in the new config file.

1 Like

is the place for the new configs.

For the issue with installing i3 and xfce side by side i just have no clue… there are config for the xfce4-terminal for both, but they are similar, and would not cause an issue as far as i can see.

2 Likes

i try to reproduce on a install with both choosen…

1 Like

sound great, thanks! I will also check the github, I have an account but no experience giving bug reports etc. will check it out.

there is $mod+right mouse button to size now, a bit more easy to use impov.
i just re-add the old resize option commented to the config so in case you can uncomment it

1 Like

fantastic. I really liked the feature mod+R and arrow keys to size windows! I guess I already got used to the i3wm EOS workflow, I just discovered i3wm last winter using EOS.

2 Likes

i do just check to install xfce4 and i3 side by side in a VM, I do see only that gtk theme settings are set to default from vanilla xfce4 installation, but both starting fine and do work as they should here…

I will run one now on metal.

If I could I would also try it again, but my internet is super slow, it takes min 40-50 min to install EOS using the online installer. Speed of 1-5 Mb/s at home but more likely 800kb. :cry: and yes this in the U S and A. :laughing:

but i get now what you have… after setting xfce4 theme to EOS theming you got this error on open terminal under i3:


The reason is DEX
it seems to wrongly try to start some xfce desktop stuff… by disabling it in ~/.config/i3/config the issue disapere

exactly this one!

# dex execute .desktop files
exec --no-startup-id dex -a -s /etc/xdg/autostart/:~/.config/autostart/

is the culprit…
i do comment this line out and all is working fine…

what shows

ls /etc/xdg/autostart/
ls ~/.config/autostart/


this or something else there is causing some issue…

Ran installer feb xfce + I3wm. Both work. I3 after using arandr to set display on i3.

My understanding is that the problem appears when switching xfce to EOS theme and then login back into i3wm.

And here another suggestion, adding two lines for the brightness config on laptops. I think it is warranted since it is a basic feature, perhaps commented out since xbacklight does not seem to be installed by default, at least I had to install it to make my brightness button work.

Not sure how you prefer to do this, add this type of suggestion on github using a commit or discuss here first then add it if of interest.

think idea is EOS give you basics . if you need / want something you add ( make it your i3 )

Dev"s give you the start point … That my opinion (only) :+1:

3 Likes

Sure but keyboard volume and brightness function, I consider basic functionality. I also like to have EOS as light/vanilla as possible :wink:

Could be added but commented so only folks we laptops would use it. I suspect that the majority of people use laptops nowadays but I could be wrong.

i agree but you + i no build it :wink: so if need we add …

1 Like