I think I deleted my themes in grub

Hello I think I deleted my theme! I try to update my grub with

grub-mkconfig -o /boot/grub/grub.cfg

Could you please let me know how to grab it back I kind of miss it!

Screenshot 2022-11-11 at 18-32-44 Photo - Google Photos

Thanks you!

Exactly the same happened to me yesterday.
Take a look at my thread. @pebcak got the solution for me reinstalling the grub in chroot

2 Likes

Thank you! But in my case I can boot without a problem I just deleted the theme… Wonder if I have to delete and reinstall the all grub

1 Like

What shows

cat /etc/default/grub

?

Ah,

You want the grub theme back?

Have a look here or here.

1 Like

I am having the exact same issue as OP. I am also able to boot normally after pressing any key.

cat /etc/default/grub shows this:

# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="EndeavourOS"
GRUB_CMDLINE_LINUX_DEFAULT="amd_iommu=on iommu=pt loglevel=3 nvme_load=YES amdgpu.ppfeaturemask=0xffffffff"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/path/to/gfxtheme"
#GRUB_THEME=/boot/grub/themes/EndeavourOS/theme.txt

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
GRUB_DISABLE_SUBMENU=y

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.
GRUB_DISABLE_OS_PROBER=false

Few days ago someone suggested to comment out the THEME section because some EnOS package got removed from repos.

1 Like

Did you run sudo grub-mkconfig -o /boot/grub/grub.cfg after that?

You have to edit /etc/default/grub and then run sudo grub-mkconfig -o /boot/grub/grub.cfg

I am pretty sure that I did. Will do it again, and see if it helps.

@dalto that was the fix I guess :slight_smile: Thanks

2 Likes

so you were lucky :wink:
i did not run

sudo grub-mkconfig -o /boot/grub/grub.cfg

so i have to reinstall grub in chroot . but i surely learned from that mistake :upside_down_face:

I mean I didn’t run it few days ago, and got the error from above only today. But I was able to boot normally every time after clicking the error away.

Running sudo grub-mkconfig -o /boot/grub/grub.cfg made the error go away :slight_smile:

1 Like

Dear Pebcak

GRUB boot loader configuration

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=“EndeavourOS”
GRUB_CMDLINE_LINUX_DEFAULT=“quiet resume=UUID=96bf0989-6172-48b3-b3ac-7538084ef8f6 loglevel=3 nowatchdog”
GRUB_CMDLINE_LINUX=“”

Preload both GPT and MBR modules so that they are not missed

GRUB_PRELOAD_MODULES=“part_gpt part_msdos”

Uncomment to enable booting from LUKS encrypted devices

#GRUB_ENABLE_CRYPTODISK=y

Set to ‘countdown’ or ‘hidden’ to change timeout behavior,

press ESC key to display menu.

GRUB_TIMEOUT_STYLE=menu

Uncomment to use basic console

GRUB_TERMINAL_INPUT=console

Uncomment to disable graphical terminal

#GRUB_TERMINAL_OUTPUT=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo’

GRUB_GFXMODE=auto

Uncomment to allow the kernel use the same resolution used by grub

GRUB_GFXPAYLOAD_LINUX=keep

Uncomment if you want GRUB to pass to the Linux kernel the old parameter

format “root=/dev/xxx” instead of “root=/dev/disk/by-uuid/xxx”

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

GRUB_DISABLE_RECOVERY=true

Uncomment and set to the desired menu colors. Used by normal and wallpaper

modes only. Entries specified as foreground/background.

#GRUB_COLOR_NORMAL=“light-blue/black”
#GRUB_COLOR_HIGHLIGHT=“light-cyan/blue”

Uncomment one of them for the gfx desired, a image background or a gfxtheme

#GRUB_BACKGROUND=“/path/to/wallpaper”
GRUB_THEME=/boot/grub/themes/EndeavourOS/theme.txt

Uncomment to get a beep at GRUB start

#GRUB_INIT_TUNE=“480 440 1”

Uncomment to make GRUB remember the last selection. This requires

setting ‘GRUB_DEFAULT=saved’ above.

GRUB_SAVEDEFAULT=true

Uncomment to disable submenus in boot menu

#GRUB_DISABLE_SUBMENU=y
GRUB_DISABLE_SUBMENU=y

To enable usage of os-prober, set GRUB_DISABLE_OS_PROBER to ‘false’.

Note: enabling os-prober creates a potential security risk!

More info: https://www.gnu.org/software/grub/manual/grub/grub.html

GRUB_DISABLE_OS_PROBER=true

Yes I just miss the wallpaper at the back ground and for science I want to know how to get it back haha

So it looks like you have removed the lines related to EnOS Grub theme from /etc/default/grub.

If you want to get rid of the error messages at boot, most probably

sudo grub-mkconfig -o /boot/grub/grub.cfg

should help.

If you want to get the theming back:

Please click on here or here in the box above.

If you install the theming package again, You would need to add back the lines you deleted in /etc/default/gub and regenerate grub.cfg.

The theme has been removed from the repos but you can easily set a wallpaper with the wallpaper with

GRUB_BACKGROUND="/usr/share/endeavouros/splash.png"

That is our standard grub wallpaper.

3 Likes

There should be no need to chroot when changing a wallpaper or grub theme.

1 Like

Thank guys

Uncomment one of them for the gfx desired, a image background or a gfxtheme

GRUB_BACKGROUND=“/path/to/wallpaper”
GRUB_THEME=/boot/grub/themes/EndeavourOS/theme.txt

I got it back!!! legendary no needed to get to the chroot!

2 Likes

Glad you got it back and dont need to reinstall grub with chroot. In my case i couldnt boot so i need to chroot. In the end we are all happy :enos_flag:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.