I need some help with packages

Occasionally I use prepros for my work and I used it last time a month ago. Today I needed it and I couldn’t find it in my program list. I also tried to run it with “prepros” or “prepros-bin” in console without success.

Program is installed and I remember that it worked before. I ran it from all apications list If I remember correctly but I can’t find it there anymore.

[uros@Uros ~]$ pacman -Qi prepros-bin
Name            : prepros-bin
Version         : 7.8.5-1
Description     : Prepros compiles your files, transpiles your JavaScript, reloads your browsers and makes it really easy to develop & test your websites so you can focus
                  on making them perfect.
Architecture    : x86_64
URL             : https://prepros.io
Licenses        : custom:proprietary
Groups          : None
Provides        : None
Depends On      : bash  java-runtime  electron25  perl  lib32-gcc-libs  lib32-glibc  glibc  gcc-libs  zlib
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 261,99 MiB
Packager        : Unknown Packager
Build Date      : sre 26 jul 2023 19:42:01
Install Date    : sre 26 jul 2023 19:42:22
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : None

[uros@Uros ~]$ which prepros-bin
which: no prepros-bin in (/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)

I also noticed some packages I don’t know what they are:
Electron 18
Electron 19
Electron 22
Electron 24
Electron 25

Thanx in advance


pacman -Ql prepros-bin

That will list all the files. Look for a .desktop file or for files located in bin.

Electron is used by lots of applications but you probably don’t need all of those.

Try removing your orphans or check them pactree -r packagename

There are a lot of files in this prepross => klik but I can’t find any .desktop

It looks like it was removed in the latest version:


Is there another way to run it? Do I have any options or is better to look for an alternative?

It looks like they added a .sh file. Have you tried running that?

Which .sh file you mean? There are few .sh files but no one seems to be for start the program.

This perhaps: https://aur.archlinux.org/cgit/aur.git/tree/prepros.sh?h=prepros-bin

Currently I’m not at home to check it but I tried it on my EOS inside virtual box. I installed prepros and then searched for prepros.sh

I found that file inside “/home/uros/.cache/yay/prepros-bin”. Using that bash file I’m able to run prepros but I don’t see a point that I need to go to go to some cache folder find a bash script there and run it ?? Aren’t cache folder cleared from time to time?

Is there any particular reason for such approach ?

from what i see the PKGBUILD is not fully updated … maintainer removed desktop file but PKGBUILD still has a sed line that replaces the string “prepros %U” with “/opt/${pkgname%-bin}/${pkgname%-bin}” in the specified .desktop file… that is not there anymore… will be no issue if the rest is fine…

Problem with starting prepros with that bash file is that console must be open and if I close it, prepros also is closed. I hope this is fixed asap.

seems the source has a desktop file with it and this sed line was added after removing the custom desktop file… so should be still fine…

Last time I used I simply clicked on “prepros” link which was located under all aplications. Is there any good reason for removing it ?

just installed this and it it truely does not install a desktop entry…


I comment there for you :wink:

There is a .desktop file shipped with the .deb file from which this AUR package is build.

It has the following content:

[Desktop Entry]
Comment=Your Friendly Web Development Companion
Exec=prepros %U

You could try making the appropriate adjustment to the Exec line to point to the .sh file`.

Call the file prepros.desktop and put it under /usr/share/applications or ~/.local/share/applications.

See if it will give you a launcher in your application menu and it actually works?


for me it starts up when using the sh starter script… but install does not have this anywhere i start it from the yay cache…
PKGBUILD is not okay … it does not pack the sh file nor the desktop file in the package so boith are missing on target

I’m a noob in this field so I will just wait for an package update . I tried to add prepros.desktop where I changed value of exec to “/home/uros/.cache/yay/prepros-bin/prepros.sh”. Program was displayed in applications list but it didn’t start.

I started to looking at nodejs, node-sass, autoprefixer and cssnano to achieve what prepros does.


Exec=/bin/sh -c “/home/uros/.cache/yay/prepros-bin/prepros.sh”

Also add the following line:


and see if that will work.

Not sure actually if it should be Terminal=true or Terminal=false.

Try each, one at the time, if you are up for it.

Still doesn’t work. I updated Exec as you described and tied without Terminal option and Terminal =true and false)

I all cases a prepros icon is displayed for a second in deskbar.