I keep getting locked out of my account


I use KDE Plasma. When I lock my screen sometimes immediately after locking it I get locked out of it, with a message saying there have been 3 unsuccessful login attempts, when in fact there were none.
This persists onto the login screen outside of KDE Plasma. (the one you use to log into a specific DE, sorry I don’t know the technical name)
I don’t know if this is the cause, but this started happening around when I changed the login screen (SDDM) settings in KDE Plasma. Just changed the theme. (side note, nothing even changed visually on the login screen)

The questions I have are:

  1. Can I just… Turn off the login attempts thing? If so, how?
  2. What could be causing this? How can I fix it?

Do you have it set to breeze? Maybe change it back and then log out and back in.

1 Like

Yeah, changing it back seems to have fixed it, thanks

To start KDE Plasma without a display-manager (“thing”):

  • To start Plasma with xinit/startx, append export DESKTOP_SESSION=plasma and exec startplasma-x11 to your .xinitrc file. If you want to start Xorg at login, please see Start X at login.
  • To start a Plasma on Wayland session from a console, run startplasma-wayland [1]. Manually starting a dbus-session through dbus-run-session should not be needed [2].

This gives you the advantage of being able to update your system from a shell, and rebooting it from there before starting KDE via the startx command.
It is much faster than booting into KDE, then updating and then rebooting from KDE.

I did not mean the display manager. I meant turning off the login attempts thing, specifically, so that the system doesn’t lock up when I get the password wrong a bunch of times.

That thing is named as greeter, and it comes together with a display-manager. For KDE, it’s usually sddm-greeter.

You can auto-login without the greeter being displayed, if you wish.

I want the lockscreen, I want the screen to be locked, I just don’t want to be locked out for 10 minutes after 3 attempts. I tend to misspell things.

Well, you can say that out loud. :wink:

This was discussed on this forum yesterday, or the day before, including a given solution. :v:

For your service @drakonic , here it is:


1 Like


However, I would not set the value for the wrong attempts too high. Just a tip! In case the device is lost or otherwise falls into the wrong hands.

Edit the corresponding file.

LINK: faillock

Does that answer your question?

1 Like

If you use KDE Connect, you can add a command that will unlock the screen without a password:

loginctl unlock-session

FYI - I use a non-standard SDDM theme and have never been locked out. What theme were you using?

Please log out and try to log in again 3x with the wrong password. You will be locked for 10 minutes. The user would like to change this!

This has nothing to do with autologin or any DE but is a security measure that was introduced with SystemD. At that time the tool of choice was “faillog”. Long time ago.

I only mentioned this because it’s a way to get back into the system, and since the OP is using KDE Plasma, I figured KDE Connect would be a logical choice. Never mentioned auto-login, either. I am completely familiar with faillock and the 3x lockout limit.

1 Like

Was already mentioned above but this is probably not what the user wants to use. At least that’s how I understood it. Let’s see what he writes when he is back online.
No hard feelings. Your tip is certainly good and works.

But I can also understand him; why tinker if you can also solve the problem in principle.

It’s funny…the #1 reason I switched to KDE from Cinnamon was because of this exact-same problem: screensaver refused to unlock, had to go it as root and not only kill the screensaver process, but reset the faillock.

I totally agree on finding a true solution, that would be ideal.

1 Like

I do not use KDE. The devil take me before I give it another try. Hahahahaah :rofl: :rofl: :rofl: :rofl:

So I can’t contribute anything that is KDE specific.


If your issue was solved, please mark the post as solution that showed you the right direction. Thanks.

A theme called “Elarun”, I think.

As for the proposed solutions here - they do ease the user lock-out, but I was wondering if there was a way to turn it off completely. I suppose with an absurdly high attempt limit it would have a similar effect to being turned off.
Since my main issue has gone away, I suppose this question is just for curiousity’s sake now: is there a way to disable user lockout?

Yes, there is. The number needed is 0 (zero) for allowed login-attempts. It is in the ArchWiki that is quoted in the other forum-thread, I linked above:

Note: deny = 0 will disable the lockout mechanism entirely.