I deleted a config related to xorg :(

System info: https://0x0.st/HiYo.txt
So, so saw I this endeavouros article and followed it. I did had optimus manager but wanted to try optimus switcher. I followed the article
It told to delete configs

6a. Any conf file that deals with the keyboard, touchpad, or networking can stay. Anything else, you can manually delete. For example, if you have a conf file name 20-nvidia.conf , it needs to be removed. You can remove it by typing sudo rm /etc/X11/xorg.conf.d/20-nvidia.conf

I delete that config “20-nvidia.conf”, it fricked the display, plasma-shell, etc. I could still run application web browser, file manager, terminal worked fined. In wayland, everything was fine. Thats for the intel mode, in nvidia mode graphics don’t launch only tty.

Edit- also i tried ( nvidia-inst -n ) which was the solution for previously same problem.
I did kept the config as backup nothing by returning it back

I thought we got you through all this once already and had it working? :thinking:

Edit: What is the current problem? You reverted to nouveau and what is the issue? No output to a second monitor? What is the current status?

inxi -Ga

yes, I saw this article and wanted to try optimus-switcher. So yeah back to square one but atleast igpu works and on wayland everything works fines, atleast not that bad for me

edit-

inxi -Ga
Graphics:
  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0
    chip-ID: 8086:46a3 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile]
    vendor: Hewlett-Packard driver: N/A alternate: nouveau non-free: 525.xx+
    status: current (as of 2023-02) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:25a0 class-ID: 0300
  Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo
    bus-ID: 3-6:3 chip-ID: 04f2:b766 class-ID: 0e02 serial: 01.00.00
  Display: wayland server: X.org v: 1.21.1.7 with: Xwayland v: 22.1.8
    compositor: kwin_wayland driver: X: loaded: intel dri: i965 gpu: i915
    display-ID: 0
  Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
  API: OpenGL v: 4.6 Mesa 23.0.0 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes

well the current problem is that nvidia gpu is not working, when i switch to it only black screen and also xorg acts weird any way to reset it?

Please use code tags when you post output.

Why are you using lightdm on KDE again? KDE uses sddm and i wouldn’t recommend changing it.


hmm :thinking:

Okay doesn’t look like any driver id loaded. Please run this test and post the output.

nvidia-inst -t
System:
  Kernel: 6.1.15-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11 dm: LightDM
    Distro: EndeavourOS base: Arch Linux

:point_up:

nvidia-inst -t
2023-03-23 19:14:41: Info: Running: nvidia-inst v23-2
2023-03-23 19:14:41: Info: Command line: nvidia-inst -t
2023-03-23 19:14:41: Info: Selected mode: nvidia
2023-03-23 19:14:41: Note: Kernel parameter 'ibt=off' may be required, see https://wiki.archlinux.org/title/NVIDIA#Installation
NVIDIA card id: 25a0
Fetching driver data from nvidia.com ...
2023-03-23 19:14:44: Info: Installing packages: nvidia-dkms nvidia-utils nvidia-settings nvidia-hook
2023-03-23 19:14:44: Info: Removing packages: xf86-video-nouveau
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
COMMANDS TO RUN:
    pacman -Rs --noconfirm --noprogressbar --nodeps xf86-video-nouveau
    pacman -Syuq --noconfirm --noprogressbar --needed nvidia-dkms nvidia-utils nvidia-settings nvidia-hook
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Are you using the kernel parameter ibt=off first of all?

Edit: Post the url

cat /etc/default/grub | eos-sendlog

Please check if sddm is installed?

pacman -Qi sddm

yes, i am using ibt=off as the kernel parameter

this command is not working because i am using systemd-booter

Name            : sddm
Version         : 0.19.0-9
Description     : QML based X11 and Wayland display manager
Architecture    : x86_64
URL             : https://github.com/sddm/sddm
Licenses        : GPL
Groups          : None
Provides        : display-manager
Depends On      : qt5-declarative  xorg-xauth  xorg-server  ttf-font
Optional Deps   : None
Required By     : eos-plasma-sddm-config  sddm-kcm
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 4.44 MiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Monday 24 October 2022 06:59:29 PM
Install Date    : Sunday 12 March 2023 12:57:09 PM
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

[kd@kd-arch ~]$ pacman -Q | grep sddm
eos-plasma-sddm-config 22.03.1.2-1
sddm 0.19.0-9
sddm-kcm 5.27.3-1

If you are using systemd-boot then you have to do things differently. You have to add ibt=off in /etc/kernel/cmdline

Then run sudo reinstall-kernels

Also before this can you show me

systemctl status lightdm

I have already done that, :+1:

systemctl status lightdm
● lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; preset: disabled)
     Active: active (running) since Thu 2023-03-23 19:18:11 IST; 10min ago
       Docs: man:lightdm(1)
   Main PID: 721 (lightdm)
      Tasks: 4 (limit: 18754)
     Memory: 67.8M
        CPU: 5.678s
     CGroup: /system.slice/lightdm.service
             └─721 /usr/bin/lightdm

Mar 23 19:18:11 kd-arch systemd[1]: Starting Light Display Manager...
Mar 23 19:18:11 kd-arch systemd[1]: Started Light Display Manager.
Mar 23 19:18:14 kd-arch lightdm[949]: pam_unix(lightdm-greeter:session): session opened for user lightdm(uid=971) by (uid=0)
Mar 23 19:18:14 kd-arch lightdm[1028]: pam_systemd_home(lightdm:auth): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Mar 23 19:19:00 kd-arch lightdm[1028]: pam_unix(lightdm:session): session opened for user kd(uid=1000) by (uid=0)
Mar 23 19:19:39 kd-arch lightdm[2859]: pam_unix(lightdm-greeter:session): session opened for user lightdm(uid=971) by (uid=0)
Mar 23 19:19:40 kd-arch lightdm[2954]: pam_systemd_home(lightdm:auth): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Mar 23 19:19:48 kd-arch lightdm[2954]: pam_unix(lightdm:session): session opened for user kd(uid=1000) by (uid=0)

Okay lets get back to sddm.

sudo systemctl disable lightdm
sudo systemctl enable --now sddm

Edit: Then run

systemctl status sddm

Edit: Waiting for you :wink:
Edi2: Is there an issue?

Reinstall the nvidia drivers with.

sudo nvidia-inst 

reboot

Post

inxi -Ga

done, it works