I cannot create or delete files on an existing ntfs partition

Hello everyone, it’s probably something very silly to solve, but I’ve been reading on the internet for two days and I can’t figure it out.

I decided to take the leap and switch completely to linux, both on my laptop and desktop pc (although I still keep a ssd with the windows installation just in case).

In a new ssd I installed linux with Gnome DE. It works perfect, the problem I have is that I have another ssd apart (with ntfs partition) with all the files, photos, games that I saved before switching. Linux recognizes it and I can read it but it does not allow me to delete or write on it. it says that I can not do it because I am not the owner, which is root, then I added my user to the root group but it does not let me do it either.

The disk in question is mounted, in properties/permissions it says that the owner (root) and the root group can create and delete files, but I can’t do it.

I hope someone can help me, thank you very much.

Translated with www.DeepL.com/Translator (free version)

Take a look at this recent post:

2 Likes

I would suggest copying the files you want to keep, then unmount the drive and try format with gparted, gnome-disk or a similar tool.

Thank you very much! I’ll try to follow those steps and see if I have luck (I’m a newbie).
if I don’t succeed I will ask you again, TY

1 Like

uf … what a bad idea is this :wink:

1 Like

yes, I know it’s not the most recommended thing to do in the linux world, but I didn’t know what else to do. :sweat_smile:
I still don’t know what else to do really, I’m reading the Arch wiki that Dalto recommended me, but my English level is not very high and my Linux knowledge is not very good either. is there any way to do it through GUI?

https://wiki.archlinux.org/title/international_communities

You could try look it up in a language you are more comfortable with

1 Like

TY for the tip :wink:

1 Like

Some arch wiki articles are available in Spanish (and also other languages), normally the title will be the same but with _(Spanish) in it.

For example: https://wiki.archlinux.org/title/Main_page
In Spanish is: https://wiki.archlinux.org/title/Main_page_(Español)

You need to mount the ntfs partition with certain options. Read here for some starting points.

Thank you all for your help, the EndeavourOS community is truly fantastic! :heart_eyes:
The truth is that something difficult to explain is happening to me. Following the guides and tips that everyone contributed, I finally managed to be the owner of the SSD and get the read and write privileges but … still can not create, edit or delete files. in disk properties says I can do it, but the reality is that then does not let me. I will try to upload a photo to see if someone finds some logic.

Captura desde 2022-05-19 20-43-14
Captura desde 2022-05-19 20-44-31

Can we see the entry in /etc/fstab and the output of the command findmnt --real

Hi, Sure mate! and TY for help
I dont find the /etc/fstab

Captura desde 2022-05-19 21-11-29

Please don’t use a screenshot to post text output. Much of the output is cut off.

Instead of however you are mounting it, you should create a permanent mount in /etc/fstab as described in the wiki post I linked above.

It looks like the underlying filesystem is mounted read-only.

Are you dual-booting windows? If so you need to go into WIndows and disable “Fast Startup”

ok, sorry, I dont know how do it in only text format. can you teach me for the next time?

yes, I see it too, the arch wiki is hard to me, I used a gui app
Captura desde 2022-05-19 21-18-21

Did you read the part above about disabling fast startup in windows?

yes, I disable it in the bios/uefi menu before install Linux. I go to check it again.

That is not the same thing. “Fast Startup” is a setting in Windows.

Ups, my bad. I need to reconect the windows ssd and do it? and then reinstall Linux or something? sorry for all the noob questions, really sorry. Thanks for your help, and if it’s too annoying for you don’t worry, I’ll leave the disk as read-only until I get used to Linux and then format it to ext4.
I thought there might be an easy way to do it given my capabilities.

There is. Specifically, look for these two LINUX items:
Change Ownership
Fstab settings for NTFS

And this one setting for WINDOWS:
Go to: Control Panel > Hardware and Sound > Power Options > System Settings
and select “Choose what the power buttons do” from the left-hand side. Then uncheck “Turn on fast startup.”

Reboot