I am trying to setup triple boot, but it keeps failing

So on an MBR system I firstly installed Windows 10. Then what I did was I installed EndeavourOS on an extended partition. sda5 is the boot partition and mounted it as /boot, sda6 is the home partition and mounted it as /home, and sda7 is the root partition and mounted as / and it is encrypted. And it works fine. I am able to dual boot between EndeavourOS and Windows.

I have an issue though when I am trying to install EndeavourOS (as the third operating system) on a separate partition. I create another boot partition on on sda8 and mounted it as /boot and mounted sda6 as /home and on sda9 I created a root partition that is encrypted and mounted it as /.

The issue is that I can’t boot into the previous EndeavourOS installed operating system. I did not overwrite it nor even touch it during the installation process. I can boot into Windows and the newly installed EndevourOS but not the previous one.

Here is my current layout of my partitions.

I have installed grub-customizer and I am trying to add the previous EndeavourOS partition but it keeps failing to boot into it.

This is my previously installed EndeavourOS I am trying to put inside grub.

image

Here is the grub boot screen,

And here is the error message that i get when I try to boot into the previous EndeavourOS.
image

I am not too sure how to solve this. Any ideas?

I’m not sure if /vmlinuz is the right path. I believe that file lies in the boot partition. Same for /initrd.img
(I might be wrong)

This is how my boot sequence looks like

load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root='hd0,msdos6'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,msdos6' --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0,msdos6  36ca0a49-13dd-4ecc-a226-4645f4cba313
else
  search --no-floppy --fs-uuid --set=root 36ca0a49-13dd-4ecc-a226-4645f4cba313
fi
echo	'Loading Linux linux-lts ...'
linux	/boot/vmlinuz-linux-lts root=UUID=36ca0a49-13dd-4ecc-a226-4645f4cba313 rw  quiet resume=UUID=2e0bebde-5de9-44bd-810e-08db42d5d5dc loglevel=3
echo	'Loading initial ramdisk ...'
initrd	/boot/intel-ucode.img /boot/initramfs-linux-lts.img

Notice that the path are /boot/vmlinuz...

1 Like

I can give this a try but is it possible to use a GUI way?

If not then how would I find the UUID for any partition, including luks encrypted partition?

I’m just curious why you used a separate boot partition? I’m sure it would have just worked without it…

I am also fairly sure that it needs to ‘look’ in /boot to locate the boot files - and am not sure there is a GUI way to tell it to look there!, Os-prober (which is run by the grub setup) would have found it if boot was in the / partition…

Hopefully a grub expert will chime in here - my grub expertise mostly lapsed when grub2 came out!

1 Like

Try this command sudo lsblk -o +name,mountpoint,uuid
(Edit: I never worked with luks partition, so don’t know if the command is gonna work there)

When you are creating the entry for “EndeavourOS - XFCE”, in second screenshot, prefix /boot/ in the path of initial ramdisk and linux image. So they look like /boot/initrd.img and /boot/vmlinuz

Not sure if this will work, but no harm trying.

2 Likes

If I want to encrypt the root partition, then I need a separate boot partition, otherwise it will ask me for the decryption key before even showing the grub boot screen. I want to only prompt me for the luks encrypted password only when I click on to boot into EndeavourOS.

So I should replace /vmlinuz inside the Linux Image place with /boot inside grub-customizer?

Ah I see. So in that case I would need to specify which partition it is (i.e. /dev/sda5) or do I need to to just type /boot?

I suppose the old grub must have changed a lot?

Thanks.

I could give this a try, thanks.

1 Like

Sorry mate it still fails :frowning:

This is what I setted up. am I missing something such as Kernel params or something?


Try reading this

Otherwise we should wait for a grub expert to help/

Also, did you try unlocking the luks partition, mounting it and then running grub-mkconfig?

I will try, its a bit hard to understand but yeah I will try and get through it.

Through grub-customizer I removed that particular OS from the list (as it may interfere with the command) then I ran grub-mkconfig but it didn’t do anything sadly :frowning:

1 Like

Pardon me as you may know this already, but have you tried using rEFInd? I multi-boot Linux with it, although I ditched Windows so I don’t have to deal with that at boot. But, when I did multi-boot OS X, Win 7, and Debian back on my iMac years ago, I used the older program rEFIt, and it worked no problem.

1 Like

I have never heard of this before, is this a GUI software?

I thought with Apple PCs, it already has its very easy bootloader or something where you can easily put a third party OS on it or something?

It is not exactly GUI for setting up, and in fact requiresd a couple of minor tedxt file edits for non UEFI setups. For an idea of its use, look on the Wiki entry on here for:

I wrote that - so I am available if you want to try it, and need assistance :grin: - but I couldn’t call it a GUI…

3 Likes

Ah I see, it looks interesting I could give this a try. One thing though, I do have a UEFI firmware on my EEPROM, however, I am using MBR partition table rather than GPT. So do I still need these extra text files or additional setups?

Oh nice, I will give it a read then, thanks mate :slight_smile:

I am about to give it a try but I just wanted to point out something.

Shouldn’t it be yay -S refind?

I think because of UEFI, I had to use that with OS X when it came to Linux. You had Boot Camp to dual boot OS X and Windows, but I think that has changed. My iMac can only upgrade to El Capitan, unless I pull a hack. With El Capitan, I had to go into the terminal in OS X, and disable some security measures in order to use rEFInd. The iMac is cold right now, pulled RAM out and plan to order 8 gigs to replace it this week. This might be where I install NixOS, and shrink the El Capitan partition to around 50 gigs.

1 Like

Then just curiosu to know what is the point of using refind if you have bootcamp, does it support triple boot?

No it didn’t, it was only for Windows. It basically was a Windows installer, that prepped the HD and partition before you installed Windows. I think it was for Win 7 only, as I recall I couldn’t install 10 with it. I don’t use Windows at all anymore, no need for it really, unless I had to for dev purposes, but I am far from having any dev skills yet lol.

Sorry I missed this, yeah once you get the package from AUR (might also be in the regular repo), you then go into terminal and enter # refind-install (you don’t need the hashmark, just have it there to show it’s a terminal command) and then it installs and becomes default. If it doesn’t, or you want to make sure, the command is refind-mkdefault (check that first on the refind website, don’t want to frag your install). I’d read up on the refind website first. I partitioned kinda like you have, using an extended one that held two Linux builds, and with rEFInd, it was pretty seamless, although you may find older grub entries on it when it boots. I go into my bios and uncheck it when change a build for another (also to boot into the USB stick), and check back into it in bios, and I find the grub entry from the last build still there. I just carefully delete them in su.

1 Like