Huion Tablet Inspiroy H950P doesnt work (solved)

Hi there,
New Endeavour OS user here, migrated from Manjaro.
I am trying to get my above mentioned tablet stylus to work along with the pressure sensitivity. Unfortunately it doesn’t.
I have all the wacom driver and the digimend drivers (https://aur.archlinux.org/packages/digimend-drivers-git-dkms/)
and I followed the steps on this topic as well : Huion tablet

It still doesn’t work. Any help is appreciated.

Regards
Aurelius

“it doesn’t work” could be rolled out a bit more to show us what exactly you have tried, and what exactly is not working… what are the errors commands gave you… logs?

When I connect it, it connects fine and the tablet has mouse functionality. When I try to use the stylus it doesn’t work. I use an App called Xournal++, and the pen input is nonexistent without any pressure sensitivity as well.

What logs do you need ? I didn’t get any error commands, just the stylus refuses to be a pen.

I managed to get it to work. I did this by correctly assigning the devices in edit > preferences in xournalpp. Choosing the correct device assignment and checking “enable new input system”


PS: a small note, the laptop that I have Endeavour OS installed is a “Toshiba X-40E”. Not a Dell, The dell in the above pic (uses manjaro) was used to post on the forums while solving the issue on the Toshiba.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.