Htop in the LXQt desktop environment

Htop is one of my favorite little graphics apps, but I can’t start it on LXQt from the menu or panel. This is also interesting because it is Qt-based and works flawlessly on Debian Sid.

Isn’t htop a terminal application?

Are we talking about the same thing? It is qt-based?

1 Like

It must be a qt thing because it’s messed up in kde plasma also. I have to fix it in plasma but i don’t know how it is set up in Lxqt. In Plasma i had to create a directory and change file settings for htop in /usr/share/applications/htop.desktop and then copy it to the folder in ~./ local that i created.

Edit: It probably works from the terminal just not the menu.

It does work for me in terminal. Using lxqt as well :sweat_smile:
edit: can launch it from dmenu too. Doesn’t seem to work from the standard applications menu, or I am not using it right.

I had to ask how to fix it as it was frustrating me. :rofl: So on plasma in/usr/share/applications/htop.desktop file has to be edited.

This is on Plasma but it may be similar on Lxqt? Maybe?

Change: /usr/share/applications/htop.desktop

Terminal=true
Exec=htop

To:

Terminal=false
Exec=konsole -e htop

Then:

mkdir ~/.local/share/applications/

cp /usr/share/applications/htop.desktop ~/.local/share/applications/htop.desktop

2 Likes

Editing the one in /usr/share/applications/ is unnecessary. I just copied htop.desktop from there to ~/.local/share/applications/ and then changed this:

Terminal=true
Exec=htop

to this:

Terminal=false
Exec=xfce4-terminal -e htop

as you said and it works from the menu :slight_smile:

*the terminal needs to be adjusted to the one currently installed

1 Like

I Changed the file before i copied it over but what do i know? It works.

You changed it system wide, local files usually get the precedence

The local file is just user right?

Configuration files located in user’s home should work only for that user as far as I know. It doesn’t matter much I think if you are the only user on this system. I usually prefer to leave system-wide configs alone if possible…

1 Like

I’m not sure why it’s messed up anyway because on Plasma i just installed again and it’s still not working. Had to fix it! I just installed Lxqt and it is okay from the menu?

Edit: I just realized it has the xfce4 terminal plus whatever the other is but it works from the terminals and the menu.

lxqt shouldn’t have xfce4-terminal :thinking: It’s what I am using, because it’s so beautiful with new (well, new for me :smile:) EOS colors. I even took it to my bsd install and using there too :slight_smile:

QTerminal (I hope it’s spelled like that) is what should be put into the Exec line for lxqt installs…

1 Like

I don’t know I’m just saying both terminals are installed so xfce4 must have been added and htop works in both. I didn’t look at the settings i just tried it in the terminals and the menu and it all works.

Take a look at:
https://bugs.kde.org/show_bug.cgi?id=421374
and


Just tried to run htop from the menu and got this:
htop_error

I’ll wait and let upstream fix it.

1 Like

It’s a very easy fix. But i didn’t know where to start. It’s funny i never saw any info about it on Arch.
Edit: yes i see it say’s it’s fixed as of 05/14/2020 on version 5.71 but not sure what that is?

If you run kinfocenter It will tell you what KDE Frameworks Version you have. Mine is at 5.70. So the next update should fix it for me.

Amazing. One never stops learning. It never came to my mind to start htop from the menu. I didn’t even expect it has a launcher there. :joy:
But now as I tried to launch it from the menu I get the message that terminology (my standard terminal; belongs to Enlightenment) can’t be found. Using Plasma as DE.

This seems to be depending on DE and on terminal application.
I wrote a post on this 6 months ago: switching from Xfce to cinnamon.

Running htop from the shortcut in Xfce with Xfce terminal as default?
Worked.

Running it in Xfce with Tilix as default?
Works, but opens in Xterm instead.

Running it in cinnamon, period?
Doesn’t work until changing the start command to “terminalname -e htop” and uncheck “run in terminal”

1 Like

Unfortunately, 5.70 was just released a few days ago so 5.71 is probably a month or so away.

Does it read the TERMINAL env.variable to determine in which terminal to launch htop? Since it was silently failing in my case, I checked TERM and TERMINAL vars, and indeed TERMINAL wasn’t even set. I’ve set them both to /usr/bin/xfce4-terminal and it seems to be fixed, no .desktop intervention required :thinking:

edit: Although I am probably wrong. After several logging out and back in it doesn’t work again, even with TERMINAL set. And setting TERM to the current terminal was a bad idea :sweat_smile:

1 Like