How to watch Netflix on Microsoft Edge

If you hate reading like me, here’s the summary:

Open terminal (ctrl+alt+T) and type:

yay -S chromium-widevine

This will download a .deb package of Chromium (I assume because of dependencies) and then install Widevine. This will NOT INSTALL the Chromium web browser.

For context of how I came about this solution (spoiler, nothing genius): Widevine is needed to play DRM/Private/paid content on the browsers. It was a known issue that sometimes this could’ve been by default, disabled. For example on Firefox, sometimes you had to check the box of “Play DRM content”.
Going to edge://flags however, wasn’t the solution because for some reason, hardware encode/decode, hardware video acceleration, widevine and other stuff is “unavailable on your platform”, so you couldn’t enable/disable it from there.
According to a comment by the package uploader in the AUR:

Scimmia commented on 2020-05-18 20:20
This package is no longer needed for Chromium, it can download the component itself. With Chromium 81, you can either use this or let it download the component, but when Chromium 83 is updated in the Arch repos, it will ignore this package all together.
I’ll maintain this package for a while for the other systems that use it.

As you can see, widevine component should now comes directly with Chromium and because of this, I assumed chromium-based browsers as well, but maybe it was just Chromium browser and not the engine (this is perhaps why it has to download the .deb package).
This wasn’t “obvious” for my newbie mind because Firefox could play it just fine, and not just Endeavour, other distros as well, both Arch and Debian based (that is why I kept it installed). So I thought perhaps it was Edge’s fault alone. In a Ubuntu forum, people said to use the switch user agent string extension and that should work (switch to chrome) - however, not understanding how that works entirely, I got the extension but when you click on things it’s like… super old. It has Internet Explorer and Windows Phone, as well as Firefox 33. I didn’t want to mess with that and maybe you could turn it off (aka disable the extension) to go back to normal but what are you going to do, switch it back and forth? There’s no point. So I had my first idea as arch/endeavour OS user: “Someone must’ve done it!”. It occurred to me to search pacman and yay (repos and AUR) for widevine, see if there was something. And so here we are. Once you install the component, you don’t need to do anything else, not even enable the flags (which is still unavailable). Just close the browser and open it again just in case. Enjoy your Netflix watching! Hilariously enough it works MUCH better than on Windows. Pausing and pressing play, changing tabs or pausing for a long time don’t break the thing or make it work weird (at least that’s what happened to me through several versions of windows 10, 11 and different fresh installs). Hopefully this helped you :smile_cat: (and maybe this solution is also needed for other browsers, except Vivaldi which has its own component in AUR).


Although - if Chromium works why use Edge?


Perhaps a bit of a misconception here I’d like to correct. I use Vivaldi stable as my primary browser and it’s available in the main community Arch repos (as is vivaldi-ffmpeg-codecs), so you don’t need to install anything from the AUR in order to get Vivaldi working or playing media of any format, it will just work. Now if you’re referring to thevivaldi-snapshot that is beta software, (beta software is never included in Arch) so that is an AUR package, but that’s not to be confused with Vivaldi stable which Arch does support.

Microsoft Edge uses a non-redistributable license, so it’ll never be in the main Arch repos, it’ll always be an AUR package. For most users in the Linux open source community, we’ve tried our best to leave Microsoft behind, so installing and using their own proprietary browser kind of defeats that purpose. Most users are fine to use Firefox as one of the best open source options. If you need to use Microsoft products for work that’s understandable and if Edge is required by your work then that is your prerogative, but if it’s only for personal use, I don’t think you’ll find many Microsoft Edge advocates here (and that’s for good reasons).


Good clarification Scott, thanks.
And yes, I know this other side of the fence aims to leave all the enclosed ecosystems behind, and with good reason understandably so. I just thought that if there was anyone who would use it and encounter the issue, it would be good for future reference (for this and maybe other distros) to find the solution and perhaps make the switch easier for whoever does it.

It is for personal use and I have my reasons, but that is not the point of the post (I have used FF for years and tried Vivaldi as well), and is not my intention either to tell people what they should or shouldn’t use (not saying you did, I’m saying in general). It’s one of the great things I learnt in my personal journey coming to Linux and using duckduckgo instead of Google for a while. Cheers! :grinning_face_with_smiling_eyes:


Because that’s the browser I use. If Edge works, why use Chromium? (the why is subjective and I’d say most if not all reasons for both would be valid).

At the risk of re-hashing an existing thread that was closed recently, I’ll say this just in case you’re not actually aware of the considerations around software choices.

Because Edge is produced and maintained by a global corporation that is diametrically opposed to open-source principles and includes proprietary extensions to an open-source browser, and Chromium - being open source - is in the repos and works by default without additional packages?


… it really can’t be the purpose of our support channels that users who have installed closed-source apps and are mentioning or ask for support for those apps are being ridiculed or lectured for using it.

This is certainly NOT the vision we have for EndeavourOS. Just respect each other’s choices because EVERYONE should feel welcome on our channels and most importantly, feel comfortable asking for support, no matter if it is an issue in Firefox or Google Chrome.

Just keep the friendly vibe alive…


I definitely would have never known this to be true. I had to use widevine on Fedora, but other than that I don’t know I’ve ever needed it. I don’t even remember why I needed it.

1 Like

True. However, this was not a support thread. :stuck_out_tongue_winking_eye:

Post edited to make it clear where the quote comes from, though the reply is still to Stagger_Lee :wink:

1 Like

Just to clarify - those aren’t my words, they’re Bryan’s.

I do think they are good words.


Me too. I totally agree with what Bryan has said, he’s on point. It makes total sense.

I have the slight feeling that this post got misunderstood as me requesting help for it, instead of giving the solution (which I put first).


I have already made my conscious decision on what to use and what not to use and why.
I don’t do or say without my own critical approach, generally speaking, so if I am using X or Y, there’s a reason, not just because. So I am aware. That’s why I landed here on Endeavour :stuck_out_tongue_winking_eye: - Thanks though!


vivaldi-ffmpeg-codecs doesn’t include widevine support. There is an AUR package for that.

If your Vivaldi is capable of playing widevine encrypted content, then either you have another browser installed which pulled it in or Vivaldi fetched it themselves.


Hmm interesting. Well these are the only packages I have installed from the AUR (I didn’t see anything widevine related), but I am able to play Netflix videos just fine.

[scott@endeavourOS ~]$ pacman -Qm
archlinux-appstream-data-pamac 1:20211122-1
chrome-gnome-shell 10.1-5
gdm-prime 41.0+r15+g23ebe617-1
gwe 0.15.4-1
humanity-icon-theme 0.6.15-1
libgdm-prime 41.0+r15+g23ebe617-1
libpamac-aur 11.2.0-0
minecraft-launcher 928-1
nvm 0.39.1-1
optimus-manager 1.4-3
optimus-manager-qt 1.6.4-1
pamac-aur 10.3.0-1
papirus-folders 1.11.0-1
pika-backup 0.3.5-1
pop-gtk-theme-git 5.4.4.r13.g23d7ac83-1
popsicle-git 1.3.0.r45.g3ace3a8-1
python-hsaudiotag3k 1.1.3.post1-3
python-injector 0.18.4-1
python-isounidecode 0.3-3
python-pulsectl 1:21.10.5-1
python-py3nvml 0.2.7-1
python-pylyrics 1.1.0-2
python-pypresence 4.2.1-1
python-pysdl2 0.9.9-1
python-stagger 1.0.1-6
rhythmbox-plugin-alternative-toolbar 0.20.1-1
tauon-music-box 6.8.3-2
timeshift 21.09.1-3
ttf-ms-fonts 2.0-12
ttf-roboto-slab 3:2.001-1
wike 1.6.3-1
yaru-gnome-shell-theme-git 1:21.10.1.r50.g670a52f26-1
yaru-gtk-theme-git 1:21.10.1.r50.g670a52f26-1
yaru-gtksourceview-theme-git 1:21.10.1.r50.g670a52f26-1
yaru-icon-theme-git 1:21.10.1.r50.g670a52f26-1
yaru-metacity-theme-git 1:21.10.1.r50.g670a52f26-1
yaru-session-git 1:21.10.1.r50.g670a52f26-1
yaru-sound-theme-git 1:21.10.1.r50.g670a52f26-1
yaru-unity-theme-git 1:21.10.1.r50.g670a52f26-1
[scott@endeavourOS ~]$ 

When I type in the Vivaldi address bar vivaldi://components there is an option called “Widevine Content Decryption Module” which I have and say it is up to date. I wonder is maybe the OP doesn’t have than enabled/available for some other reason perhaps?

Edit: @latisullivan does this site help you in any way? - -

Edit2: I do not have chromium-widevine or vivaldi-widevine from the AUR installed, but I can still successfully watch Netflix videos. Now I did install Vivaldi stable before it was brought into the main Community Arch repos, so when I first installed Vivaldi stable it was an AUR package, so not sure if that package install is/was any different than the Vivaldi packages being installed from the main Arch repos or not, hmm.

To be clear, I wasn’t implying that you had a specific package installed. Either Vivaldi downloads the widevine stuff itself(This is what Firefox does as an example) or you have another browser installed with widevine support and Vivaldi is using that. For example, I believe Google Chrome is bundled with widevine.

1 Like

Yeah no worries I kind of figured that, I was just trying to provide an extra information I could think of to hopefully help. I only have Vivaldi and Firefox installed on my system. I’ve never installed Google Chrome or any other browser on my system for that matter. I guess maybe Vivaldi supports it out of the box now (not sure if that’s accurate), but I have been using Vivaldi and Netflix for at least the last 2-3 years between EndeavourOS, PopOS, and Solus and I can’t remember ever really having any issues.

I don’t think the licensing would allow it to be bundled but it could download it behind the scenes automatically.

Using the lovely pahis (in the EndeavourOS repos), when I installed Vivaldi, it didn’t pull anything else in that I can tell would be helpful, but here’s a brief log of the installs before and after I installed Vivaldi back in July of this year:

Run command: pahis --installed

[2021-07-25T19:13:11-0400] [ALPM] installed http-parser (2.9.4-1)
[2021-07-25T19:13:11-0400] [ALPM] installed npm (7.20.1-1)
[2021-07-25T19:13:11-0400] [ALPM] installed node-gyp (8.1.0-2)
[2021-07-25T19:13:11-0400] [ALPM] installed semver (7.3.5-2)
[2021-07-25T19:13:11-0400] [ALPM] installed nodejs-nopt (5.0.0-2)
[2021-07-25T19:13:11-0400] [ALPM] installed nodejs (16.5.0-1)
[2021-07-25T19:13:11-0400] [ALPM] installed c-ares (1.17.1-1)
[2021-07-25T19:13:11-0400] [ALPM] installed jq (1.6-4)
[2021-07-25T19:13:11-0400] [ALPM] installed oniguruma (
[2021-07-25T19:05:05-0400] [ALPM] installed vivaldi-ffmpeg-codecs (91.0.4472.114-1)
[2021-07-25T19:05:05-0400] [ALPM] installed vivaldi (4.0.2312.41-1)
[2021-07-25T19:05:04-0400] [ALPM] installed libxss (1.2.3-3)
[2021-07-25T18:57:50-0400] [ALPM] installed tilix (1.9.4-3)
[2021-07-25T18:57:50-0400] [ALPM] installed gtkd (3.9.0-12)
[2021-07-25T18:57:50-0400] [ALPM] installed liblphobos (2:1.26.0-4)
[2021-07-25T18:16:42-0400] [ALPM] installed linux-lts (5.10.52-1)
[2021-07-25T18:13:49-0400] [ALPM] installed nvidia-settings (470.57.02-1)
[2021-07-25T18:13:49-0400] [ALPM] installed libxnvctrl (470.57.02-1)
[2021-07-25T18:11:35-0400] [ALPM] installed pamac-aur (10.1.3-1)
1 Like

I wouldn’t be a package.

Well then I’m all outta idea :stuck_out_tongue: :sweat_smile: