How to stop password prompt for partition mounting from happening?

Every time I log in, I see this screen.


This particular partition is never mounted.
How to stop this from happening?

Easiest way in KDE:

  1. Open System Settings → Removable storage → Removable devices
  2. :white_check_mark: Enable automatic mounting of removable media

This is not enabled from the beginning.

What KDE is asking permission to mount a internal partition. I’ve tried “Start with a empty session” too, but doesn’t help. I’ve put the ~/.cache to ~/.cache.bak to get a new cache, but that too doesn’t help.

What about those 2?

image

To be clear, do you want it to be mounted without prompting you or do you want it to remain unmounted?

1 Like

I want it remain unmounted.

I don’t have problems in EOS XFCE.
But this problem was happening to me in my raspberry.

To fix it, I mounted it through fstab, maybe this method can help you.

To get the partition uuid, type blkid in terminal.

Then, edit /etc/fstab and set the partition, mount pount, and mount options.
In the example below, I’m mounting an ext4 partition with the nofail option.

Example of my external hardrive:
PARTUUID=705a1f2a-1c4d-4b3b-86ba-2ea1bb103583 /media/pi/external ext4 nofail,user,noauto 0 0

In case you need more details how to do it, type man fstab, or ask us here in the forum.

I also had to change the mountpoint permissions so I could have write permission…

Edit:
Noticed that you want the partition unmounted, you can add the noauto to the mount options in fstab.

Enabled, but greyed out.

Sorry, i’ve misunderstood what you wanted with that partition (thx @dalto for asking :laughing: ), so best would be:

This is sort of a bug. That window always comes after login, and I cancel it. It is bit of a headache, and it reminds me that something is wrong with the system.

fstab

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=5454-F005                            /boot/efi      vfat    umask=0077 0 2
UUID=3268aab1-568e-4707-9d9c-683e88391dea /              ext4    defaults,noatime 0 1
   /swapfile swap swap defaults 0 0

When you edit fstab, remember to type mount -a to confirm if the new mount point is working before you reboot the system, ok?

If it’s an internal drive, you don’t need the nofail option. (this is good for external drives, usb, nas and such).
If you don’t want an user to mount, only root, you can add the nouser.
The noauto option won’t automatically mount it.

man fstab will show you every possible option that you can set in the mount options

Hmm… I wonder which application it is that requires privileged access.
Is it some indexing app like baloo?
I don’t have a clue how to figure which app it is either, maybe clicking on the Details button will give the answer?

It requires privileges to mount the non-removable device.

How to get all the internal partitions to be mounted without prompting for the password? Maybe, that way this would go away.

I am not sure that is a good plan from a security point of view but if you want that you probably could add a polkit rule that allowed access to mounting.

The action id is org.freedesktop.udisks2.filesystem-mount-system

You can add the rule in /etc/polkit-1/rules.d

More information here:
https://wiki.archlinux.org/index.php/Polkit#Authorization_rules

Thanks. If I can’t find a solution to this problem, I might as well do that.

Several solutions have been presented. The fact you seem to have ignored them doesn’t make them any less of a solution (as well as being slightly rude to the people who are trying to help you).

2 Likes

Which one is the solution?

@chdsl

You are more than likely experiencing these problems due to the fact that you are triple booting windows opensuse and EndeavourOS.

This is also related… Spectacle is stuck in one window - #28 by chdsl