How to properly remove a winetricks dll?

I have used winetricks to install a DLL file for one of my proton prefixes to solve an issue. The issue was solved.

Now I am trying to unsolve it for some testing,and I have tried deleting and re-generating the proton prefix, I have gone to winetricks, change settings and set: alldlls=default

But something still clearly remains of this dll because the problem is still not recurring, (I know with 100% certainty that installing this dll is what resolved the issue, in short it was an error regarding gdiplus, so i installed gdiplus with winetricks, no more error, i did all the above steps to try and uninstall gdiplus, but still no error)

How am I actually supposed to do this? A web search turned up nothing except what i have already tried.

I remember having a similar issue with a dotnet package on another prefix, i deleted the prefix and re-generated it and dotnet was still somehow installed, to uninstall it i had to run the uninstaller in winetricks to properly remove it, wich is strange, where is it stored if it is not in the prefix? Is it just installed on all prefixes if i install it on one? I am so confused here.

How to remove things installed by Winetricks

It’s easy to install an entire wineprefix, so by default, winetricks installs each app into its own Wine prefix, and offers an easy way to remove wineprefixes and the menu items they created.

Winetricks does not provide a way to uninstall individual apps or DLLs inside a Wine prefix. This is for several reasons, but mainly because the preferred way to uninstall anything in Wine is to simply install into a fresh Wine prefix. (Yes, it would be nice to have uninstallers for everything, but I don’t need it myself. Patches welcome.)

If for some reason, you still don’t want to fiddle at all with your Wine prefixes, Wine does offer a built-in Uninstaller program. Like the Windows “Add/Remove Programs” applet though, it only recognizes programs installed by well-behaved Windows installers that respect the registry, like InstallShield or WISE. There are no guarantees it will work with a program installed by Winetricks or other installers like .msi packages.

That’s the official documentation. It says to just create a new prefix, but that doesn’t work.

First of all, unfortunately given windoze registry and all the complications of it’s architecture - yes it’s the only sure way.

Secondly, how come it doesn’t work?
You should phiscally remove your wineprefix and create a new one, where no winetricks exist.

I do not know, it might be a quirk of proton or something, I mean unless i’m wrong, /steamapps/compatdata/{game_id} is the prefix, and i delete that and re-generate it but things like dotnet and dlls seem to still be installed, (And yeah i have checked the obvious, like whether i’m really deleting the right prefix)

I think to troubleshoot this I need to know where winetricks actually install DLLs so I can delete them by hand, or does it use registry to link them up to the ones in /usr/lib/wine/x86_64-windows/ (or are those just the built-in ones?)

It auto-installs all the needed stuff for games, you don’t really control it.
At least in case it’s in Steam

Proton installs stuff the game needs, but it doesn’t use protontricks. This happens everytime it generates the prefix.

I never had to install anything, except one time an app for fallout 4 mods.

It’s practically impossible to remove a dll by hand, just like on windows. But you don’t need to do that, just delete the prefix and at next launch you get the default proton prefix for that game.

i’m using winetricks through steamtinkerlaunch, and proton isn’t perfect. Also I’m running a non-steam game so there’s no pre-existing profile for it.

1 Like

I don’t though, let me run an experiment yeah? I’ll create a new proton prefix, install dotnet on it (because it’s kinda hard to tell if dlls are installed or not, there’s no actual way to check… is there?)

then i delete the prefix and see if it’s still installed (this happened before)

Sorry that took a while cuz i was busy, but anyhow it seems deleting the prefix does in fact remove the things done by winetricks.

Now I’m only more confused really, because… The problem is not recurring but gdiplus is not installed :thinking: and installing it was what resolved the problem (it was literally the only thing i did, i didn’t try to change anything else at the time). Kinda mysterious.

Also it’s not really impossible to remove a dll by hand on windows, the things are installed somewhere, they either ship with the application or are buried somewhere in a subfolder of C:\Windows.

I have actually in the past had to manually install individual DLLs by moving them to i think it was C:\Windows\System directory. although that directory seems to be specifically for the purpose of installing custom dlls systemwide since it is empty by default (I’m guessing normally they would get dumped somewhere under system32)

But yeah i’m gonna just mark one of your answers as the solution, although my problem isn’t technically solved since i couldn’t reproduce an issue solved by installing gdiplus, by removing gdiplus… it appears after testing a bit more that it should actually be uninstalled, it kinda sucks that there is no real way to verify this properly since we don’t even know where these files are installed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.