How to login to Wayland in EndeavourOS KDE?

I am using EndeavousOS KDE. I noticed that I am running the X.Org session. How do I switch to Wayland? I could not find any such option in the login screen (SDDM).

1 Like

in the extreme lower left of sddm you should see

Desktop Session: Plasma (X11)

Click on that and choose Wayland

Pudge

2 Likes

Have you installed plasma-wayland-session?

To enable support for Wayland in Plasma, also install the plasma-wayland-session package. If you are an NVIDIA user, also install egl-wayland if it is not already installed, and if the session does not start with the proprietary nvidia driver, also enable the DRM kernel mode setting. If that does not work, too, check the instructions on the KDE wiki.

https://wiki.archlinux.org/title/Plasma#Plasma

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.