How to install kde from a sway install

How to install KDE from a sway installation ?
I did everything mentioned here, but when I run sddm, the comand stops immediately and gives back the prompt, no output at all. sudo sddm switches the screen to console 1 and makes the screen FREEZES and even sometimes a pitch black screen with a prompt, no console no nothing.
sudo startx or startx opens a bare black xserver with three minimalistic terminals.

I’m not saying archlinux is better or worse than others, but 10 years ago, with other distribs, I had no issue installing kde or whatever else desktop in one or two commands max. It’s become so disgustingly worse…

I don’t need kde, just a desktop still using xorg, because apparently nvidia-cuda won’t work.
I’ve tried that too:

pacman -Syu nvidia-utils --assume-installed xorg-server

makes no different whatsoever, I still have

drm@dr-80qr ~ (main)> nvidia-smi NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

You sound frustrated… Maybe you did some mistake, or a typo during the procedures.
For example,

There is no sudo sddm , but instead (from the linked article):

To be able to login to the KDE desktop environment on EndeavourOS|Garuda Linux, you are required to enable the sddm display server and network as below.

sudo systemctl enable sddm
sudo systemctl enable NetworkManager

Also, using sudo startx breaks your home account login.

That’s normal, if you have not setup anything locally. :person_shrugging:

1 Like

This might help somewhat:

I am frustrated.

[quote=“petsam, post:2, topic:37005”]

sudo systemctl enable sddm
sudo systemctl enable NetworkManager

I did that.

It is a fact that years ago I only needed one/two commands to install mainstream desktops. I didn’t have to care about enabling whatnot, alternative display managers would be proposed, cards would be recognized and corresponding drivers proposed, etc. Perhaps I had luck or debian was especially good, dunno…

Running sddm only gets me:

drm@dr-80qr ~ (main)> sddm                                                                                                       (base) 
[17:42:06.108] (II) DAEMON: Initializing...
[17:42:06.116] (II) DAEMON: Starting...
[17:42:06.116] (II) DAEMON: Logind interface found
[17:42:06.117] (II) DAEMON: Adding new display on vt 1 ...
[17:42:06.117] (II) DAEMON: Loading theme configuration from ""
[17:42:06.118] (II) DAEMON: Display server starting...
[17:42:06.118] (II) DAEMON: Adding cookie to "/var/run/sddm/{d3d20e32-f16d-4697-af7a-cb7aafea568f}"

Wrong usage. Run this:

sudo systemctl start sddm

This is Sparta Archlinux. Even if most things are configured automatically, a standard Archlinux user is supposed to RTFM when having difficulties. If you are not ready for this, it might be better for you to go back to a Debian-based distro. :person_shrugging:


Nvidia requires special handling to work on Sway. It is officially unsupported (see Sway wiki here:, but can be made to work if you enable KMS and launch Sway with the special flag.

From the ArchWiki page :

Note: All proprietary graphics drivers are not supported, including NVIDIA. After NVIDIA driver version 495, sway works if you enable kernel mode setting and run sway with --unsupported-gpu.

As for SDDM, I’m not sure if it is problematic to set it up from Sway, but they do note that Wayland is not supported yet. From the ArchWiki page:

Note: The Wayland windowing system is not yet fully supported: Wayland sessions are listed, but SDDM runs on X11. SDDM 0.20 will introduce full Wayland support.[1]

For what it’s worth, you do not need SDDM to log in to KDE.

I am not trying to run sway from sddm, but just to install the latter from the command line.
And I don’t get why it doesn’t work !
I had already tried sudo systemctl start sddm. no reaction, no output. prompt returns immediately.
Yes I know there is no love lost between those two groups, that’s why I try to install ANY desktop environment that is not reliant on wayland. although maybe the issue with nvidia relates to sway only, not wayland as a whole ?
In any case, how would you install kde and run it from the commandline ?

Yes, that’s right. Like I mentioned you need to launch Sway with the special flag for it to honor your proprietary GPU driver (the special flag used to be “--my-next-gpu-wont-be-nvidia:joy:), and you need to set up KMS. These conditions are specific to Sway, not Wayland in general. My understanding is Nvidia is reasonably usable on Wayland these days.

Installation is described here, in the ArchWiki:



Before installing Plasma, make sure you have a working Xorg installation on your system.

Install the plasma-meta meta-package or the plasma group. For differences between plasma-meta and plasma reference Package group. Alternatively, for a more minimal Plasma installation, install the plasma-desktop package.

To enable support for Wayland in Plasma, also install the plasma-wayland-session package. If you are an NVIDIA user, also install egl-wayland if it is not already installed, and if the session does not start with the proprietary nvidia driver, also enable the DRM kernel mode setting. If that does not work, too, check the instructions on the KDE wiki.

You can launch KDE from the TTY with startplasma-wayland or startplasma-x11.

Indeed. The problem is with SWAY. I ran the installation script after cloning the repository. And then my system, correctly configured to run Kwin with Plasma, suddenly lost the ability to run anything remotely plasma-y. Good thing I have Timeshift :slight_smile:

$XDISPLAY is not set or cannot connec to the X server.

startplasma-wayland works… But I don’t care, since I need a Xorg desktop.
Thanks for --my-next-gpu-wont-be-nvidia. I remember the time when this flag wouldn’t do anything save for infuriating users… This kind of behavior doesn’t bode well with me. Most users do not have the luxury to handpick their material. I don’t know which one is more at fault in this nvidia-sway situation, and honestly, I don’t care…

Sway isn’t intentionally trying to break your other DEs, it’s just not really designed to be used the way you are using it. Sway needs a very specific configuration to work correctly, with environment variables and other settings, and a lot of that stuff is set up differently than how it is done in KDE or XFCE or whatever. It is meant to be a standalone system, not something to layer with other DEs.

It sounds like Sway is just not what you want–I would recommend not using it. :man_shrugging:

i3 will work much better for your use case, and is very similar feature-wise. It also takes better to layering with other DEs, such as described here.

1 Like

I had no idea of those subtleties… Why such a design ?
People shouldn’t be bothered by extensive modifications when they don’t actually use Sway, and its authors disagree, they are wrong. Now I have my habits and my config, I can’t change… I am no developer so I can’t exactly spend half my day configuring things imho…
And more often than not, programs which I would find interesting or well-designed, or horrendous from a user standpoint and quite “unfinished”, so I’m stick with “what works” regardless of disagreements.
It’s just sad to see how uncooperative the atmosphere has become.

1 Like

That’s good to know! I assumed that I could, as I usually do, switch between Sway and my other DEs. No harm done since I have Timeshift, but I think a super prominent notice would be a good idea?

Normally, Linux is all about choice … so Sway took me by surprise!

1 Like

that’s why it’s borderline unforgivable… I advise them to make their own kernel and complete userland while being at it, and language, and anything to be sure it’s all THEIR way.
Huh, it reminds me of the whole “ethical source” debate… any relation perhaps ?
With their whole “it’s our way or the highway” attitude

1 Like

My experience has been that the more opinionated a DE or WM is, the more likely stuff will be broken if you try to combine it with something else. I feel like Sway is getting a lot of grief in this thread, but you can just as easily break KDE by trying to install Gnome on top of it. :eyes:

1 Like

I don’t agree. Choice is also deciding how to run a project. As long as the people behind Sway are prominently open about what it is, and what it isn’t, it’s fine by me. As long as I am free to choose not to use it.

People have the right to be a$$holes, is what you say ? Absolutely. And the right to be called names because of it. This attitude is toxic.
I do not want to use GNOME or anything on top of sway, but beside it. I find kinda hard to understand why anyone would have anything to say about it…
It’s not like I am using and promoting proprietary softwares for no reason, like… Linus Torvalds
Damn, this world makes so little sense…

1 Like

Looking at the actual SWAY, as opposed to the EndeavourOS community edition, I don’t see anything opinionated about it, except that it uses Wayland.

The wiki even mentions how you should instruct KDE/Plasma/Qt to use a Wayland rendering back-end instead of X11.
The community edition installation script doesn’t seem to take the fact that people might want to run different desktop environments into account, but I doubt that that is a problem with SWAY itself. I could be wrong, though.

We should set the Qt platform to Wayland, like this:


Things have changed a drastic amount just in the last couple of years. 10 years? You can’t even compare things. As mentioned, nvidia doesn’t play well with wayland. But it shouldn’t be too difficult to install on KDE. Your mileage may vary. Some folks it works well. Others, will be stuck on x11. You won’t know until you try. Sway is i3+wayland. . . so if nvidia works on sway, will again vary depending on how well your particular model works.

There’s a lot of distros out there you don’t need to do anything with. Actually, if you install EOS right out of the gate with KDE, it will be all setup, and you don’t have to do that. You may want to check out Debian though, that’s much older and may suit you better, but realistically, that’s probably even too new for your liking. You may just need to chalk it up to the good old days for you are gone, and that’s just the way Linux works today.

That’s just how it works and was written to work. You’d have to go back and ask a lot of people why, but it’s extremely unlikely anyone on this forum will be able to give you a better answer than “that’s just the way it is.”

You could also choose not to use it. . . You should see some really opinionated DE’s - pantheon for instance. Different strokes for different folks.

But, this thread is solved. @BluishHumility Solved it in post 7. It’s quite easy to install plasma. Just install it, start/enable sddm, and you’re pretty much all done.

1 Like

But I wanted to install kde with X11 and it still doesn’t work.
So “the way things are now” across the board in linux is… "things are more complicated ? huh, pretty much confirming my impression :cry: