How to install fre:ac CD ripper

Can’t get it installed neither with pacman nor AUR. :frowning: What am I doing wrong?
Or alternatively, is there a better ripper available?

honka_animated-128px-37

2 Likes

Dunno.
I have used the appimage version of it myself.
https://www.freac.org/downloads-mainmenu-33

1 Like

Thanks but I don’t use any snaps or flatpaks or what that stuff is called. Am an oldfashioned sudo/yay girl. All else makes me :woozy_face: :dizzy_face: :face_with_spiral_eyes:

What is the exact package name?
I don’t seem to be able to find it in the repos.

By the way, with appimage nothing gets actually installed on your system. It is an standalone portable app sort of.

Edit: Not in the repos, so pacman won’t do:

sudo pacman -S freac
error: target not found: freac

But it is in AUR:

yay -Si freac
:: Querying AUR...
Repository      : aur
Name            : freac
Keywords        : None
Version         : 1.1.6-1
Description     : Audio converter and CD ripper with support for various popular formats and encoders.
URL             : https://www.freac.org
AUR URL         : https://aur.archlinux.org/packages/freac
Groups          : None
Licenses        : GPL2
Provides        : None
Depends On      : faac  faad2  lame  libmp4v2  mpg123  libogg  opus  libpng
                  speex  libvorbis  libpulse  libgudev  boca
                  hicolor-icon-theme
Make Deps       : None
Check Deps      : None
Optional Deps   : None
Conflicts With  : None
Maintainer      : yochananmarqos
Votes           : 11
Popularity      : 0.052887
First Submitted : Mon 30 Mar 2020 08:32:02 PM CEST
Last Modified   : Sat 22 Jan 2022 03:36:54 AM CET
Out-of-date     : No

So the question is why you can’t get it installed using yay. Output from terminal might help someone to help.

Also >> https://wiki.archlinux.org/title/Optical_disc_drive#Audio_CD

2 Likes

Scripts? Can’t I just install a simple program with a command line anymore?

Hm, seems to work on my Manjaro desktop but not on my EOS lappy. :frowning:

1 Like

NO!
honka_memes-128px-40

P.S. Of course you can, but just not while :clown_face: watching :rofl:

2 Likes

I guess it’s just freac … and no prob, seems to work in Manjaro. Unfortunately my Manjaro desktop has no CD drive.
:grimacing:

1 Like

I tried it just for you, in EOS vm. And yes, it worked here. AUR version.
yay freac

local/freac 1.1.6-1
Audio converter and CD ripper with support for various popular formats and encoders.

Summary

2 Likes

Have a look at sound-juicer. It’s a simple, no frills cd-ripper.

Thx very much, guys, I got it figured out. Totally forgot I gotta install yay before I can use it. Manjaro is a bit weird about that,
:nerd_face:

1 Like

yay comes pre-installed on EnOS, so I wonder why it wasn’t there :thinking:

Anyways, glad you got it sorted out!

1 Like

I extract the appimage, delete out the garbage and have .desktop file in /home/my_user_name/.local/share/applications/ So, it is a “portable” install of sorts.

I am using 1.16 without any issues. I don’t use it for ripping, but only for format conversion.

2 Likes

That’s an interesting approach!

I did extract the appimage and it produced an squashfs-root folder with the following content:

ls squashfs-root/
AppRun   freac     lang                   libcdio.so.19       libssl.so.1.0.0          Readme
boca     freaccmd  libboca-1.0.so.3       libcrypto.so.1.0.0  manual                   Readme.de
codecs   freac.so  libcdio_cdda.so.2      libcurl.so.4        org.freac.freac.desktop  translator
COPYING  icons     libcdio_paranoia.so.2  libsmooth-0.9.so.0  org.freac.freac.png

I am not sure how to proceed from here. Would you mind to give me some hints?

1 Like

I just make a folder in my home directory. In my case I call the folder “Software” as I use this same approach for FF Nightly as I would rather update manually direct from mozilla and remove, pingsender, crash reporter , features, updaters etc…
In my case that squashfs folder is renamed Free_Audio_Converter and I deleted out items labeled “donate”, language files, translator, langnotify, I didn’t need, etc. freac should be made executeable…

My Free_Audio_Converter.desktop looks as follows ( I run Manjaro xfce and Endeavour and Arch VMs all xfce)

[Desktop Entry]
Version=1.0
Type=Application
Name=Free_Audio_Converter
Icon=/home/jrichard/Software/Free_Audio_Converter/icons/freac.png
Exec="/home/jrichard/Software/Free_Audio_Converter/freac"
Path=/home/jrichard/Software/Free_Audio_Converter
NoDisplay=false
Categories=AudioVideo;X-XFCE;X-Xfce-Toplevel;
StartupNotify=true
Terminal=false
3 Likes

Thank you @jrichard326! I appreciate it.

Here it is:

:handshake:t5:

2 Likes

Coz me was stoopit and forgot hubby is running Manjo on that old lappy. It’s so old it still features a DVD drive, that’s why I wanna use it to digitize some audio treasures.

1 Like