How to install EndeavourOS with old package like KDE 5.21 now?

I reinstalled my EOS today but KDE 5.25.3 has a noise bug (glitch and tearing random when extended display connected if it happen, I need unplug display and restart OS and reconnect display after logged in to fix it).
So Can I install EOS with KDE old version?
My hardware is so simple: Thinkpad T480 i5-8350U without nvidia card.

Hi and welcome to the forum!

EndeavourOS is a rolling distro, so it’s probably the worst one to pick if you need an outdated version of something so big as the desktop environment. It would be a total mess to even attempt that.


Technically you could but it would require building and maintaining your own version of all the KDE packages you use.

Have you tried using KDE with Wayland to see if that is better or worse?

Also, have you tried switching intel drivers?


Mostly technically… In practice, it would be an awful experience.

You could try to disable all desktop effects. Fn+F8 I think.

Yeah! I know that but I dont know what actually make this bug happen :frowning: Have you an idea for me to fix or log it? I tried to search and change Compositor settings but it’s not working :frowning:

If you have the knowledge to do it, it wouldn’t be that bad. It would just be time consuming and probably an enormous waste of time.

Well, whatever the solution is, trying to install an old version of KDE is certainly not it.

Probably faster to switch to xfce or other for a little while…

Edit: Or try lts vs recent kernel, it also fixed some glitches on certain hardware. For me it was Intel Xe on Thinkpad carbon.

I gave you two different ideas above, have you tried either of those?

1 Like

Is this a video problem or an audio problem?

yeah thanks you I think I dont have time to create my own so I will try switching Intel driver :smiley:

Welcome to the purple side! :smile:

As EndeavourOS is getting these (and most other) packages from Arch, and I assume Arch is directly copying the source code from KDE development,
I assume the best place to ask these kind of KDE questions is on the KDE forums.
They have the best knowledge and fixes about it probably.

EDIT: I don’t mean the downgrade question, but the actual fix.

Oh I dont record it before it like 2 skewed frames with small distance. I will record it when happen

In my experience, KDE Community Forum is totally useless. There is one user who regularly answers questions, and she seems to be fairly clueless (often not even understanding the question). Apart from her, that place is as dead as a door nail.

OK, didn’t know that, as I don’t use KDE… :wink:

Yes :smiley: Thanks your advice. :smiley: I very like EOS so I think change KDE version. I will report this bug to KDE :smiley:

Instead of that, I recommend you try out @dalto’s ideas: wayland and switching intel drivers.

His ideas are usually a good place to start, and more often than not, also a good place to end. :slight_smile:

In addition, instead of rebooting, try logging out and back in, as that’s much faster.

Or, you can try restarting the compositor when the glich occurs, with this command:

qdbus org.kde.KWin /Compositor suspend; qdbus org.kde.KWin /Compositor resume

If, by some miracle, that fixes the problem without having to reboot, you can make a keybinding that runs that command and just press it whenever the glitch occurs.

1 Like

oh wow! I understood and I will try it :smiley:
Thanks you so much!

1 Like

Some years ago, there was a fairly competent guy, rog131 (or something like that). claydoh is still there and pretty clued in. The one you mention does more harm than good.