How to get windows 10 to show up in grub bootloader

I have endevourOS installed on one SSD, and Windows 10 on the other. I don’t know how to get Windows 10 to show up in grub or even boot into it from my BIOS. No matter what SSD I boot from, I am always booted into linux. Even when I boot from the SSD that I know has the Windows 10 install. I also know that I didnt overwrite or wipe the windows drive because I can see it as an NTFS formatted drive in endevourOS with all of the standard windows folders.

As of now I have no way to boot into windows, and I need to because of a few games I want to play and my school apps. I dont want to wipe my endevour install, but if I have to I will because I do need Windows this coming week for school.

Try the following when booted into EnOS:


1 Like

Ive already tried this, no luck .__.

Please post the output of the:

sudo parted -l

sudo os-prober

Try mounting your Windows drive, then install and run grub-customizer:

sudo pacman -S grub-customizer

It should run the os-prober command @pebcak mentioned, and allow you to edit & save a new grub with Windows boot-loader inserted, all with an easy enough to use GUI.

It’ll also allow you to re-order the entries, and dictate which OS you want to launch as default if no option is chosen, as well as set a grub-timeout.

1 Like

There was a recent thread where the op didn’t find their Windows partition after the changes to /etc/default/grub simply because os-prober wasn’t installed in the system :roll_eyes:

Don’t you think that using grub-customizer is like hitting the nail with a sledgehammer?
There are numerous reports about issues with it. Mostly, I admit, from users who really don’t know what it does and how. That’s why they cannot revert the changes and run into various issues with Grub,

It’s an option, and one which has always worked for me ok :slight_smile:

1 Like

I understand that. I just wanted to point out that there might be certain risk involved in using that tool, like there is if one does not know how to use a knife.

1 Like

True :slight_smile:


this what worked for me.

sudo pacman -Syu
sudo pacman -S grub-tools
sudo pacman -S grub os-prober
sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like