How to force 2500 mbit link speed

Hi there
I have build new multimedia/TV/Nas PC. Moved from ubuntu to endeavour (im usining it on desktop sometimes) i like arch base os more :-).

But need help.
Old PC with realtel 8125B 2.5Gbit link to my 2.5Gbit xiaomi router was OK → full speed.
New PC with Windows and i225v3 2.5Gbit OK.

But after install and setting upp all stuff i found that on endeavourOS the link speed is only 1Gbit .
Where cant be problem when on windows worked OK (same PC) same cables →

Some info

Settings for enp2s0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supported pause frame use: Symmetric
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised pause frame use: Symmetric
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Auto-negotiation: on
Port: Twisted Pair
Transceiver: internal
MDI-X: off (auto)
netlink error: Operation not permitted
Current message level: 0x00000007 (7)
drv probe link
Link detected: yes

[ 19.573234] igc 0000:02:00.0: PTM enabled, 4ns granularity
[ 19.790084] igc 0000:02:00.0 (unnamed net_device) (uninitialized): PHC added
[ 19.906667] igc 0000:02:00.0: 4.000 Gb/s available PCIe bandwidth (5.0 GT/s PCIe x1 link)
[ 19.906699] igc 0000:02:00.0 eth0: MAC: 84:47:09:2a:ff:19
[ 21.873088] igc 0000:02:00.0 enp2s0: renamed from eth0
[ 44.888608] igc 0000:02:00.0 enp2s0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
[ 50.558454] igc 0000:02:00.0 enp2s0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
[ 608.021699] igc 0000:02:00.0 enp2s0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
[ 610.714896] igc 0000:02:00.0 enp2s0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
[ 930.977781] igc 0000:02:00.0 enp2s0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
[ 934.137783] igc 0000:02:00.0 enp2s0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX

description: Ethernet interface
product: Ethernet Controller I225-V
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: enp2s0
version: 03
serial: 84:47:09:2a:ff:19
size: 1Gbit/s
capacity: 2500Mbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi msix pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd 2500bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=igc driverversion=6.7.9-arch1-1 duplex=full firmware=1089:878d ip= latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:16 memory:74400000-744fffff memory:74500000-74503fff

and force the 2500 with sudo ethtool -s enp2s0 advertise 0x80000000002f dit not work …

Nobady any idea ? Waiting for new CAT6 cable if its in it but previous network card worked and even this system under windows works in 2.5Gbit speed.

well your whole network must be 2,5 Gbit will automatic negotiation set the speed to 2,5 Gbit afaik
Otherwise the lowest speed is applied

To force this go to you network settings ( i use xfce) and set link negotiation to manual and set the link speed to what you want?

Yeh i instaled LXDE version … (no need for desktop … still runing kodi over). But in som network manager that is inside i see only 100mbit , 1gbit , 10git … no 2.5Gbit

yes this is at my computer the same, but i have 1Gbit network adapter so i assumed that your 2,5 Gbit would be in that list

Most 2.5gb nic’s have only moderate driver support, at best. The i225v is one of the better supported ones, but still isn’t great. You may have a hard time reaching those speeds, even if you have a 2.5gb router and change it in settings.

There is a very good explanation on a recent episode from the 2.5 Admins (or wherever you get podcasts from) podcast.

Ok so where is problem.
Ubuntu server 23.04,23.10 and 24.04 with Realtek 8125 work out of box by dhcp auto conect no extra settings.
I225 must have better support over Realtek 8125b.
And endeavour has newer packages so theoreticaly better support.
Is the problem that causing the issue the gui network tool in lxde default install?
If so what to install to replace it?

Edit ; don’t want to go back to Ubuntu when everything else working (kodi with hw acceleration, samba server already configure, qbittorent server and others…)

With Linux the best Desktop Enviroments are Plasma (also called KDE) and Gnome.

For people that are new to linux i would recommend to install either Plasma (KDE) or Gnome as DE.

Plasma uses networkmanager, which has a 2,5GBit option. You could try if that works?

Edit 2: I mean install networkmanager in LXDE.

Edit 1: I have no knowledge of LXDE.

It’s not necessary to force the 2.5 GB option either. I don’t touch any settings in NetworkManager and I’m running 3 GB speed using a 10G Ethernet adapter and Cat 6A cable.


What happens if you set it to off

My NetworkManager settings are untouched.


That’s not horrible looking service. :stuck_out_tongue_closed_eyes: And I thought I wasn’t doing badly with symmetrical gigabit.

It’s on fibre optic to the modem.

1 Like

That’s what I have as well.

WiFi is much slower depending on the standard you are using and what hardware (WiFi Chip) it is.

Absolutely. Anyone who argues differently is either ignorant or trolling. Even Wi-Fi 6/7 cannot even come close.

Edit: I suppose I should have noted that my desktop is only via Ethernet. I don’t even have a WiFi chip on my motherboard. Was merely noting your brilliant connection. My ISP maxed out at the gigabit that I have and is better than the 25mb of my previous ISP. :laughing:

I’m getting the fastest speed available to my location. It was 1.5 GB. Now is 3.0GB. Eventually it might be 8 GB. It depends on the market what users are willing to pay for the service whether they bring it here. Most users have basic speeds of 50 Mbps

1 Like

Fiber was just brought to my area last October. There have been rumors that within a year, once the build out is complete, business accounts may be able to get up to 10gig. We’ll see…

Yes i can see that happening because they will be the ones who are willing to pay the price for it. Most average users don’t care about speed as long as it works. It’s hard going back once you have the faster speeds. :wink:

Edit: I used to have 500 Mbps when fibre first came out. (2011) Now they have newer modems and faster speeds with software upgrades also.

1 Like

Absolutely. I just found out about a month ago, from the project manager overseeing the build out, of the first 1000 customers to sign up, I was the second to choose gigabit. One choose the midrange and everyone else choose the 75mb. I was traveling for work this week and was desperate to get back home to my service. :rofl:

1 Like