How to force 2500 mbit link speed

I guess we’ve slightly diverged from the OP. Back to the point, I have the same NIC, with a 10 gigabit router and cannot get 2.5 speeds on my LAN.

In my opinion it makes a huge difference in updating. The number of issues and problems are substantially less. I still find times when i know that the mirrors need updating. You get to know when an update fails. You can see package errors that don’t get downloaded or are corrupted. I usually update the mirrors and re-run the update and all is good.

I was just thinking about that same point yesterday whilst responding to another user on the forum here. It really does make a huge difference and why I think Internet service should be a public service and quality available to everyone and not this patchy system most people have (regardless of country you live in).

Sure… I’m using an add in card that is 10 GB and i know the Intel Ethernet chip is not the greatest.

Device-1: Aquantia AQtion AQC107 NBase-T/IEEE 802.3an Ethernet [Atlantic
    10G] driver: atlantic v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 4
    port: N/A bus-ID: 23:00.0 chip-ID: 1d6a:07b1 class-ID: 0200

MSI Board has only 1 GB Ethernet port so i upgraded to the add in card in order to get the 3GB speeds along with Cat 6A cable.

Device-3: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI X570-A PRO driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 27:00.0 chip-ID: 10ec:8168
    class-ID: 0200
1 Like

I was always under the impression that Intel NICs were better supported than Realtek?

I’ve got an MSI board that came with the 225v onboard. I’m already thinking of upgrading to a SFP NIC and 10g adapter. And I just built this a month ago. :man_facepalming:t2:

I guess eventually I’ll try out this new board with the 2.5 GB Ethernet port and I’m sure it’s a realtek but one never knows. Then we’ll see if it’s any good. It should run on the r8169 kernel module but well see. Not in a hurry yet to build it just have parts waiting.

Well, always fun to have a project in waiting.

From what I’ve read, I thought the 8169 module is one of the better supported ones?


So it seems this Intel adapter does have some issues.



1 Like

Yeh i see.
New cable still not arrived.
But creating dit not help (i dont have any files in /etc/systemd/network/)

i created file contaning

MACAddress=my lan mac adress

NamePolicy=kernel database onboard slot path

Command : sudo ethtool enp2s0 autoneg off
and sudo ethtool --change enp2s0 autoneg off
Dosend do anything.

So the problem is network manager
After stoping and disabling networkmanager.service
and run sudo ethtool -s enp2s0 speed 2500 duplex full

Network runs at 2.5Gbit :slight_smile:

But Im not sure what hapen after reboot … what replace the network manager (i will remove it) and how to force the 2500 after reboot ?

These may help you. From the Arch wiki.

Network Configuration

Network Managers

If you remove NetworkManager, you’ll need to replace it with something else.

I’m using Network Manager and i have no issues. No settings have been altered. It’s stock install of EndeavourOS Kde Plasma.

1 Like

Maybe just stopping and restarting NetworkManager may have worked. I don’t make any changes on NetworkManager on Kde Plasma or any other network settings.

I’m the same. I’ve made no changes to my install, except minor UI, everything else is stock. The OP just said they were going to uninstall and I made some suggestions, that may or may not be helpful.

I agree with your following reply. systemctl restart NetworkManager.service should be all that’s needed.

No I try restart before it’s not enough.
Network manager block the changes by ethtool.
Buť if I disable network manager, then made changes and start network manager again it’s running 2.5gbit.

So solution is sh skript running after start, that will disable networkmanager service, made ethtools changes and start networkmanager…
But that is not nice.
There must be better solution…

For network manager, remove it and set Lan setting directly to /etc/network/interfaces… Still supported under arch? I have it in Ubuntu but I needed to remove netplan.

Litle hope that if the network manager will not create trouble the operation with ethtool will not be needed.

This does not make sense. You should be able to use ethtool and NetworkManager together. In fact, you can even use NetworkManager to configure ethtool. Something else must be going on here.

Any changes to default setting from lxde install from my side except adding on it (kodi, ssh, samba…).

I missed this the first time I read your post. Unless you have changed something since posting this, this is part of the problem. It is set for auto-negotiation and it is detecting that 1000mb/s is that max that your network is able to negotiate. It is NOT a problem with NetworkManager.

Further down in information you provide, it also confirms this.

What is the speed of your WAN connection?
What is the speed of the router the PC is connected to?
What is the output of sudo ethtool -i enp2s0?

Yeh I know that is the problem.

And again if somebody don’t read.
My network is 2.5gbit. My computer is conected by 2.5gbit. My old multimedia centrum was conected by 2.5gbit (realtek network card). This new multimedia centrum under windows runs in 2.5gbit.

Now it’s runs by 2.5gbit. After forcing it.

I will post new ethtools out up later but after forcing the setting.

Restart will performe later (now kids watching tv so can’t play with it :-))

So yes it’s problem in linux and because after disabling networkmanager and forcing the speed… Works… It’s in networkmanager or it’s applets.

And from what I have read over internet - it’s definite networkmanager fault… Because it miss 2.5gbit and 5gbit settings.

So now I understand why Ubuntu moved to netplan (even that I hate it and replace it :-D)

:+1:t5: No problem, Better to not disturb them if they’re happy.

I understood that this had been a Windows device and has been changed to Linux. If I was mistaken and this is a dual-boot device with BOTH windows and linux, this is a known problem and has nothing to do with NetworkManager or EOS - it is because of Windows. From what I have read elsewhere, the problem will return every time you reboot. It is fairly easy to search online and see many people with this network card have the exact problem you describe on Ubuntu, Fedora, Manjaro and others that dual boot with Windows.

I can confirm what @ricklinux says above, NetworkManager does not have a problem with the 2.5gb. I have the same network card as you, Intel I-225v, on my motherboard and NetworkManager sees 2.5gb.