How to enable fingerprint support in kde 5.24?

I have installed fprintd but still not able to see anything related to fingerprint in System Settings. There’s no tut on how to do this is KDE.

$ lsusb | grep FingerPrint                                                                                                                                                                       
Bus 003 Device 003: ID 27c6:538d Shenzhen Goodix Technology Co.,Ltd. FingerPrint

Read:

https://wiki.archlinux.org/title/Fprint

@ricklinux Thanks a lot. I know about this project. But what about kde 5.24 integrated fingerprint support?

@PeterRies Can you guide a little here or I have to used fprint only?

There are a large number of devices that don’t work with lifprint. Not sure about this feature. I can’t test it right now. Here is a list of possible unsupported devices for fprint. Drivers may become available or not. :man_shrugging:

https://fprint.freedesktop.org/supported-devices.html

Edit:
It is my understanding you press enter on the login screen and then use fingerprint.

Edit2: Need to edit

 /etc/pam.d/sddm
auth     [success=done ignore=ignore default=bad] pam_selinux_permit.so
auth        sufficient    pam_fprintd.so
auth        substack      password-auth
-auth        optional      pam_kwallet.so
auth        include       postlogin

Edit3: Could also be maybe?

auth        sufficient  pam_fprintd.so
auth        include     system-login
account     include     system-login
password    include     system-login
session     include     system-login

Edit4: You may only need to add auth sufficient pam_fprintd.so

Every distribution the sddm is not going to be exactly the same. This is just what i read.

Edit5: Best to follow the Arch wiki here:
https://wiki.archlinux.org/title/Fprint#Installation

Yes you are right. My reader on a latest 2021 dell inspiron 15 laptop isn’t supported. Typical linux problem.

Thanks a lot for your time.

As I’ve been mentioned and raised a similar question before…

First I have a Lenovo Thinkpad T14 Gen 1 that needed a BIOS update in mid 2020 some weeks after it came to market.

After this fingerprint reader was detected.

Now with endeavour I installed “fprintd” and modified two files in /etc/pam.d (first two lines matter)

For fprint with sudo I have:

$ cat /etc/pam.d/sudo                                                                                                                             
#%PAM-1.0
auth                    sufficient      pam_unix.so try_first_pass likeauth nullok
auth            sufficient      pam_fprintd.so
auth            include         system-auth
account         include         system-auth
session         include         system-auth

For lockscreen unlock I have:

$ cat /etc/pam.d/kde
#%PAM-1.0
auth                    sufficient      pam_unix.so try_first_pass likeauth nullok
auth            sufficient      pam_fprintd.so
auth            include         system-login
account         include         system-login
password        include         system-login
session         include         system-login

then you’ll get the fingerprint AFTER pressing “Enter”. I tried the “aur/pam-fprint-grosshack” package that should provide Keyboard AND fprint at the same time but that didn’t work…

SDDM is being skipped with autologin on my machine as I’m the only user and the whole system is fully encrypted so asking for a login password doesn’t make sense imho.

@PeterRies Thanks a lot for repying. My question is if this method works even if the driver is not in supported list??

lsusb | grep FingerPrint                                                                
Bus 003 Device 003: ID 27c6:538d Shenzhen Goodix Technology Co.,Ltd. FingerPrint

Also what’s all the fingerprint stuff in kde 5.24. can’t find it anywhere in settings only in the articles.

Thanks a lot.

I was looking for the place where magic happens as well when 5.24 was released.

If your device gets detected you can install fprintd and then go to settings → users(!).

After selecting your user you should see a button “Configure Fingerprint Authentication” where you can enroll fingers via GUI.

If you haven’t got this button your hardware might not be supported.

Confusing for me was that after enrolling my fingerprints there it wasn’t of any use unless I added my lines (see abouve) in some files in /etc/pam.d

Screenshot from user interface (German GUI) where button should be…
image

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.