Upgraded to 5.24 with fingerprint but no lockscreen or sudo unlocking

Hi all,

I upgraded this morning to 5.24 and was happy about fingerprint support. I had to install fprintd first and configure my user to use them.

But even after reboot neither lockscreen nor sudo is “unlocked” with my fingers do I have to adjust sth. in pam.d files, too? I thought this would have been done with upgrade to 5.24…

Meanwhile I tried to add pam-fprint-grosshack (password AND fingerprint at the same time) to /etc/pam.d/kde and sudo files. But it did weird things like “invisible command input” in konsole after sudo + fingerprint. lockscreen does not work at all. So I removed pam-fprint-grosshack and enter my password like before.

Any hint welcome :wink:

Hello, I am currently stuck at the same point you are. I managed to get to the point where I can enroll a fingerprint but no matter what else I’ve tried I can’t get a fingerprint prompt when logging in or any other time.

I found something related to this in KDE Forum.

1 Like

Hi madduke. I wrote my “experience” here.

2 Likes

Thanks for that but I can enroll a fingerprint. I just can’t ever get a prompt use to unlock anything.

Yeah that is pretty much where I got stuck too. I can enroll a fingerprint, just can’t use it!

You adjusted both files as mentioned in my posting? (for lockscreen and sudo)

If so then you still need to press [enter] with no password before the fingerprint prompt shows up…

In my case for a sudo it looks like this…

  1. command with sudo
  2. no password, just enter
  3. “Please put finger on fingerprint reader” (or similar in English)
    image

I never see any prompt for the fingerprint. I had tried hitting enter but that just froze thee machine briefly before failing.
I’m going to go through your config again and verify that I got it right.
I appreciate your help btw, thank you.

You’re welcome :wink:

You should also have a look if there’s a BIOS update for your machine. My Thinkpad didn’t work properly before I upgraded. Was a brand new Laptop series that time…

1 Like

I’m running a Framework laptop and I’m at the current BIOS version (3.07). This hasn’t been a major concern for me because I can live with the fingerprint reader but I would like to get it going at some point. Thanks again.

1 Like

Well some good news. I had some time to fiddle with it today and I can now log in with my fingerprint. Sudo still isn’t working but progress has been made!

My config files weren’t all that different than yours but I guess they weren’t close enough!

Thanks again for your expertise.

1 Like