How do I run Plasma5 on Wayland?

Guys, I am wondering what to do to run plasma5 on wayland rather than xorg.
I have installed plasma-wayland-protocols, plasma-wayland-session, I can select plasma on wayland in the sddm login screen, but when I enter and confirm my password, I do not get to a graphical environment, in fact, it seems that nothing at all happens after logging in in sddm.
Any ideas?
J.

What’s the output of

yay -Qs wayland

I just installed plasma-wayland-session and logged in and is working.

Edit:

[ricklinux@eos-plasma ~]$ yay -Qs wayland
local/kwayland 5.79.0-1 (kf5)
    Qt-style Client and Server library wrapper for the Wayland libraries
local/kwayland-integration 5.21.2-1 (plasma)
    Provides integration plugins for various KDE frameworks for the wayland
    windowing system
local/kwayland-server 5.21.2-1 (plasma)
    Wayland server components built on KDE Frameworks
local/libva 2.10.0-1
    Video Acceleration (VA) API for Linux
local/plasma-wayland-session 5.21.2-1
    Plasma Wayland session
local/qt5-wayland 5.15.2-1 (qt qt5)
    Provides APIs for Wayland
local/sddm 0.19.0-3
    QML based X11 and Wayland display manager
local/wayland 1.19.0-1
    A computer display server protocol
local/wayland-protocols 1.20-1
    Specifications of extended Wayland protocols
local/xorg-xwayland 21.0.99.902-1 (xorg)
    run X clients under wayland
[ricklinux@eos-plasma ~]$ 

Edit2:

[ricklinux@eos-plasma ~]$ echo $XDG_SESSION_TYPE
wayland
[ricklinux@eos-plasma ~]$ 

Check the logs and see if something is failing when you try to login.

<[jeannie@p707 ~]$ yay -Qs wayland
local/egl-wayland 1.1.6-1
EGLStream-based Wayland external platform
local/kwayland 5.79.0-1 (kf5)
Qt-style Client and Server library wrapper for the Wayland libraries
local/kwayland-integration 5.21.2-1 (plasma)
Provides integration plugins for various KDE frameworks for the wayland windowing system
local/kwayland-server 5.21.2-1 (plasma)
Wayland server components built on KDE Frameworks
local/lib32-wayland 1.19.0-1
A computer display server protocol
local/libva 2.10.0-1
Video Acceleration (VA) API for Linux
local/plasma-wayland-protocols 1.1.1-1
Plasma Specific Protocols for Wayland
local/plasma-wayland-session 5.21.2-1
Plasma Wayland session
local/qt5-wayland 5.15.2-1 (qt qt5)
Provides APIs for Wayland
local/sddm 0.19.0-3
QML based X11 and Wayland display manager
local/wayland 1.19.0-1
A computer display server protocol
local/wayland-protocols 1.20-1
Specifications of extended Wayland protocols
local/xorg-xwayland 21.0.99.902-1 (xorg)
run X clients under wayland
[jeannie@p707 ~]$>

As far as I can see, the kwayland components are missing.

yay -Qs kwayland
local/kwayland 5.79.0-1 (kf5)
    Qt-style Client and Server library wrapper for the Wayland libraries
local/kwayland-integration 5.21.2-1 (plasma)
    Provides integration plugins for various KDE frameworks for the wayland windowing system
local/kwayland-server 5.21.2-1 (plasma)
    Wayland server components built on KDE Frameworks

Please post command outputs in code tags (</>). It’s much easier to read.

Edit : Missed those because of the formatting. You have those installed.

What’s the output of inxi -G
You might have to install inxi first. Not sure about that one.

The three mentioned kwayland packages are installed.

[jeannie@p707 ~]$ yay -Qs kwayland
local/kwayland 5.79.0-1 (kf5)
   Qt-style Client and Server library wrapper for the Wayland libraries
local/kwayland-integration 5.21.2-1 (plasma)
   Provides integration plugins for various KDE frameworks for the wayland windowing system
local/kwayland-server 5.21.2-1 (plasma)
   Wayland server components built on KDE Frameworks
[jeannie@p707 ~]$ 

1 Like

Just edited my previous post. :wink:

[jeannie@p707 ~]$ inxi -G
Graphics:  Device-1: NVIDIA GP106BM [GeForce GTX 1060 Mobile 6GB] driver: nvidia v: 460.56 
           Device-2: Chicony Chicony USB 2.0 Camera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: loaded: nvidia unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~75Hz 
           OpenGL: renderer: GeForce GTX 1060/PCIe/SSE2 v: 4.6.0 NVIDIA 460.56 
[jeannie@p707 ~]$ 

Maybe this helps?

http://blog.davidedmundson.co.uk/blog/running-kwin-wayland-on-nvidia/

https://community.kde.org/Plasma/Wayland/Nvidia

Huh. Kernel parameter modifications? Never done that.
J.

Might be interesting to have a closer look at

cat /var/log/Xorg.0.log

Maybe we can see some more information what is going wrong.

I must say I am impressed. Wayland is running flawless so far on my amdgpu on KDE. This is the first time i have tried it in a long time. Window effects works exactly as they do in x11. Very fluid and responsive. It is my understanding that wayland works well on graphics that are running on modestting. Nvidia is little more (couple steps) to get working but i haven’t tried it. I have Xfce on my Nvidia system. Sorry. :slightly_smiling_face:

The link you provided states that I need to modify my kernel command line and add the line nvidia-drm.modeset=1.
If I only knew how.
J.

Just follow the steps here:

Edit2: Just the first section shows it.

Edit: KDE documentation say’s you also need to have this installed.

libnvidia-egl-wayland1

@Jeannie

The kernel parameter is very straight forward.

sudo nano /etc/default/grub

add the parameter in the grub command line

ctrl +o +enter to write it out
ctrl +x to close

Then run

sudo grub-mkconfig -o /boot/grub/grub.cfg

reboot

Edit: Make sure you have this file installed also.

libnvidia-egl-wayland1

@Jeannie
I haven’t tried this on my nvidia so i can’t say whether it works or not. This is just what the KDE documentation says. Hopefully it doesn’t mess stuff up on you. :innocent:

Thanks so far, but tere is no package named libnvidia-egl-wayland1 in the repos.
J.

On Arch I believe it is egl-wayland

1 Like

Seems to work pretty good on amdgpu now on current kernel.