How do I disable my keyboard and mouse from waking my PC either from sleep or hibernate?

How do I disable my keyboard and mouse from waking my PC either from sleep or hibernate?

I did go to the power settings and I tried to find something in relation to hibernation but still can’t find it. Does anyone have an idea?

It is in BIOS? wake on LAN, wake on USB and so on.

I can try and check these settings, but I had the exact same problem on Windows and I did manage to figureout how to disable this on Windows. I don’t know about Linux or KDE for what the solution is. But yeah I will see if there is such setting(s).

Just checked the BIOS settings, all of those are disabled. So it has got to do with the OS I believe.

ok, do you use KDE?
some info needed :slight_smile:

ah plasma. so kde

1 Like

Yes mate KDE plasma I use :slight_smile:

it’s possible it’s something in a tlp config file? i vaguely remember that, but have long since uninstalled tlp since i use a desktop.


It can also be done by writing a systemd service.

Here is an example:

Disable unattended wakeup


Leopard. Spots.

Why does it keep re-writing back to defaults unless you use a script?

Edit: Isn’t there a way for it to permanently keep it disabled?

I tried your suggestion it fails though. Even after a reboot it still wakes when I do a mouse movement.

You can look at my service to enable wakeup of a USB device (Logitech trackball) earlier in that tread.

USB Wakeup service

Changing enable to disable on the USB port your mouse and keyboard are using should work. You can even shut down the entire USB bus using a service.

I suggest you start reading the thread on services, especially posts relating to enabling disabling USB devices on suspend. There are different ways to accomplish doing that.

You might want to try disabling the device by its unique ID.


USB Restart Service

Sorry, but there are over 100 posts on that thread and I’m only on my cell phone, so I’m not going to be walking you through all of them. You’ll need to start reading the information that is already documented on my service thread or other sources.

A service will work for this as I have used services to enable support for KB & mice. Logically, if a service works to enable support, it can just as used to disable support for wake up.

1 Like

If services and scripts are a little too much effort for you do as @steanne suggested.

You can install tlp (if not already installed) and tlpui from the AUR. You should then be able to use the tlpgui program to change your power settings through a GUI.

1 Like

I will try this method then.

I installed the tlpui (tlp is already preinstalled) so I went to the USB section and it all has got to do with USB autosuspend feature. Is there a setting I am missing or something?


cat /proc/acpi/wakeup

Edit: Is this a dual boot with Windows?

The result I get is this:

Device  S-state   Status   Sysfs node
PEG0      S4    *disabled  pci:0000:00:01.0
PEGP      S4    *disabled  pci:0000:01:00.0
PEG1      S4    *disabled
PEGP      S4    *disabled
PEG2      S4    *disabled
PEGP      S4    *disabled
PS2K      S3    *disabled
PS2M      S3    *disabled
RP01      S4    *disabled  pci:0000:00:1c.0
PXSX      S4    *disabled
RP02      S4    *disabled
PXSX      S4    *disabled
RP03      S4    *disabled  pci:0000:00:1c.2
PXSX      S4    *disabled  pci:0000:03:00.0
RP04      S4    *disabled
PXSX      S4    *disabled
RP05      S4    *disabled
PXSX      S4    *disabled
RP06      S4    *disabled
PXSX      S4    *disabled
RP07      S4    *disabled
PXSX      S4    *disabled
RP08      S4    *disabled
PXSX      S4    *disabled
GLAN      S4    *disabled  pci:0000:00:19.0
EHC1      S4    *enabled   pci:0000:00:1d.0
EHC2      S4    *enabled   pci:0000:00:1a.0
XHC       S4    *enabled   pci:0000:00:14.0
TPD4      S4    *disabled
TPD7      S0    *disabled
TPD8      S0    *disabled
HDEF      S4    *disabled  pci:0000:00:1b.0
PWRB      S3    *enabled   platform:PNP0C0C:00

Yes correct, I did shutdown Windows, not hibernate Windows when booted into EndeavourOS.

My apologies as with @steanne I use a desktop and therefore do not use tlp. I am not that familiar with tlp’s GUI settings. There is also the tlp config file that can be edited manually if you check the options there.


It’s possible EHC1, EHC2 and XHC could be the culprit. (Enhanced Host Controller and Xhc) All related to USB.

You could try log in as root and try each of these separate and all. You’ll have to google this. As far as i know it’s temporary until reboot. If this is the cause then permanent solution has to be done. So maybe this is a setting in tlp that can be set? USB auto suspend?

echo EHC1 >> /proc/acpi/wakeup

echo EHC2 >> /proc/acpi/wakeup

echo XHC >> /proc/acpi/wakeup

The other one is the power button so don’t touch that.

1 Like

Yes… a desktop guy! :+1:


I could give this a try maybe.

Tried running the first command sudo echo EHC1 >> /proc/acpi/wakeup I am getting an error message

<W> fish: An error occurred while redirecting file '/proc/acpi/wakeup'
open: Permission denied