How do I disable modesetting?

I have been reading up over here:

and I am a little confused as to how things work. is KMS modesetting?

For an Intel graphics card, I have to add i915.modeset=0 this but where do I add this to, which file do I add this to? If I disable modesetting, then would it just use Intel’s own drivers instead?

Is EndeavourOS by default using modesetting?

EndeavourOS defaults to whatever Arch defaults to.

As for disabling modesetting, add i915.modeset=0 to GRUB_CMDLINE_LINUX_DEFAULT option, in the /etc/default/grub file. Afterwards, generate grub config file # grub-mkconfig -o /boot/grub/grub.cfg

What does Arch defaults to if you know by any chance?

Thanks :slight_smile:

Made a slight mistake, recheck before commiting changes.

1 Like

If you have to do something to disable it, generally that means it’s coming enabled by default :wink:

1 Like

Oh lol

To be honest I don’t know if it is enabled or not but like I am having some issues with web browsers and I want to make web browsers render differently.

What mistake did you make? Did you mean I have to add it to GRUB_CMDLINE_LINUX= instead?

nomodeset can break some drivers, better test it first by pressing e while in the grub menu (the screen where you’re choosing the kernel) and add the option(s) to the linux entry (near the bottom of the menu), this way you can test them just for the next boot.


Hey man, where do I add it to the grub menu the nomodeset setting? I am not too famililar with this?

Here’s a rather detailed tutorial on how to do that: