How can I roll back to the previous version Nvidia?

I got streaks in the game at the highest resolution. This didn’t happen before. Most likely this is due to the new Nvidia driver. Question: How can I roll back to the previous version?

➜  ~ git:(master) ✗ inxi -G 
  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] driver: nvidia v: 545.29.02
  Display: wayland server: X.Org v: 23.2.2 with: Xwayland v: 23.2.2
    compositor: kwin_wayland driver: X: loaded: nvidia
    gpu: nvidia,nvidia-nvswitch resolution: 2560x1440~165Hz
  API: EGL v: 1.5 drivers: nvidia,swrast
    platforms: gbm,wayland,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.02
    renderer: NVIDIA GeForce GTX 1080 Ti/PCIe/SSE2
  API: Vulkan v: 1.3.269 drivers: nvidia surfaces: xcb,xlib,wayland

EOS ships with a nice script for that:

downgrade nvidia

There is also eos-shifttime, if other packages are a problem…

1 Like

Everything would be fine, except the login screen freezes and I can’t do anything.
I return my previous version via tty and then the system will boot.

What did you do, exactly? Just downgrade nvidia ?

There are probably issues with other packages, like nvidia-utils or others, that also need to be downgraded. How did you handle them?

Did you try eos-shifttime? Overall that’s probably the safest bet, Arch does not support partial upgrades, which is what downgrading a single package / a subset of packages boils down to. Reverting everything to a previous, coherent state is brutal, but more principled.

I used sudo downgrade nvidia nvidia-utils.

I have the version 545.29.02-2

I tried to install 545.29.02-1 and 545.29.02-3 (it does not require any dependencies)
Then I tried to install 535.113.01-9 and of course I had to change nvidia-utils (which I did).

In 3 cases I get what is in the screenshot.

I would like to understand this particular tool in order to understand what exactly is wrong with it.
It looks very good and does its job. Perhaps some manipulations need to be done after it?

You could try using the less error prone nvidia-dkms instead of nvidia.
Then you’ll need kernel headers too.

1 Like

In general, I’ll tell you how to generally downgrade the Nvidia version

yay -Rdd nvidia-dkms nvidia-utils
This will remove the packages and not affect their dependencies (after all, I will just change them to others)

Next you need to select which version you need to install and all packages must have the same version

sudo downgrade nvidia-dkms nvidia-utils nvidia-settings opencl-nvidia lib32-nvidia-utils lib32-opencl-nvidia libxnvctrl

And in each one we choose the same version to which we will switch and reboot!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.