Desktop environment does not startup/load after turning on monitor

I’ve been using EndeavourOS for a little over a year, I haven’t had any major complaints with the install and after some online searches I can usually find a resolution to any minor issue that arises.
This one issue that I’ve been having has been difficult for me to figure out where is the source of the issue is.
Some system specs:
Intel i7-5930k
RTX 3070
EndeavourOS with XFCE and the bare-bone install and setup i.e. I do not stray from what EndeavourOS devs ship the installer with.

I don’t turn off my PC unless I know I won’t be home for several days, so it is always on and I just power off the monitor when it is not in use and when I do want to use my PC I would just power on the monitor and my desktop would be there and ready to be used etc, I don’t have hibernate/sleep function enabled nor do I use it.
After a recent “eos-update --yay” that I ran on this past Sunday (06-09-2024), my workflow of powering off the monitor and the powering it back on when I need to use the PC does not function anymore, I just get a blank screen and the monitor says there is no power signal and goes to stand-by mode. I can log into TTY3 (ctrl+alt+f3) and see a text login input and then get access to the terminal.
I know there was an Nvidia driver update that it installed on Sunday and so I thought it might be a buggy driver as the previous version didn’t cause this issue so I used the “downgrade” command to downgrade all Nvidia related packages/applications etc: How can I roll back to the previous version Nvidia? - #7 by dmali
I restarted my PC and tested out the powering off monitor and power it on again to see if I get my desktop back and nope it still has the blank screen and again still have access to TTY3 and so just sent a command to restart my PC.
I got frustrated enough that I just decided to use my Timeshift backup and restored it to the last time I made a backup which was on 06-01-2024 and now everything works like how it was before I did the last update on 06-09-2024.
I’m at a lost of what could be the cause of the issue, and when I see the list of updates available with “eos-update --yay” I just don’t know which of these packages could be the cause of it and I would like to keep my system updated (I usually update once a week) but something is causing me issues.
Any help would be greatly appreciated.

I just updated today. So far, the driver seems just fine. One thing I’ve done to try to prevent issues like this, whether the monitor is being turned off by me or Xfce’s power management, is to have display profiles setup so the system knows what to do when the monitor(s) come back online (SettingsDisplayAdvanced). This works coming back from suspend/hibernation as well.

I haven’t changed any of these settings from what I recall since I installed EndeavourOS and so I believe it is all set to the default values.
The values currently in my restored Timeshift snapshot should have been the same when I did the update on Sunday.
As it currently is set in the Settings → Display → Advanced, there is nothing in there no profiles saved/set, “When new displays are connected:” is set to “Do nothing”, “Show popup windows to identify displays” is set to “off”.

Only things updated after 6/1 that jumped out at me were mesa, the kernel, and nvidia. Only the (1) monitor, correct? Not sure how much the display profiles will help, but it’s worth a shot

Thanks for your assistance on this issue I’ve been having, I appreciate it.
Yeah, just one monitor a Dell 27" 4k.
I guess I don’t understand why this profile setting would be “required” now when it was working fine up to this recent update changes.
I’ll create a new display profile for this one monitor and install all these updates and see what happens.

Updated my system with “eos-update --yay” and installed all of the packages and made sure my display settings had the single profile saved and my issue still persist.

After further searching my system, I found these Xfce package updates that happened over the last couple of days:

[2024-06-09T09:28:37-0700] [ALPM] upgraded xfce4-settings (4.18.4-1 -> 4.18.5-1)
[2024-06-10T15:55:45-0700] [ALPM] upgraded xfce4-power-manager (4.18.3-1 -> 4.18.4-1)
[2024-06-10T15:55:45-0700] [ALPM] upgraded xfce4-session (4.18.3-1 -> 4.18.4-1)

So maybe the Xfce power manager is the culprit. I would post something on

That might be the culprit, I installed every packages update but the listed XFCE ones and tried to reproduce my issue and it did not occur.
I will relay my issue with the XFCE forum.
Thanks again for your help!

1 Like

Just a small update, Xfce dev released a new update to Xfce4-settings that fixed the issue.
Thanks again for your help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.