Hibernate Seems to Cause Shutdown Instead


I am fairly new to linux. I installed Endeavor a few days ago.
My laptop seems to not be hibernating. When I choose the action in the KDE start menu, it seems to shut down instead, since the next time I press the power button, I see it post and go through the usual boot-up procedure. All the apps that were open are now closed, though intwerestingly my browser seems to offer the option to restore my tabs.

I found this other forum post, but I had problems with it:

On my system, /etc/dracut.conf.d/resume.conf already exists and has the line:
add_dracutmodules+=" resume "

I ran dracut-rebuild anyway, but the problem did not go away.
I then attempted to run reinstall-kernels like the post susggests, but the command is not installed on my machine. That’s where I gave up.

By the way, how do I add code blocks to my posts?
Thank you,

Have a look at the following thread and try the suggested solution:

1 Like

I added the line to the file, restarted, and then tested the hibernation.
It is still not working. Could it be because I am using grub and not systemd-boot?

Did you do the last line in the solution?

1 Like

Ahh, I forgot the rebuilding step. It seems to work now!
By the way, how do I post code blocks in the forums?

When you hit reply there will be a menu in the box your typing in.
Welcome to the forums. :wave:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.