Help with fonts

Hey guys, sorry to have to bug ya’ll. I had to move away from this os a couple of days ago after having some issues (that I didn’t understand at the time) with my system. All that is pretty much sorted out now though. I reinstalled EndeavourOS now for the third time because everytime I update after a fresh install, my fonts brake. When I open terminal after the update, all my text is just blocks. I can go into the preferences and check use system fonts, and that helps, but I was hoping to get some insight as to either how to update without updating the fonts or how to fix the issue. Also, just about any font I choose after updating looks really blurry. I have not done the update yet on this install.

I think this page might be helpful to you, as it gives 2 options for excluding certain packages from being updated by pacman:

https://bbs.archlinux.org/viewtopic.php?id=48538

Packages (31) appstream-glib-0.7.15-1  archlinux-appstream-data-20190726-1
              docbook-xml-4.5-8  docbook-xsl-1.79.2-5  gcab-1.2-1
              ghostscript-9.27-1  glib2-docs-2.60.6-1
              gobject-introspection-1.60.2-1  graphviz-2.40.1-17
              gsfonts-20180524-2  gtk-doc-1.30+1+g44c5972-2  gts-0.7.6-5
              ijs-0.35-2  itstool-1:2.0.2+5+g676f3f7-1  jbig2dec-0.16-1
              libidn-1.35-1  libpaper-1.1.24-11  libstemmer-0+337-3
              libxaw-1.0.13-2  meson-0.51.1-1  ninja-1.9.0-1
              python-anytree-2.6.0-2  python-beaker-1.10.1-1  python-lxml-4.4.0-1
              python-mako-1.0.14-1  python-markdown-3.1.1-2
              python-markupsafe-1.1.1-1  python-pygments-2.4.2-1  python2-2.7.16-1
              run-parts-4.8.6.1-1  vala-0.44.6-1

Total Download Size:    57.94 MiB
Total Installed Size:  256.82 MiB

:: Proceed with installation? [Y/n] n
Error installing repo packages
[jay@jay-pc ~]$ sudo pacman -Syu --ignore gsfonts-20180524-2

Like this? Just double checking to be sure. I can be a little dense sometimes.

It may be helpful to know what desktop you installed each time? Was it the same? I have ghostscript and gs fonts installed on Arch with Cinnamon desktop. Is it just in the terminal that the fonts are messed up? If you don’t mind me asking what were the issues you didn’t understand that caused you problems? What terminal are you using? Is it the standard terminal that installs with the desktop or have you installed a different terminal? I may not have an answer here but more information is helpful to understand the issue.

“We are all a little dense”…sometimes! But i speak for myself. :smile:

Everything is stock. I ran that update up top, and xos4, and a handful of ‘certain’ fonts are looking ok. Majority of them are super blurry.


As far as what’s on my system, it’s all stock ftm. Once I get this font issue fixed, I’ll be alright. The issues I was having were due mostly to me not knowing what I was fully doing, such as getting virtualbox to fully work and a couple other caviats that I ironed out. I never had those problems on arch. Yes I am new to linux, but I also used that archfi script to install it. Decided to give it a shot after being on pop os for a few months.

The other thing I was having issues with, and still having issues with, is getting my bluetooth headphones to play sound. Not really sure what the bug is there or if I’m missing something.

So you are saying you used the Archfi to try Arch before coming to Endeavour? Did you use the final stable release ISO to install Endeavour? It looks like your Fonts are not blurry but rather squished together. I see 1360X768 resolution on your picture. What is your monitor size specs. Also is this on virtual that it is installed?

Can you get into the Terminal options to set a different font?

As for getting Bluetooth audio to function, one must pair the headphones, and then select them as the current sound device.

That’s correct. Every os displays my tv as 1360x768. Yes I installed the stable release from the direct download.

@Technomancer I did that multiple times, but no sound comes through.
And yes I can select ‘certain’ fonts, but most of them look horrible. The only ones that seem to really be playing nice are the xos4 ones

Darn, if I was running EndeavourOS now I’d be trying to figure it out. I can’t remember the last time I paired my Bluetooth headphones to my Linux PCs, unfortunately.

Currently you have the updates installed or not?

@Technomancer That’s cool, thanks for the input though. I’m sure I’ll get it sorted eventually.
@ricklinux Yes sir, I have updated my system while omitting the only font set that I saw. At least I think I did it right. After I did that, then the arch logo at the bottom said I had 6 system updates, and I tried doing it in the terminal for those six packages with no luck, so I turned back the the system updater and ran that. No font packs were selected to update that I could see, unless certain packs don’t hve the word fonts in it.

Could you run in the terminal and post:

locale

[jay@jay-pc ~]$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=
[jay@jay-pc ~]$ 

Also, the xos4 fonts now look like this

If I select the use system fonts box, it looks perfect, but I like to customize.

Well the locale is correct and language. What happens if you install the other fonts that were in the updates?

pacman said there’s nothing to do after running -Syyu, so I gues the system update through the arch symbol updated the font without my knowledge?

Do you have ttf-bitstream-vera installed?

Yes sir, I sure do.

So are the fonts just messed in the terminal or on the start menu and on the browser page on the internet?

Only in the terminal. I can look at the different files and everything else seems good, but maybe just because everything else is on default font. How can I change system font to check?

Why don’t you try installing the gnome-terminal and see. You can uninstall it after.

sudo pacman -S gnome-terminal