Help with dying light graphics issue please

(post deleted by author)

Yeah, just as I feared, you updated Nvidya drivers from 470 to 495… I can just echo what Linus Torvalds said to Nvidya (slightly NSFW).

I’m sure someone will come up with a solution for you.

1 Like

Oh, ok, then my advice is to start playing through Proton / Wine - native Linux games are far from stable unfortunately, otherwise you’ll start working as a 24/7 debug service for devs.

Yes, and also see this, looks like your series of cards have just become legacy

2 Likes

Install the 470 series of nvidia drivers.

2 Likes

Someone correct me if I’m wrong, but I think it would be easiest to add @jonathon’s repo and just install the 470 drivers. Installing them will automatically remove conflicting (replaces) packages. Do not uninstall anything, because your computer might become slightly unbootable.

What’s weird is that 750 Ti is not listed there…

1 Like

Oh it’s Maxwell, not Kepler…so it’s not the drivers guys.

1 Like

Even if it is supported, I would try downgrading since the game stopped working after the update. If nothing else, it will tell you if the issue is related to the drivers or not.

It could be that the drivers are incompatible with the game, not the hardware. Only way to tell for sure is to test.

1 Like

I guess you’re right, especially since it’s Linux native game…
Well at least hardware compatibility is intact :upside_down_face:

I don’t see what else it could be, these packages were upgraded when the thing broke:

archlinux-keyring
tzdata
bind
systemd-libs
device-mapper
cryptsetup
xorg-server-common
libnghttp2
systemd
xorg-server
nvidia-utils
egl-wayland
eos-translations
gawk
geoip-database
gupnp
gupnp-igd
imagemagick
ldb
lib32-nvidia-utils
librsvg
libxnvctrl
linux
linux-headers
lvm2
nvidia-dkms
nvidia-installer-db
nvidia-installer-dkms
nvidia-settings
openexr
python-gobject
r8168
smbclient
systemd-sysvcompat
v4l-utils
vala
virtualbox-host-modules-arch
xmlsec
zenity

The only thing that screams on this list is Nvidya…

xorg could, as well as Kernel (not likely).

P.S. I’ve seen it sometimes back on Manjaro :sweat_smile:

No, that’s very unlikely…

Add the kernel-lts repo as described here:
https://wiki.archlinux.org/title/unofficial_user_repositories#kernel-lts

It contains the older drivers.

Don’t try to remove the new drivers separately. Just install the older drivers after adding the repo. They will replace the newer drivers.

1 Like

If you need more detailed instructions, see:

Specifically, “How to use” part… When you’ve edited your /etc/pacman.conf and imported the keys, you can run:

sudo pacman -Syyu nvidia-470xx-dkms nvidia-470xx-settings nvidia-470xx-utils lib32-nvidia-470xx-utils

I think these are all the packages necessary. Someone please check.

Well, we can just force it:

sudo pacman -Syyudd nvidia-470xx-dkms nvidia-470xx-settings nvidia-470xx-utils lib32-nvidia-470xx-utils

Hopefully, this won’t break anything… Do not reboot until you check that everything is installed.

When everything is done, check:

dkms status

What does:

pacman -Q | grep nvidia

give?

Oops. :sweat_smile: Hopefully this should fix it:

sudo pacman -Rdd nvidia-dkms nvidia-installer-db nvidia-installer-dkms

When done check with:

dkms status

I think this is good, but I would like someone else too look at it before you reboot.

Because if you get a black screen, you’re going to have to boot from an ISO image and chroot.

I hate this nvidya crap.

Oh, that’s excellent! If you have an iso image ready on a USB drive, then just reboot, and pray :rofl:

You should have said so in the first place :smiley:

You’ll have to do the exact same procedure, only correctly, not like I told you. :sweat_smile:

You can start by adding Jonathon’s repo, just like you did.

1 Like