Help needed Troubleshooting a Missing Icons from Gnome 42 System Overview (shortcut SUPER S)

Hi,

So I’m working on a bug I noticed in the e-mail application called Betterbird (forked from Thunderbird) where:

  • The System Overview (SUPER S) Icon is missing for Betterbird.
  • The correct icon is showing for Betterbird in the Gnome Dash and All applications (SUPER A).

Screenshot from 2022-09-06 23-16-17

Troubleshooting:

By default the icons are placed by the AUR install in the “/opt/betterbird/chrome/icons/default” directory.

The Betterbird desktop icons are placed in the “/usr/share/icons/hicolor” as soft links. I assume this is why the Gnome Dash and All Applications show the Betterbird icon.

image

Any suggestions on how the Gnome System Overview fetches the icons are welcome.

Thank you.

References:

Betterbird GIT Bug:

AUR Reference:
https://aur.archlinux.org/packages/betterbird-bin

Gnome 42 Icons missing

Have you checked the troubleshooting done in this topic? That user had broken icons symlinking, done during installation.

Although this is clearly a Gnome upstream (potential) issue and should be posted there, you might want to check possible caching issue (~/.cache/), or local config, which is strangely ~/.config/thunderbird/, as the developer says in an AUR post.

It doesn’t seem to be an application/installation issue, rather a DE or system configuration (not EnOS I suppose).

Maybe another Gnome user could confirm or not. :person_shrugging:

Have you checked the troubleshooting done in this topic? That user had broken icons symlinking, done during installation.

I have reviewed that post. But in that post all references to the missing icons affected the Desktop Icon.

In my case the Betterbird shows the correct desktop icon. Only the System Overview Icon is missing for Betterbird.

The correct Desktop\System Overview icons show for Thunderbird:

image

I also have tried changing the system icon theme to high colour and still no icon for this one program even though the icon in several resolutions is available.

image

I’m going to try to create the same PNG resolutions as Thunderbird to see if that is the problem:

image

IMHO, you are looking it wrong. The icons are fine. That System Overview is the problem. That thing cannot find the icons for this specific app, which is a weird, unusual app.
Is it original Gnome, or an extension?

Ask upstream Gnome about it.

I was just answering your questions (in relation to the Missing Icons post you suggested and I already referenced in my original post.

Is it original Gnome, or an extension?

The System Overview is built into Gnome 42.

In my mind the key is understanding how System Overview fetches the icons so we can find what dependency is not being met.

On a side note the following files do not have soft links in the hicolor theme:

/opt/betterbird/chrome/icons/default/default128.png
/opt/betterbird/chrome/icons/default/default64.png

Softlinks missing in:

/usr/share/icons/hicolor/64x64/apps/betterbird.png
/usr/share/icons/hicolor/128x128/apps/betterbird.png

So I will report this to be addressed as well.

2 Likes

You should confirm if those links are required, important, or solving your current issue.
If you think this is the problem, create those missing symlinks and check any difference with your issue.
:person_shrugging:

The missing system links don’t resolve the issue. I already tested that (just in case Gnome was looking for a particular display resolution).

I will have to bite the bullet and look into the upstream requirement, IMHO always best to ask in our community before talking to the Gnome people.

2 Likes

Hi there.
with the update to 102.2.2_bb16 i changed the PKGBUILD to create softlinks for 64x64 and 128x128 icons.
Greets :slight_smile: :laughing:

1 Like

Opened Gnome Defect to help investigate what dependency might be missing.

I checked with the Gnome project and this is what they recommended:

Sebastian Keller commented:

Please use https://discourse.gnome.org/ for user support. This specific issue is most likely a mismatch between the .desktop file (either the filename or the StartupWMClass) and the WM class of the window (use Alt+F2, lg, Windows) to find the WM class used by a window).

image

If I was to guess, looks like no “app:” property is being passed to Gnome Shell. As a result it cannot match the betterbird.desktop with the window.

So the fix the problem you need to add the following property in the betterbird.desktop file under [Desktop Entry] section:

StartupWMClass=thunderbird-default

Source:
Sebastian Keller commented:

So the problem is exactly what I mentioned earlier, the .desktop file does not match the WM class, so gnome-shell won’t be able to match the window to an application. Try renaming the .desktop file to thunderbird-default.desktop or add StartupWMClass=thunderbird-default to the [Desktop Entry] section of the .desktop file.

Please update the AUR and confirm that the changes I made are now working.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.