Gnome 42 Icons missing

Hey guys, I’m having this weird issue where none of my Adwaita icons are showing up anymore, most of them have a gear symbol on them. I have tried updating the icon cache and re-installing the icon them several time but with no luck.
I have also tried other icon packages but they have icons missing as well.

Does anyone have any suggestions on what to do?

If it helps, I’m running the latest Gnome 42 build.

Thanks in advance
Screenshot from 2022-07-02 21-20-59
Screenshot from 2022-07-02 21-38-48

1 Like

Have you tried reinstalling hicolor-icon-theme and shared-mime-info packages?

Welcome to the forum and the purpleverse :enos:

Do you remember what you have changed before this happens?
and also gtk theme is using libadwaita icons still getting set in old way … so you can try setting icons to another icon theme?

I just tried installing both packages again , using yay -S with no luck. i was not able to remove them first as gtk is using it .

setting other icon theme brings back some icons but not all
Screenshot from 2022-07-03 15-23-47

It’s really quite strange, if you create a new user to test the problem persists? If it doesn’t happen with the other user I suggest you remove the configuration file .config/dconf/user this will reset all your settings to the defaults, I suggest you make a backup of the file before removing.

Thats the first thing i tried, i created a new user and when i switched to it, it had the same issue :confused:

Try reinstall librsvg and rerun

sudo gtk-update-icon-cache /usr/share/icons/hicolor

you could try adding an icon theme in users config-home under ~/.icons/ from here p.e.
then you can choose from settings… if this works you have something screwed in system path…

Thank you for the quick response, that didn’t work either. is there any other place I can look to see if it might be a pathing issue?

I tried that but still the same result. not sure what could be doing this? is there a path file that tells the icons to display certain icons with certain apps?
Screenshot from 2022-07-03 20-41-21


sudo gtk-update-icon-cache /usr/share/icons/default

sudo gtk-update-icon-cache /usr/share/icons/gnome

sudo gtk-update-icon-cache /usr/share/icons/Adwaita

sudo update-desktop-database

that would be it and restart the session, I had this problem this week in an installation of cent os stream 9 in boxes VM, and having installed gnome 42 I had the same problem and I solved it this way, reinstalling librsvg and running these commands, you can see the icons in /usr/share/icons/hicolor/scalable/apps?

something weird is happening here , when I look at hicolor/scalable/apps folder I’m not seeing any icons. I deleted the folder and reinstalled hicolor-icon-theme via yay. and it still doesn’t populate.

The other thing is when I try to install another theme the theme colors get inverted. ehh i’m just digging myself into a deeper hole lol.

Screenshot from 2022-07-03 22-25-44
Screenshot from 2022-07-03 22-17-12

Did you happen to have any other DE installed before? try removing the .config/gtk*/settings.ini file, these issues with themes usually happen when installing another DE like Plasma for example.


the hicolor/scalable/apps directory should look like this.

Captura de tela de 2022-07-04 00-37-20

Did you do anything recently where you had to type or copy something into the terminal? It doesn’t have to be gnome related necessarily, but you could have made a mistake and ran a command that deleted, modified or set wrong rights on something.

1 Like

I copied hicolor from another pc and replaced the folder in /usr/share/icons, that seems to have made a difference. although there are some icons still not showing but all the settings icons are showing correctly. now the new issue is my settings app seems to have gotten stuck on white sur theme, I’m not seeing the white input boxes now.

This is what my windows look like now, notice the different title bars on windows and completely different theme in the settings app. BTW i have completely removed the WhiteSurTheme and removed the local ~/.themes folder

Screenshot from 2022-07-04 00-10-55
Screenshot from 2022-07-04 00-13-11

I may have deleted the hicolor folder and reinstalled it, I think that is what caused the icon issue, but for the life of me I cant figure out why the theme is stuck on the settings gtk app?

gnome settings uses GTK4/libadwaita, so if you installed the theme through an installation script it probably left some configuration remnants that are causing this behavior, probably in .config/gtk-4.0/ remove files if they exist here mainly gtk.css, it’s just a suspicion, i’m not sure.


yes!, that’s what it was, i removed the folder and switched the themes and that seem to have fixed the issue.
Really appreciate your help on this


Most themes and icon packs you can find in the aur, it’s better if you install from there, because probably someone tested and configured it for arch.