Help needed instaking dkms nVidia driver

[alienprober@TheMothership ~]$ sudo pacman -S linux-lts linux-zen linux-hardened linux-lts-headers linux-zen-headers linux-hardened-heders
[sudo] password for alienprober: 
warning: linux-lts-headers-5.4.63-1 is up to date -- reinstalling
warning: linux-zen-headers-5.8.7.zen1-1 is up to date -- reinstalling
error: target not found: linux-hardened-heders
1 Like

Typo should be headers


Yeah, that’s my mistake, sorry :slight_smile:

Fixed my post.


That perfectly fine. I should of caught it here as well.

1 Like

After that, when you run dkms status you should have four lines, one for each kernel installed, telling you that Nvidia dkms drivers are installed, and you can use all four kernels normally.

1 Like

Looking good.

nvidia, 450.66, 5.4.63-1-lts, x86_64: installed
nvidia, 450.66, 5.8.7.a-1-hardened, x86_64: installed
nvidia, 450.66, 5.8.7-arch1-1, x86_64: installed
nvidia, 450.66, 5.8.7-zen1-1-zen, x86_64: installed
1 Like

OK rebooted and one little hiccup. Instead of getting the options screen for EndeavorOS it boots to the kernel selection that list all the kernels. Wasn’t sure at that point which to select so I let it boot to the zen since it was at the top of the list. So I guess I have to ask how to I get my normal selection screen back? Thanks

Hmm, not sure what your normal selection screen was. Try

sudo grub-mkconfig -o /boot/grub/grub.cfg

(that’s the same as update-grub on Manjaro)

It was:

advanced options

and I’m assuming with the kernel updates we just did that the Garuda entries would of been on it as well.


ok one more snapshot, your command, and a reboot. thanks

1 Like

Don’t forget about getting this bit fixed. :wink:


I’m not sure, but I think @manuel now has all the info he needs to add this card to the database.

1 Like

@Kresimir here is a screenshot. Instead of the page screen with the OS, OS advanced options, and Snapshots I get that. It boots just fine and I can’t see any other issue other than that

That’s the default EndeavourOS GRUB theme. It looks the same way for me.

1 Like

So with multiple kernels they’re not hidden under advanced options like in Garuda and Manjaro? If that’s the case fine by me. It’s working like a charm so all is good.

You change that in /etc/default/grub, but I’m not sure how to do it off the top of my head.

1 Like

That’s fine all it will do is pretty it up a bit, the way it is it’s the same difference so I can live with it. Thank you and everyone else again for all the help.

1 Like

I’m not sure, but I think you have to comment out this line in /etc/default/grub:


(i.e. add # in front of it).
And then re-run

sudo grub-mkconfig -o /boot/grub/grub.cfg

If that’s not it, it is some option like that…

1 Like

Hi all!

Thanks for this thread, it helped a lot! :smile:

The bug with the testing option (-t) of nvidia-installer-dkms, along with the option --tmpdb of nvidia-installer-update-db should be fixed now.The new package versions are:

  nvidia-installer-dkms 3.3.8-1
  nvidia-installer-db 2.4.8-1

These should update on their own, right?


Never mind. Just checked and those are the versions I have. Thanks

Now that you have the dkms drivers installed, you can safely remove the installer scripts:

sudo pacman -R nvidia-installer-dkms nvidia-installer-db
1 Like