Help for kernel update hangs on boot

I am having trouble after the recent update, I have comment in the post

but I didn’t get it solved so think I’d better open a new topic to discuss this.

My desktop just hangs on boots, after update, no matter I choose
EndeavourOS Linux, with Linux linux
EndeavourOS Linux, with Linux linux (fallback initramfs)
and it hangs like this

And I try to chroot and downgrade linux to the previous version, but it does not help, it’s like this:

the same if I also downgrade networkmanager (don’t know if its related).

Then I also download the linux-lts and boot from it but it also hangs…

I notice that when I downgrade linux or install linux-lts, it didn’t output something like
...dkms install --no-depmod ....... so I am wondering if this is the reason that it still hangs? I tried to reinstall nvidia-dkms but it does not help…

Forgot to downgrade the header, fixed now…

1 Like

thats a good sign!
Thanks for reporting this!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.