Hello World

Just a quick hello to everybody from the Empire State. I’m not new to linux in general (but certainly new to getting into the weeds with it), but I’m working to push myself to replace win10 completely and get to 100% linux. I found EOS and currently have it running in a VM (win10 with virtualbox), so I can work on breaking things there first. I’m really liking the tweaking I’ve done so far with cinnamon and I haven’t run into any windows programs that I can’t replace. Hopefully in the next month or so I’ll take the plunge and wipe the win10 completely and replace it with EOS. Any suggestions on things to test in vm/learn ahead of time/backup before I switch/etc are much appreciated. Thanks.

Hello @ramblinwreck
I too am quite fond of the Cinnamon desktop although i have come to like xfce, plasma and mate. There are a couple of things with Cinnamon. One is that you need to turn off window effects in Effects from the menu. The reason for this is because the Welcome screen has an issue with transparency when you mouse over it if you don’t turn window effects off. The other setting i can recommend is right click on the show desktop folder in the taskbar and click configure and set the hover feature to show desktop when ever you hover over the show desktop folder. I would suggest just getting used to some of terminal commands for updating and installing. I use Chromium and Firefox browsers and Thunderbird for email. Libreoffice Fresh is great and you can install just about anything you need or want.

Get used to using pacman and also yay for updating and installing. If need be there are some GUI tools also such as Pamac. You need any help we are here for that and more. Welcome to EndeavourOS!

Good job. I ditched windows immediately and dove right into Linux when Windows kept forcing some dumb creator’s update that broke the scrolling on my system

I’m really glad I did because I like Linux much more than I ever liked Windows now

I recommend testing out XFCE and KDE Plasma, both are awesome. XFCE might look a bit plain and old at first but you can make it look really nice too

1 Like

If you are running email in your W10 installation you could Thunderbird there, get it to import from you other app, and then when that is working the Thunderbird profile directory is directly usable in Linux by copying it across. Same with any of the usual browsers (Firefox, Chrome, Vivaldi, Opera).
Welcome the the new addiction :smiley:

Or Evolution is also an other option. It’s more like Outlook.

Pudge

1 Like

Thank you @ricklinux @Archnoob @onyxnz and @Pudge for the replies. I made the cinnamon changes recommended. The “show desktop on hover” option is a good one for sure and the other is updated now, but I hadn’t seen issues with it before. I’m planning on messing around more with other DEs, xfce and mate were on the list before, but I’ll add plasma too. I like having the options on for things and the pc I’ll be on eventually has plenty of horsepower, so I’m open to installing a few different things. I have libreoffice installed and it seems to be working fine. I’ll check out Thunderbird and Evolution too. My main plan is to be able to move most (everything?) from the win10 install to the non-OS drive in the pc so that I can wipe the os drive when the time comes and know I won’t lose any important .txt or .xls or stuff like that. One thing I did notice is that I installed vlc on EOS and I see it in the menu, but clicking on it doesn’t open anything. I don’t have any video/audio files in the vm to test if they open in it, but it seems odd that vlc itself won’t open. I’m sure it’s something stupid I’m doing/did. Thanks again to everybody.

1 Like

Of course, I just installed mate and vlc opens just fine in it. Now I’ll get to tweaking mate some to look/work the way I want. Maybe it was just me and cinnamon that vlc didn’t like…

Try opening vlc from the terminal inside cinnamon, to see if there is any error message to enable diagnosis. (Simply type vlc )

Typing “vlc” into the terminal in cinnamon gives me “bash: vlc: command not found”. Clicking on the icon in cinnamon does nothing still as well.

Very strange, it appears that vlc is not installed for you.
Do yay -S vlc in the terminal again, and follow throught the process of installing it.
Once that is done, you should get something similiar to mine:

vlc
VLC media player 3.0.10 Vetinari (revision 3.0.10-0-g7f145afa84)
[00005561289ae660] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0000556128a4b1c0] main playlist: playlist is empty
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 534, resource id: 0, major code: 20 (GetProperty), minor code: 0

I tried a few more things just to see if I was crazy.

VLC opens just fine in MATE via the icon in the applications menu and plays a video from a youtube url, but I get the same output in the terminal (bash: vlc: command not found).

Still in MATE I did yay -S vlc in the terminal and went through the install process. After this vlc opens from the terminal (output like yours above) and there are 2 vlc icons in the application menu, both open vlc like normal. Back in cinnamon, opening vlc from the terminal works with similar output to above and there are “VLC” and “VLC (Flatpack)” icons in the menu. The regular one opens like normal, but the “(Flatpack)” one seems to do nothing. It works now at least, so that’s solved. I won’t drag this thread out more (if I run into things I can’t fix by searching around I’ll start new threads as needed), but thank you again everybody for the help. We’ll see how much fun I can have in this VM in the next few weeks and hopefully take the full plunge before too long.

Where did the flatpak stuff come from? You don’t need flatpak. I have everything installed with yay.

1 Like

I’m sure it’s from me trying to install VLC another way. I’m new to running linux as a desktop, so I’m not did some downloading of files, extracting and installing via the cmd line initially (vlc and irssi was all, I think). It sounds like this is unnecessary and probably not the best idea in general. Are there times when you can’t install something via yay? Is there a reason to not use it 100% of the time?

pacman is the defacto package manager for Arch but it doesn’t install AUR packages. You have to use yay for that. But yay will do both. With yay you have to have the exact proper name of the package or it will not find it. So if you use just yay without the -S it will bring up all and you have to select what you want to install. I usually use yay -S but not always. I don’t know everything about it. Best to use the man pages.

i.e.
man pacman

Or anything you want information about.
But for fast installing yay -S vlc

Then you can just arrow up and backspace over vlc and type in the next thing you want installed such as:

yay -S rhythmbox

You can install just about anything you’ll need or want.
libreoffice
thunderbird
chromium
spotify
rhythmbox
celluloid
vlc
qbittorrent

These are just a few examples… I can give you many. Just ask what you are looking for. Lots of help here on the forum.

Edit: yay -S irssi

I mainly use yay [searchterm] for all my install and search needs. Which is equivalent to yay -s [searchterm], which is different from yay -S [package name] and yay -Ss [searchterm]. I recommend typing all of these commands to see how they behave.

The reason I use yay [searchterm] is that it gives a result of all packages containing [searchterm] in their name or description and, at the same time, allowing installation of all or any of the results found.
None of the other variants allows both search and install in one go.

2 Likes

Thank you for the tips @nate. I’ll dig into each of those options and see what I can find.

I’m a large fan of yay but must add that pamac is making me lazy for looking up things.
However all my updates and installations are done using yay and pacman.

Is the syntax for pacmac the same as listed above for yay and pacman? I’ll dig into the man for each some and see for myself, just wanted to get a general idea.

The only thing I use pamac for is packages search and info via GUI.
It’s just a easier cheat.

Ok, if I should create a new post in the Cinnamon section for this please let me know…

I just did all of the latest system updates and messed around with a few themes/colors in Cinnamon. After a reboot the only DE I can get into is i3. Everything else I try just gives me a black screen. Maybe these changes (system update and themes/colors) shouldn’t be made at the same time? Is there anything I can do to fix whatever it is I broke? I’m in i3 now, so I can get into things to adjust as needed, I’m hoping. Thanks in advance for any help.