Hello! I backed up Windows, erased my drive, and installed EndeavourOS!

I followed the instructions in the news box to reinstall Grub, because as soon as I installed, I updated the system.
It feels good to be on a non-debian distro. Now I need to begin to learn my way around.


Welcome to the Purple side! You won’t find a better forum for help, as well as all the great Arch resources.

1 Like

No, you didn’t install EndeavorOS but EndeavourOS!
Like the space shuttle that was named after HMS Endeavour, James Cook’s famous exploration vessel.


Welcome to the forum :enos_flag: :enos: :partying_face:

1 Like

We have liftoff! :rocketa_purple:

1 Like

Welcome :wave: and enjoy the purple ride :enos_flag:

1 Like

I took the liberty to rectify that title :grin:

Good call with erasing windows, and good luck on your Linux journey :rocket:



Thanks Orca for the correction. It’s my lazy typing. I have everything updated and now I will install java and minecraft to get my feet wet.

I was following ArchWiki, but there wasn’t time for me to follow through. It was the second night; I had decided to back up a step and make a recovery disk for Windows, which ended up taking 2.5 hours, probably because I chose to backup system files. While I waited for the typical vague Windows progress bar, I prepared to install Mint to be done with it, but then I recalled reading about EndeavourOS.

Nice. It was a smooth installation experience using yay.


Welcome to the forum and the purple side of life!

1 Like

Welcome treacle to the purple haze, a truly great experience, the community here is second to none
and you’ll find all the help you need and more, right here on the forum,…Enjoy.


Welcome. It seems you have been pulled over by our resident grammar patrol officer on your first ride out with EOS.

Hope you do better on your next post. The grammar police never sleeps :smiling_face_with_tear:


Which package did you install? Did you manage to play Minecraft onmultiplatform co-op, like with windows users?

1 Like

This is the version of Java I installed:

extra/jre-openjdk (183.4 KiB 503.4 KiB) (Installed)
OpenJDK Java 18 full runtime environment

However, I would like to uninstall OpenJDK JRE and and switch to Oracle JRE:

aur/jre 19-1 (+1095 0.29) 
    Oracle Java Runtime Environment

This is the Minecraft package I installed:

aur/minecraft-launcher 1:1.0.1221-1 (+1045 9.50) (Installed)
Official Minecraft Launcher

This is Java Minecraft, so it is fully compatible with Windows or MacOS players online.

1 Like

I tried yay -R jre-openjdk but it complained that this was would break the dependency required by Minecraft. So, I installed Oracle java, yay -S jre, and then removed the openjdk package after that. I noticed that there was still a related openjdk headless package installed, so I ran yay -clean to remove this.

I’m not sure it makes any difference because in the top right corner of Minecraft when I hit F3, it reads Java 17.0.3. It’s using a bundled version of Java.

I tried java -version but Oracle Java wasn’t automatically set as the default java version. I see that it’s not officially supported, from this wiki page:. However, the page instructs to use a built in script, archlinux-java, which allowed me to set oracle java as the default version. So, I really didn’t need to uninstall the OpenJDK version after all. However, the next task will be to see if I can force Minecraft to now use my installed Oracle Java.

OK… Minecraft can’t run using Oracle Java 19 nor OpenJDK 18. It needs the bundled JRE and says so in the error message if I force it to use my own java version.

The bottom line is you can probably just install the minecraft-launcher package without installing java first.

Any reason to use oracle over open java? Open source should be preferable.

1 Like

I was hoping to compare performance.

Nuffink to do with grammar. Endeavor can be right, should you be using American (simplified) English. Buuut, the Endeavour was a ship of her Majesty, the kink or kween of Britain, and is a name, so there is only one way to spell it anyway.


I have screen rotation with accelerometer now, touchscreen scrolling and pinch to zoom enabled in Firefox for tablet-mode browsing, and I have both fingerprint or password set up for login and authorization. It finally feels like this is my very own PC. I didn’t have that with Windows and Ubuntu.

The Spelling Department is part of the Grammar Police. The same way FDA takes care of regulating food and drugs :wink: