HDMI Sound Has no Output

Hello everyone,

I’m a little new to the form and may not be in the right place so be kind and don’t yell to loud… :smiley:
“Modiators” Please feel free to move this where it should be…

So Yes I did do a bunch of searching for a bit here and the interweb and did not see anything that might help so I am posting this here if that is ok…

I am having a issue with my HDMI audio not working in the EndeavourOS… I am having the same issue with other OS’s like, MX-19, Linux Mint 19.2, Manjaro-Cinnamon 18.4…
I play alot in VM’s and on real test systems if I like it… That includes EndeavourOS…

Now, Mint 18.3, MX-18, PepperMint 10, Ubuntu 16.04 all work on these Mobos with the HDMI Audio working…
The only thing thats changes it the HDD or the USB stick that I am booting from…

A bit of history been running MX, Mint, Ubuntu, and so on this box with no issues. The sound has work on all versions with the same setup.
My Dell has both HDMI and VGA video out (yes both at the same time)…
Has the standard audio plugs, the green plug being the soundcard. Everything is build on the Motherboard video, usb, network, etc…

Note:
I have 3 Gigabyte Mobos that are the same as My Dell, Video setup, Network, Sound and so on but they have 4 core AMDs and 8 gigs of ram.

However I do not use the onboard soundcard.

I use the HDMI port for my video and audio through my 46" and 32" tv’s. I have the audio piped into my stereo system from there for both computers with optical cable. This setup has work from day one for years…

Now to the ISSUE:
After installing MX-19 or EndeavourOS or Manjaro on a seperate HDD on the Dell system in question, which also has MX-18.3 on its own HDD and everything is working as it should, video and sound and so on…
I am booting from separate HDD’s with my F12 key and choosing what HDD to boot from, MX-18 to other Hdds or USB sticks.

After installing MX-19 or Mint19.2 or EndeavourOS, Manjaro-cinnamon 18.04 the sound does not work at all on the HDMI or the built-in soundcard until I turn on the internal soundcard in the sound/mixer settings.

I don’t use the built-in soundcard, so I had to find a cable to hook it to my stereo to see if there was sound from the onboard soundcard and there was not! So I had to go to the Mixer and there I found that the settings was not set for the soundcard but for the “Digital Stereo Output” which there is not connector for that, so I changed that and got the onboard sound card working.
At first the sound was in slow-motion but then cleared up and worked ok.

Now for the HDMI sound…
All the OS’s reports there being a HDMI Audio Card(s) and it is a AMD and so on, but it reports it as being “HDMI Unplugged” which is not true as I have video…Lol

I have been testing stuff and I find that the kernel (old 4.09 or new 5.3) did not make to much of a differences, I used new ones and old ones… The ALSA drivers on all the OS’s that HDMI work and don’t work are not that different in the Version numbers.

1: ALSA V:k4.19.79-1 for Manjaro 1804 No HDMI sound ??? Maybe!
2: ALSA V:k4.10,0-38-generic Mint 18.2 Has HDMI Sound
3: ALSA V:kv4.18.o-18-generic Peppermint 10 has HDMI Sound

The sound driver: snd_hda_intel is the same on most everything…

As for Plusaudio I have not been able to figure that out… :frowning:
The onboard soundcard ALWAYS works no matter what OS is being used, Some have to be turned on in the Mixer and some not…

I borrowed a AMD Radeon HD6450 1GB Graphics Card from a friend that is like the Mobos. (HDMI, DVI) where the Mobos have the VGA too. I have been using it for testing. Kinda neat can have 4 Monitors at once… Digressing…

So Aplay -l reports it them there, shown below, “Card 1” is the onboard and “Card 2” is the add on card…

 >> ~/bin : -> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: HDMI_1 [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Here is all the EndeavourOS board information on the Gigabyte Mobos I have (probably more than needed)… The Dell Mobo’s Infomation is below…


============
File created:
============
25 October 2019 00:22:18

	    <---====+++++++++++++++++++++++++++++++++++====--->
	           System information for bruce-pc:
	    <---====+++++++++++++++++++++++++++++++++++====--->

============
Bios Information:
============
	Bios Manufacturer: Award Software International, Inc.
	Bios Release Date: 10/19/2012

============
System Information:
============
	System Manufacturer: Gigabyte Technology Co., Ltd.
	System Product Name: GA-78LMT-USB3
	System Version:  
	System Serial Number:  

============
Board Information:
============
	Board Manufacturer: Gigabyte Technology Co., Ltd.
	Board Product Name: GA-78LMT-USB3
	Board Version: x.x
	Board Serial Number:  

============
Distro Information:
============
	Distro OS: Arch Linux
	Desktop: Distro: Arch
	Codename: n/a
	Release: rolling
	Kernel Ver: 4.19.80-1-lts
	Software Bit: bits: 64

============
CPU Information:
============
	AMD FX(tm)-4300 Quad-Core Processor

============
RAM Information:
============
	7.2948 GB

============
Graphics Adapter: 
============
	Advanced Micro Devices, Inc. [AMD/ATI] RS780L [Radeon 3000]
Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] <---- Test Card ---->

============
Network Adapters:
============
	Ethernet:
	Port Name: enp4s0
	Nic Card: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
	MAC Address: 94:de:80:0f:f5:80
	Ethernet Address: 192.168.1.114/24

============
Inxi - System Data Information:
============
System:
  Host: bruce-pc Kernel: 4.19.80-1-lts x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: Cinnamon 4.2.4 Distro: Arch Linux 
Machine:
  Type: Desktop Mobo: Gigabyte model: GA-78LMT-USB3 v: x.x serial: <filter> 
  BIOS: Award v: F4 date: 10/19/2012 
CPU:
  Topology: Quad Core model: AMD FX-4300 bits: 64 type: MCP arch: Bulldozer 
  L2 cache: 2048 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 30535 
  Speed: 1406 MHz min/max: 1400/3800 MHz Core speeds (MHz): 1: 1406 2: 1406 
  3: 1405 4: 1405 
Graphics:
  Device-1: AMD RS780L [Radeon 3000] vendor: Gigabyte driver: radeon 
  v: kernel bus ID: 01:05.0 
  Device-2: AMD Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM] vendor: Dell 
  driver: radeon v: kernel bus ID: 02:00.0 
  Display: x11 server: X.org 1.20.5 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: <xdpyinfo missing> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 
  Device-2: AMD RS780 HDMI Audio [Radeon 3000/3100 / HD 3200/3300] 
  driver: snd_hda_intel v: kernel bus ID: 01:05.1 
  Sound Server: ALSA v: k4.19.80-1-lts 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: ce00 bus ID: 04:00.0 
  IF: enp4s0 state: up speed: 100 Mbps duplex: half mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 37.01 GiB (4.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000NM0011 99Y1164 59Y1812XIV 
  size: 931.51 GiB 
  Floppy-1: /dev/fd0 
Partition:
  ID-1: / size: 62.23 GiB used: 9.63 GiB (15.5%) fs: ext4 dev: /dev/sda3 
  ID-2: /boot size: 476.2 MiB used: 103.7 MiB (21.8%) fs: ext4 
  dev: /dev/sda1 
  ID-3: /home size: 845.24 GiB used: 27.28 GiB (3.2%) fs: ext4 
  dev: /dev/sda4 
  ID-4: swap-1 size: 7.81 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 13.2 C mobo: N/A gpu: radeon temp: 44 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 185 Uptime: 2h 17m Memory: 7.29 GiB used: 1.09 GiB (14.9%) 
  Init: systemd Compilers: gcc: 9.2.0 Shell: mystat-in_work_ inxi: 3.0.36 

So after 3 days of messing around there was no Joy on the sound issue.

Booting off of USB sticks or HDD installation no sound on the HDMI… :frowning:

I once again had to fix the onboard sound card issue which was not a issue as I done it before…
Now if I boot into MX-18, Mint 18.3, Peppermint 10 everything is working as it should on the HDMI…
NOT changing anything but OS’s

Booting into EndeavourOS Not so much, for the HDMI sound anyway!
Everything else seems to be ok…

BTW I have the same sound issue booting off of the USB stick for the newer OS’s…
From what I can tell the Kernel version and Sound drivers are newer and might be the issue…

Your thoughts???
I would take a wild guess if it works… :slight_smile:

Here the Information I have on the system Dell with MX-18…

============
File created:
============
20 October 2019 17:29:18

	    <---====+++++++++++++++++++++++++++++++++++====--->
	           System information for Dell357-Mx18:
	    <---====+++++++++++++++++++++++++++++++++++====--->

============
Bios Information:
============
	Bios Manufacturer: Dell Inc.
	Bios Release Date: 01/19/2010

============
System Information:
============
	System Manufacturer: Dell Inc.
	System Product Name: Inspiron 546 
	System Version: Not Specified
	System Serial Number: 2BK2FK1

============
Board Information:
============
	Board Manufacturer: Dell Inc.
	Board Product Name: 0F896N
	Board Version: A02
	Board Serial Number: ..CN7360498F00OP.

============
Distro Information:
============
	Distro OS: MX 18.3 Continuum
	Desktop: Distro: MX-18.3_x64
	Codename: Continuum
	Release: 18.3
	Kernel Ver: 4.19.0-1-amd64
	Kernel Bit: bits: 64

============
CPU Information:
============
	AMD Athlon(tm) II X2 240 Processor

============
RAM Information:
============
	5.5767 GB

============
Graphics Adapter: 
============
	Advanced Micro Devices, Inc. [AMD/ATI] RS780 [Radeon HD 3200]

============
Network Adapters:
============
	Ethernet:
	Port Name: eth0
	Nic Card: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 02)
	MAC Address: 00:25:64:d2:03:1c
	Ethernet Address: 192.168.1.103/24

============
Inxi - System Data Information:
================
System:    Host: Dell357-Mx18 Kernel: 4.19.0-1-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0 
           Desktop: Xfce 4.12.3 Distro: MX-18.3_x64 Continuum Dec 20  2018 
           base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Desktop System: Dell product: Inspiron 546 v: N/A serial: <filter> 
           Mobo: Dell model: 0F896N v: A02 serial: <filter> BIOS: Dell v: A11 date: 01/19/2010 
CPU:       Topology: Dual Core model: AMD Athlon II X2 240 bits: 64 type: MCP arch: K10 rev: 2 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 11200 
           Speed: 1600 MHz min/max: 800/2800 MHz Core speeds (MHz): 1: 1600 2: 800 
Graphics:  Device-1: AMD RS780 [Radeon HD 3200] vendor: Dell driver: radeon v: kernel 
           bus ID: 01:05.0 
           Display: x11 server: X.Org 1.19.2 driver: ati,radeon unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RS780 (DRM 2.50.0 / 4.19.0-1-amd64 LLVM 7.0.0) 
           v: 3.3 Mesa 18.2.6 direct render: Yes 
Audio:     Device-1: AMD SBx00 Azalia vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Device-2: AMD RS780 HDMI Audio [Radeon 3000/3100 / HD 3200/3300] 
           driver: snd_hda_intel v: kernel bus ID: 01:05.1 
           Device-3: Sunplus Innovation type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-4:2 
           Sound Server: ALSA v: k4.19.0-1-amd64 
Network:   Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet vendor: Dell 
           driver: r8169 v: kernel port: e800 bus ID: 02:00.0 
           IF: eth0 state: up speed: 100 Mbps duplex: half mac: <filter> 
Drives:    Local Storage: total: 1.37 TiB used: 654.87 GiB (46.8%) 
           ID-1: /dev/sda vendor: Maxtor model: 7Y250M0 size: 233.76 GiB temp: 50 C 
           ID-2: /dev/sdb vendor: Maxtor model: 7Y250M0 size: 233.76 GiB temp: 40 C 
           ID-3: /dev/sdc vendor: Western Digital model: WD10EAVS-00M4B0 size: 931.51 GiB 
           temp: 31 C 
           Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVD+-RW GH50N rev: B101 
           dev-links: cdrom,cdrw,dvd,dvdrw 
           Features: speed: 48 multisession: yes audio: yes dvd: yes 
           rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
Partition: ID-1: / size: 52.62 GiB used: 7.39 GiB (14.0%) fs: ext4 dev: /dev/sda3 
           ID-2: /home size: 168.29 GiB used: 16.71 GiB (9.9%) fs: ext4 dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 31.0 C mobo: 30.0 C 
           Fan Speeds (RPM): cpu: 1032 fan-2: 819 fan-3: 0 
           Voltages: 12v: N/A 5v: 2.96 3.3v: N/A vbat: 3.25 
Info:      Processes: 179 Uptime: 44m Memory: 5.58 GiB used: 446.0 MiB (7.8%) Init: SysVinit 
           runlevel: 5 Compilers: gcc: 6.3.0 Shell: mystat-in_work_ inxi: 3.0.36 

I have stared that the forest so long that I do not see the trees anymore…

Well that is about it for this book…LOL If you need something else let me know…
THANKS for any help or thoughts…

LLAP

Have you looked at all information on the EndeavourOS wiki regarding sound problems?

in pavucontrol of pulseaudio, there are sound profiles, in this case my own hdmi i select the hdmi to have sound on that

Well we are going backwards this morning I did 20 some updates and now the HDMI is not even detected by pulseaudio at all. Before it was there but showing UNPLUGGED…
I checked the Wiki at the link you showed and from what I can tell all the test the HDMI must be available, mine is NOT!
On the MX forum one king person suggested to rollback to a older kernel 4.9 or 4.14…
I did so late last night to 4.14 on MX-19 and I now have HDMI audio on the same board not changing anything but booting to another HDD with MX-19… 4.19 must be to new for my hardware… :frowning:

I did find a 4.14 in the AUR and I have it building at this time… Well see what happens.
I run old junk as Joe Collins like to refer to it…lol I don’t need nor can I afford the latest computer parts on my disability check… :smiley:
Well see how this goes… Thanks for your thoughts…
I will let ya know what happens…
I just can’t believe that I am the only person in billion of computers that is having this issue…
LLAP

Have you looked at the configuration settings in the audio mixer of the volume icon?

Screenshot_2019-10-26_11-08-30

This one isn’t plugged into anything on the HDMI.

Yes… Not there now… Use to be there and now it is not. At least if it was unplugged that would be something… :frowning:

Well I installed 2 kernels 4.14 and 4.9 and still no sound on the HDMI nore is it now seen at all in the mixer settings…

I can boot the other HDD’s with MX, Mint, Peppermint and not changing anything the sound works on the HDMI as it should. Sorry this is a REQUIREMENT for me…

I have fooled with this for 4 days now and I am tired of playing around with it… :frowning:
I can boot Mint, Peppermint, MX, Ubuntu and my HDMI sound works, no fuss no muss…

If I have to rebuild a house just to open the front door, it is not worth it!!!
With that said, if I have to rebuild a OS just to get the audio to work, it is not worth it!!!
Sorry to say but EndervrousOS is not working out for me so it is time to move on to something else…
I will just have to stick to Debian OS’s as they work 99% out of the box with just a click here or there with my old JUNK! So sad, I do like the your OS and Manjaro but without sound they are useless…

As for the Wiki I did go there, “Getting information on soundproblems” all I get from the links in the instructions are “404 errors server not found” when trying to download the links, so that was a waste of time and useless…

So I GIVE-UP!!! An I never do that!!! But today I am…
Arch is not my friend… Sad to say…
So if you have a magic rabbit in your hat… Were moving on…

Oh thanks for the comments and thoughts…
I will check back later…

LLAP

I never give up! No magic rabbits in the Hat! The problem is i don’t know all the intricacies of what you have done and how exactly… and i don’t have the hardware in front of me. I’m not sure what you mean you have installed 2 kernels 4.14 and 4.9? You should be using the latest kernel which is 5.3.7. The configuration settings for the volume control should be there unless a component isn’t installed. Either an alsa package or pulse audio? Not sure what URL you are trying to go to but i don’t have that issue.

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting

https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture/Troubleshooting

You have two HDMI cables output to two tv’s. You said you are not using sound output. Start with the basic get sound working. Get sound working on one. Then get sound working on the other. There is no crystal ball here! :slightly_smiling_face:

I have a couple Radeon cards hooked to HDMI but i don’t have two tvs hooked up. Mine is working on the one tv and i have sound out going through my stereo system and tv speakers through HDMI.

Screenshot_2019-10-26_13-09-37

Screenshot_2019-10-26_13-10-03

Well here I am again, I said I give-up and here I am… Lol

  1. MX group said on my MX-19 to rollback to a older Kernel LTS so I installed Linux49lts and Linux414lts. That is all the software that I have installed… When I installed the OS I chose the 4.19lts kernel…
  2. I do not have 2 TV’s hooked to the card. Just one with the HDMI cable. I borrowed a video card that is a little newer that the one that is built on my Mobo and it has 3 ports, HDMI, VGA, HD something oval 25 pin plug…
    It is a Advanced Micro Devices, Inc. [AMD/ATI] RS780 [Radeon HD 3200]

    I said that I have a monitor and the TV, I think… ? Not sure… I have just been testing and checking with both the onboard video and then add the internal add-on video card which BTW both video ports work and the sound on the HDMI too! “With the add-on video card” and booted with EndeavourOS…
    Now I am just banging my head on the table at this point…
  3. when I open the Volume Control as you have pictured there is NO HDMI!
    just the Digital spid thing and the built-in-audio…(No Add-on Video card)
    In MX, Mint, Peppermint there is… No changes are made, just booting to another OS on another HDD’s and the HDMI is there as you pictured in your post!
    An the sound out of the HDMI works…
    YES, If I plugin my headphones into the little Green plug there is audio there!
  4. This link all the “Get” links were giving me 404 server not found or file not found… I tried several times… https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture/Troubleshooting

So here is a thought… Somewhere someone asked about video drivers… The HDMI audio works off of the Video port/card of something. From all my testing I did see that the same driver was used on the other OS’s, but could there be a version issue? Just had that thought… I don’t know how to check or change them…

So should I change the Kernel as I am booting the 4.19 lts and removed the others as they were not working… This is toooo much for my 65 year old brain… Lol
Yet here I am…
Thanks for your time…
LLAP

The links here work fine? What i would do is boot up on the live ISO of EndeavourOS and try it. No sense booting into any other distros if they work. I am assuming you have EndeavourOS already installed? So it could be an installation issue. So try it on the live ISO first. It has the 5.3.6 kernel.
Also here are the packages that i have installed for both pulse audio and alsa. You can check to see if everything is installed.

Do you try already to remove pulse audio settings?
rm -R ~/.config/pulse

@joekamprad If you remove the pulse audio conf file does it recreate itself? Reboot?

exactly…i do this at first if something not working with pulse…

1 Like

I’m back… :smile:
Sorry for the delay in answering… We had a real bad storm and took out trees, power lines roofs… Not good! Power was off 12 hours, so I am trying to remember where I left off and I got nothing…
So I downloaded the ISO again, got a new USB stick and booted the computer with the USB, an NO the sound does not work out of the HDMI nor does it even see it at all. The built-in audio does work as it should.
After reading your post @ricklinux, I decided to abandon the installation in question and start from a fresh install where there has been nothing done to but updates, install pamac-aur-git, Clementon…

hdmi-usb
The USB ISO see’s it but when you open the Profile: it shows it as (unplugged)(unavailable)… I could play music from the (built-in) card.

So I did a fresh install as I said and I now still get this…

I started Clementon and I could make it see the HDMI but when it changed songs it would loose the HDMI port…


When each song is finish I would have to reset the HDMI in the settings and sound would come out of the TV speakers…

Same thing with this player… After each song I would have to reset the mixer settings…


@ricklinux I have all the file as in your pics. Remember that this is a fresh install. No other OS on this drive or attached to the motherboard… :smile:

@joekamprad an @ricklinux I did not remove the file you mentioned before. So I entered the command that @joekamprad posted and to answer @ricklinux question, the folder is gone, NO it did not come back after rebooting!

This is all I have done to this point… I will not do anything until You kind folks say so… Lol
Once again Thank You for your kindness and help with this undertaking and you time…
LLAP

Okay i will let @joekamprad have a look first and give some direction here also. There should be more devices in the drop down arrow. It may not be using the correct output device. Check the output devices and see and maybe try them.

Also there is a little lock box there to change also. I’m confused as to what device you want it to play through? The HDMI going to the TV or the sound card output? Do you never have sound going through HDMI to tv? Or it works on what? Not the audio players?

What does your output devices show?

Screenshot_2019-10-27_13-38-57

@ricklinux there are a few others, here are the pic’s. All the HDMI are shown
(unplugged)…
Boy I like the Print Screen widget… Lol

I under the confusion part… Lol I would like to have the audio come out of the HDMI to the TV… NO SOUND CARD… :smile:
Look at the above pics where I have Clementine playing it is hooked to the HDMI on the playback and In the Settings Profile: Digital Stereo (HDMI) Output (unplugged)(unavailable) is selected, there is music coming from the TV until Clementine changes to the next song and the HDMI port goes to the OFF setting in the Profile: dropdown and Clementine defaults to the Built-in Audio: Analog Stereo Output, then the music comes out of the headphones I have plugged into the GREEN Port…
If I want to get the HDMI working again with Clementine I have to choose the Settings Profile: Digital Stereo (HDMI) Output (unplugged)(unavailable) again and then go to the PLAYBACK Tab as in the Pic above and select the HDMI to change it from the Built-in Audio…
I took the above Clementine in the sequence Of making the changes to get the sound out of the TV…
The sound has always came from the “Built-in Audio”… :slightly_smiling_face:

Ok then… Puppy dog says it is time for a nap! Thanks!
Catch ya later…
LLAP

@bescott9944 Trust me its easy to get confused when reading so much information on different threads. So you have VGA and HDMI but i’m assuming you only have HDMI going to the tv? The VGA is going to a normal monitor? The optical cable goes from where to where? Audio out going into the stereo system. I get that.

My setup works and i have HDMI from video card going to the tv. I have audio out going to stereo system. I do not have vga hooked up to anything. It all works so i’m trying to understand your setup because yours isn’t working. I do not have optical cable for anything. My HDMI gives me video and audio to the tv. If i want it to go through the stereo i just turn on the stereo and my sound out goes to it. Have you tried just have HDMI hooked up only? See if you get sound. Then hook up sound out to Stereo do you get both. Then what ever you have optically? Also have you tried any other audio music players other than clementine such as rhythmbox? The reason I’m asking is because you said you had sound but then when it changes to the next song it loses it.

Show output devices
aplay -l

1 Like

@ricklinux Hi,
Sorry for the delay it was Walking Dead Night…Lol

“”" So you have VGA and HDMI but i’m assuming you only have HDMI going to the tv? The VGA is going to a normal monitor?"""
No I only have the TV now. I went and got another TV from the upstairs room. No Amps, nothing, just the computer and TV… :wink:
Although my setup across the room is like you have it, computer, TV, Stereo, optical cable and so on… But when I get this sorted out with your help I will be using the stereo…

Here is the TV/Monitor…

Here is the output of aplay -l…
aplay-l

Note: I have tried several, (4) HDMI cables (including this one) thinking that it could be a cable issue but I am getting the same issues…

Yes I also used Parole Player with the same results as clementine, next song the player defaults back to the “built-in audio” …


The last pic I selected the HDMI and when the song changed the HDMI went away… :frowning:
Later and thanks!
LLAP

So there is only one HDMI card and it is card 1 device 3. You can test and see whether sound works with this command according to the Arch wiki. Not sure it will work but you could try.

aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Right.wav

Then you can also edit /etc/pulse/default.pa to load the HDMI manually. It’s a configuration file for pulse audio which will force the HDMI device to be the default. Again i don’t know whether it will work. I’m just getting this info from the Arch wiki. So before i go further well see if the sound works with the command above first. The thing that’s strange is that it say’s it’s unavailable and unplugged? So it may be a sink problem? It’s not selecting the right one?

If you can post the output from
sudo alsamixer