Having issues with AMD GPU (Radeon 7600S) on Linux

Now that was a journey, but I still couldn’t find a solution online, so I decided to make a report and see if anyone can see a way I didn’t try.

I thought I had bad experience with Linux + Nvidia GPU, so I decided to buy a laptop with AMD GPU next and try it out. Recently I bought a new Asus TUF gaming laptop with AMD Ryzen 7 and Radeon 7600S. However, I soon realized that there are scary visual bugs happening every now and then while I use Endeavour OS. These look like snow/static artifacts popping up randomly, even when the task is not hard on the GPU, such as simple messaging in a messenger, or setting up different preferences in System Settings. Unfortunately I couldn’t capture these bugs with a recording software, as it just doesn’t capture the artifacts when they occur, so it contributed to my suspicions that the GPU itself might be broken.

One pal of mine suggested that I should try out Gnome instead of KDE, and if that doesn’t help - switch to Ubuntu, because there is probably no appropriate software for Arch-based distros, and it should be better there. However, I faced the same issues on Ubuntu even after installing proprietary AMD GPU drivers.

Then I decided to switch to Windows 11, that used to be preinstalled on the laptop, in order to ensure that this is not a mechanical issue. Turns out it is not. It works perfectly with Windows 11 out of the box, with no tinkering with any configurations needed at all.

However, I’m simply used to Endeavour OS with KDE Plasma, so I’m seeking for possible solutions for this issue. I’d be thankful for any suggestions.

Good afternoon,
It’s very nice recent hardware.
Can you contribute :microscope:

$ inxi -FGa

If you can also

$ journalctl -b0

And screen format it, so as much as many pairs of eyes can look at it on the forum.
You can contribute with 3 back tiks at the beginning and at the end to format each part.
( ```

Let’s look at this :smiley:

1 Like

Hi! Thank you for your reply. Here you go:

inxi -FGa

System:
  Host: AsusTUF Kernel: 6.6.21-1-lts arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1 clocksource: tsc avail: acpi_pm
    parameters: initrd=\0fb3634c0a114679b33e4a0ce3944f4e\6.6.21-1-lts\initrd
    nvme_load=YES nowatchdog rw
    rd.luks.uuid=9cd0b5bf-7712-4460-a6fd-71c8f6424ab0
    root=/dev/mapper/luks-9cd0b5bf-7712-4460-a6fd-71c8f6424ab0
    systemd.machine_id=0fb3634c0a114679b33e4a0ce3944f4e
  Desktop: KDE Plasma v: 6.0.1 tk: Qt v: N/A info: frameworks v: 6.0.0
    wm: kwin_wayland vt: 1 dm: SDDM Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A16 FA617NS_FA617NS
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: FA617NS v: 1.0 serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends LLC. v: FA617NS.410
    date: 06/15/2023
Battery:
  ID-1: BAT0 charge: 89.7 Wh (100.0%) condition: 89.7/90.0 Wh (99.7%)
    volts: 17.4 min: 15.9 model: AS3GWYF3KC GA50358 type: Unknown serial: 08F2
    status: full
CPU:
  Info: model: AMD Ryzen 7 7735HS with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
    family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404102
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 469 high: 1514 min/max: 400/4829 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400
    4: 400 5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400 12: 400 13: 400
    14: 1514 15: 400 16: 400 bogomips: 102248
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Navi 33 [Radeon RX 7700S/7600/7600S/7600M XT/PRO W7600]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: RDNA-3 code: Navi-33
    built: 2023+ pcie: gen: 4 speed: 16 GT/s lanes: 8 ports: active: none
    empty: DP-1,HDMI-A-1,eDP-1 bus-ID: 03:00.0 chip-ID: 1002:7480
    class-ID: 0300
  Device-2: AMD Rembrandt [Radeon 680M] vendor: ASUSTeK driver: amdgpu
    v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
    pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-2 empty: DP-2,
    DP-3, DP-4, DP-5, DP-6 bus-ID: 77:00.0 chip-ID: 1002:1681 class-ID: 0300
    temp: 41.0 C
  Device-3: Sonix USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:3 chip-ID: 2b7e:b685
    class-ID: 0e02
  Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu,amdgpu display-ID: 0
  Monitor-1: eDP-2 res: 1536x960 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: radeonsi device: 2 drv: swrast surfaceless: drv: radeonsi
    wayland: drv: radeonsi x11: drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    rembrandt LLVM 17.0.6 DRM 3.54 6.6.21-1-lts) device-ID: 1002:1681
    memory: 500 MiB unified: no display-ID: :1.0
  API: Vulkan Message: No Vulkan data available.
Audio:
  Device-1: AMD Navi 31 HDMI/DP Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8 bus-ID: 03:00.1
    chip-ID: 1002:ab30 class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 77:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
    driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 77:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 77:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.21-1-lts status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: eno1 state: down mac: e8:9c:25:80:fe:a9
  Device-2: Realtek RTL8852BE PCIe 802.11ax Wireless Network
    vendor: AzureWave driver: rtw89_8852be v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 06:00.0 chip-ID: 10ec:b852
    class-ID: 0280
  IF: wlan0 state: up mac: f8:54:f6:c1:f6:1c
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: IMC Networks Bluetooth Radio driver: btusb v: 0.8 type: USB
    rev: 1.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 5-1:2 chip-ID: 13d3:3571
    class-ID: e001 serial: 00e04c000001
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
Drives:
  Local Storage: total: 480.69 GiB used: 9.36 GiB (1.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD PC
    SN740 SDDPNQD-512G-1002 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: 23232P803651
    fw-rev: 73101000 temp: 34.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 model: USB Flash size: 3.75 GiB block-size:
    physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s lanes: 1
    mode: 2.0 tech: SSD serial: Disk fw-rev: 1100 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 475.94 GiB size: 467.4 GiB (98.21%) used: 9.22 GiB (2.0%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-9cd0b5bf-7712-4460-a6fd-71c8f6424ab0
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
Sensors:
  System Temperatures: cpu: 44.8 C mobo: N/A
  Fan Speeds (rpm): N/A
  GPU: device: amdgpu temp: 42.0 C device: amdgpu temp: 48.0 C mem: 50.0 C
    fan: 0 watts: 19.00
Info:
  Memory: total: 16 GiB note: est. available: 14.87 GiB used: 3.04 GiB (20.4%)
  Processes: 394 Power: uptime: 8m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
    image: 5.94 GiB services: org_kde_powerdevil, power-profiles-daemon,
    upowerd Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1094 libs: 256 tools: yay Compilers:
    gcc: 13.2.1 Shell: Bash v: 5.2.26 running-in: yakuake inxi: 3.3.33

journalctl -b0

бер 13 20:43:49 AsusTUF kernel: Linux version 6.6.21-1-lts (linux-lts@archlinux) (gcc (GCC) 13.2.1 20230801, GNU ld (GNU Binutils) 2.42.0) #1 SMP PREEMPT_DYNAMIC Wed, >
бер 13 20:43:49 AsusTUF kernel: Command line: initrd=\0fb3634c0a114679b33e4a0ce3944f4e\6.6.21-1-lts\initrd nvme_load=YES nowatchdog rw rd.luks.uuid=9cd0b5bf-7712-4460->
бер 13 20:43:49 AsusTUF kernel: BIOS-provided physical RAM map:
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009ffff] usable
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x00000000000a0000-0x00000000000fffff] reserved
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x0000000000100000-0x0000000009afefff] usable
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x0000000009aff000-0x0000000009ffffff] reserved
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x000000000a000000-0x000000000a1fffff] usable
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x000000000a200000-0x000000000a213fff] ACPI NVS
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x000000000a214000-0x000000008fd77fff] usable
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x000000008fd78000-0x00000000928cffff] reserved
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x00000000928d0000-0x000000009296bfff] ACPI data
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x000000009296c000-0x0000000097c61fff] ACPI NVS
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x0000000097c62000-0x0000000098ffdfff] reserved
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x0000000098ffe000-0x0000000098ffefff] usable
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x0000000098fff000-0x0000000098ffffff] reserved
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x0000000099000000-0x000000009affcfff] usable
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x000000009affd000-0x000000009bffffff] reserved
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x000000009ce00000-0x000000009fffffff] reserved
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x00000000e0000000-0x00000000efffffff] reserved
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x00000000fd000000-0x00000000ffffffff] reserved
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x0000000100000000-0x000000043e2fffff] usable
бер 13 20:43:49 AsusTUF kernel: BIOS-e820: [mem 0x000000043f340000-0x00000004801fffff] reserved
бер 13 20:43:49 AsusTUF kernel: NX (Execute Disable) protection: active
бер 13 20:43:49 AsusTUF kernel: APIC: Static calls initialized
1 Like

For now, I see some firmware update available.

I’ll keep looking in the logs.

There’s a very good chance some members on the forum are gamers and posses this similar computing machinery. They will also provide advice :wink:

Thank you very much! I’ve just switched back from Windows 11 to EOS, let me start from updating everything and see if this firmware update helps.

Ok, I understand it’s optional but with Wayland in it’s beginning release, things might improve.

I’m not confortable with this one;

API: Vulkan Message: No Vulkan data available.

Maybe a professional computer technologist can reassure us, the users, with that driver information.

:slight_smile:

1 Like

Sure, thank you for reminding. Installed amdvlk. It doesn’t fix the artifacts, but still

  API: Vulkan v: 1.3.279 layers: 1 device: 0 type: discrete-gpu
    name: AMD Radeon RX 7600S driver: amd v: 2024.Q1.2 (LLPC)
    device-ID: 1002:7480 surfaces: xcb,xlib,wayland device: 1
    type: integrated-gpu name: AMD Radeon Graphics driver: amd
    v: 2024.Q1.2 (LLPC) device-ID: 1002:1681 surfaces: xcb,xlib,wayland

1 Like

Keep in mind this is a hybrid laptop with internal amd graphics on the cpu which is what it is using to render with. You have to use a method also to switch to the 7600S.

Edit:

 API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    rembrandt LLVM 17.0.6 DRM 3.54 6.6.21-1-lts) device-ID: 1002:1681
    memory: 500 MiB unified: no display-ID: :1.0

For vulkan use vulkan-radeon and also set up hardware acceleration which requires some additional packages and configuration.

Specifically if you need 32 bit library files you’ll need to install them also.

So I’ll begin with vulkcan-radeon lib32-vulkan-radeon lib32-mesa
For hardware acceleration libva-mesa-driver lib32-libva-mesa-driver mesa-vdpau lib32-mesa-vdpau
Then you have to set two environmental variables for vdpau in /etc/environment

add

LIBVA_DRIVER_NAME=radeonsi
VDPAU_DRIVER=radeonsi

You also need vulkan-tools but i think it’s already installed.

Follow the arch wiki here: https://wiki.archlinux.org/title/AMDGPU

Edit: You still then need to use a method to switch graphics. I don’t know what settings this laptop has in the bios if any for that. You may need to use envy-control or another method.

https://discovery.endeavouros.com/hardware/envy-control/2023/03/

Edit: After to check graphics for vulkan is just

vulkcaninfo

Edit: I also forgot for hardware acceleration you need package libva-utils
check after with:

vainfo

You also need package vdpauinfo

check after with:

vdpauinfo

Edit: Has to have all the packages installed and set up with enviromental variables and reboot before checking if everything is listing properly.

1 Like

Great, let me try it out. I was just reading through this article right now, but wasn’t sure if the part you quoted is the thing I need to try. I’ll send a report after completion.

1 Like

Aight, I’ve done the thing. The artifacts didn’t leave. Should I post the results of vulkaninfo, vainfo and vdpauinfo? The result for the first one appears very long.

Envy Control seems to be compatible with Nvidia GPU only. Previously I tried to find something like Optimus Manager that would be compatible with an AMD GPU, but my search didn’t give result. Unfortunately BIOS doesn’t have an explicit option for enabling dedicated GPU on this computer.

As long as they provide info you know they are working. I’m not sure about the artifacts because like i said it is rendering on the internal graphics on the cpu until you switch.

Edit: Is this on Wayland that it is happening?

Edit: Do you have another external monitor hooked up also and does it do this on both the laptop screen and the external monitor? Are they higher frequencies than 60 Hz?

I’m not really sure what is best to use with dual amd hybrid graphics for switching.

Edit: There must be some users that have dual amd that maybe can advise.

If I’m not mistaken, I started using this laptop before the Plasma 6 release, plus I’ve checked it with Gnome on EOS and Ubuntu, so Wayland shouldn’t be the issue.

No monitors connected, but the main one has 165 Hz frequency. I just tried to switch it to 60 Hz, but still face those sporadic artifacts.

While doing parallel reading, I’ve also found out about this command. If I’m not mistaken, the result for it must mean that the rendering is being performed by the Radeon card.

$ glxinfo | grep “OpenGL renderer”

OpenGL renderer string: AMD Radeon RX 7600S (radeonsi, navi33, LLVM 17.0.6, DRM 3.54, 6.6.21-1-lts)

With adding DRI_PRIME=1 part to /etc/environment, I managed to get this result for a test with glmark2

=======================================================
    glmark2 2023.01
=======================================================
    OpenGL Information
    GL_VENDOR:      AMD
    GL_RENDERER:    AMD Radeon RX 7600S (radeonsi, navi33, LLVM 17.0.6, DRM 3.54, 6.6.21-1-lts)
    GL_VERSION:     4.6 (Compatibility Profile) Mesa 24.0.2-arch1.2
    Surface Config: buf=32 r=8 g=8 b=8 a=8 depth=24 stencil=0 samples=0
    Surface Size:   800x600 windowed
=======================================================

My main version right now is to try AMD proprietary drivers according to this guide, but I can’t figure out how to disable open-source drivers and enable the proprietary by default. A result for the below-mentioned command returns AMD instead of Advanced Micro Devices, Inc. right now.

glxinfo | grep “OpenGL vendor string” | cut -f2 -d":" | xargs

I don’t think using the proprietary drivers is the way to go. If it’s just the visual artifacts i would try to resolve that. I also don’t think its rendering on the dedicated card just because of that open GL command output. :man_shrugging:

Yeah, your remark seems legit.

As to my understanding, it is indeed just a visual bug, it has never lead to any crashes or sensible productivity issues. It just looks somewhat alarming, as the issue persists on different distros, and it looks like if the GPU was dying, thus making me worried about its condition if I keep using it without addressing the issue.

Are you getting cursor corruption? Trying to understand exactly what is happening with artifacts?

I managed to capture some of the artifacts on a .gif image (I hope the link works properly. The file is big, because when I lower the quality, the bug can’t be seen). This is the most reliable way to recreate the bug in my case, although its manifestations are not limited to this case. While trying to adjust Night Color temperature, you can see the artifacts popping up here and there.

Similar effect can be seen on Gnome (both EOS and Ubuntu) when quickly switching between different wallpapers.

And, welp, it just happens sporadically now and then.

I see it but i don’t know what to suggest to help with that. :man_shrugging:

Unexpectedly switching to Xfce4 did the trick for me. I suppose the whole issue was in Wayland. I guess that’s it for me using KDE. I had enough headache with it even before Plazma 6, but they decided to make things worse just for a laugh or I don’t know :upside_down_face:

Thank you guys for helping me out!