Has anyone used AwesomeWM?

Yes. Top is installed with Endeavor.
LightDM is what allows you to log into your desktop when the system is first installed. There are other destkop managers (DM) available, but that is what comes with Endeavor. I typically use one window manager so don’t need to switch often, so I have made changes so that I can disable it.

1 Like

Display Manager.

Memory usage changes vastly between devices. A lot of factors affect how much memory a specific setup needs to run smoothly.

Did you remove some packages or something to reduce your RAM usage as well?

I see, that explains why on VM it uses less RAM compared to runing it on my actual PC.

Yeah. As I went to bed last night I realized that sleepiness was affecting my communication skills. Started to wonder what else I might have said that was wrong :neutral_face:

1 Like

Sorry. I was very tired last night. Should have mentioned that AWM is mostly stock but I have shut down a few services that I don’t need, so Endeavor on my laptop is not entirely vanilla. I do this to improve boot time with the pleasing side effect that overall performance is improved as well. Xfce is gone also, but if I wasn’t logged into the DE it didn’t affect much anyway.

As was mentioned by @anotherusername, hardware will have a lot to do with what you can or can’t turn off and how the changes will affect the system as a whole.

1 Like

Can you share, please, which services did you turn off?

And how can one check what’s running by default?

All good mate and as @Tasia91 asked if possible I would like to see what services you removed please?

I run “systemd-analyze blame” after the system is fully booted. This shows what processes were started during boot up as well as how long they take. Then I decided what is needed and what isn’t. (DISCLAIMER: I have totally bricked my laptop on a few occasions doing this. Please do some googling at this point. I am not an expert :wink:)

For example, I don’t use Logical Volume Management, so LVM2 is unneeded.
“systemctl stop LVM2” will stop the process.
"systemctl disable LVM2 will usually make it not start at the next boot.
Sometimes disable doesn’t work because another service may trigger the one you don’t want.
“systemctl mask LVM2” makes the service invisible and it WILL NOT start.

I also disable systemd-time-wait-sync-daemon, accounts-sync(I think) and avahi along with some others that I don’t remember right now. The important thing is to remember that every system is different so what I don’t need may be very important to someone else. Research is key. Google/Duck Duck Go and the ArchWiki are my best friends (other than my wife).

There are other options to consider changing like how journal flushing is handled but my ability to explain this is quite weak.

I hope some of this is helpful :blush:


Thank you for the detailed reply, that was very helpful. systemd-analyze looks like a very useful utility, there are many other great commands to run with it besides the ‘blame’, according to the man.
I think I need to brick (and hopefully fix afterwards) my laptop too, everything seems to be too stable on my side, probably because I tend to leave things as close to vanilla and simple as possible. That’s why I know so little I guess :slightly_frowning_face:

edit: I’m really sorry for all this off-topic, but I have one more question, if someone knows. Is there a config file or something similar I could back up, before disabling services? So that I remember what did I turn off and could easily restore it if needed ( I probably don’t really want to break things that much :sweat_smile: )

I was thinking that if a moderator wants to move this to its own thread that would be good. Not sure if I can do it on my own.

Systemd-analyze has been very helpful to me for education if nothing else. ‘critical-chain’ is a good tool to put on the end as well as blame. I don’t know about a config that has startup service info, I just try to disable one at a time until I learn the effect. Problems have come from the “shotgun” approach, shutting down several things, reboot, and…OOPS! Have fun and learn. Reinstalling is always available :sunglasses:


Well, the best I’ve come up so far is just list all the units and their current state and write it to a text file:
systemctl list-unit-files > backup_systemctl_state.txt
To have it as a reference how it was, when things were working :upside_down_face:

1 Like

The question is why? The current thread hasn’t totally gone out of the topic’s context.
If you can elaborate, like what’s the new topic you wanna move some posts to? Which posts are related to that specific topic? etc.

We just seemed to have drifted from AwesomeWM to system performance. If it isn’t bothersome to anyone I’m good. Honestly, system performance and WMs go hand in hand in my experience. Setting up a WM based environment is an excellent way to learn about how an operating system works.


While this shouldn’t be a problem, creating a different thread, there already are threads somewhat likely similar to this topic. Like these share your aliases or functions, tips and tricks for i3. I’m still following this topic, if it extends to a good reason, I’ll create a different thread, move things over and notify the participants.

1 Like

Awesome (no pun intended). Thanks.


What do they do?

I will give that a try then

Thanks mate :slight_smile:

1 Like

One question, how do you connect to wifi on awesome? I typed in the terminal sudo wifi-menu and it showed me the menu and I entered the key and everything, it worked once but after a reboot when I do the same thing and connect to my modem (the 2nd time it does not ask for a key/password) when I use any browsers, my Internet connection does not work, any idea?

Install networkmanager and network-manager-applet (the last is to ease the network switching process). Enable NetworkManager service. From command line, use the nmtui command to connect to a network. Once connected to a specific network, as long as the router stays turned on, the system will auto connect to the router on each reboot.

1 Like

Would this mess with KDE as I have this installed?