Has anyone tested drag-and-drop in v44?

Or is there anybody currently with access to the beta or whatever?

I have installed EndeavourOS with GNOME, with Wayland (or that’s what it reports in system settings) because I cannot help it.

If so, are all the drag-and-drop issues fixed? Because this one grates me. In particular from File Roller to a file manager other than “Nautilus”. Or going between two non-GNOME applications as been complained about on “Ask Ubuntu”.

I’m sorry if this topic was already created a short time ago but I really need this drag-and-drop to work. Before EndeavourOS I checked out RebornOS with GNOME and was faced with this issue. On that other OS I had installed Engrampa and Nemo, tried to make it work with them but the same no-go which peaked me off. Using “Extract” button inside File Roller GUI is clunky. Otherwise have to extract ZIP file whole which is not convenient sometimes, or use “Extract here” file manager context menu.

So far I have Thunar and installed the two extensions “volman” and “archive-plugin” related to it because I abhor “Nautilus”. I’m willing to absorb most of GNOME if it would run smoothly on my computer, but not the file manager which is the crown jewel IMHO.

Unwilling to wait until two major distros featuring GNOME are released later this month to find out. Done with both of them.

I had hopes with the following topic but it seems the issue still exists.

(Gnome Archive Manager Issue Drag n Drop)

“File Roller is not part of GNOME suite of apps” and “Wait until GTK4 on GNOME 44” were the best excuses out of the search results. It has nothing to do with EndeavourOS and that’s why I really didn’t want to start this topic. It was “the final frontier of Asimov’s original solar system”. :wink:

Maybe one solution for your use case could be to use another file archiver than file roller if it really doesn’t allow to drag/drop outside of nautilus and the developers don’t add this feature. One that works with your other file manager, thunar or nemo?

Personally I think there is nothing wrong with nautilus, I prefer over thunar, good search function. But that’s personal preference of course.

Edit: but doesn’t mint come with file roller per Default?

Edit 2: does it work if you login X11 session?

Man, thank you for this! I would have never figured this out on my own. After dozens of times I logged in my regular user in GNOME I never noticed the gear icon in password screen.

Now see if it could stay on X11 session because apparently with Wayland it doesn’t work. It would have to be fixed I’m sure, with all the talk that one display protocol will replace the other.

I was never comfortable with “nautilus” since they changed it from what is MATE/Caja now. That other one (and Nemo) is slow instead. XArchiver is an impressive mess with checking things out compared to Engrampa or File Roller to use but I could have used that with Thunar.

I try to clarify that a few weeks back, I checked out RebornOS for a few hours, with GNOME because none of the other D.E.'s would install for me. My Internet connection is too slow for it, I guess. I put in Nemo and fully expected it to work with File Roller to unpack stuff from ZIP, RAR, 7Z etc. Then I tried this drag-and-drop operation and it kept failing which was mind-boggling to me. It never happened to me before in any system not with GNOME. It was in a Wayland session.

But I’m glad I dumped it for EndeavourOS. :heart:


It was your destiny :grin:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.