Hardened Kernel

CPU: Quad Core Intel Core i7-7700HQ (-MT MCP-) speed/min/max: 800/800/3800 MHz Kernel: 5.14.9-hardened1-1-hardened x86_64
Up: 15m Mem: 3101.4/15736.9 MiB (19.7%) Storage: 476.94 GiB (27.5% used) Procs: 254 Shell: Bash inxi: 3.3.05

I installed the Hardened kernel on EndeavourOS and have noticed that everything seems to work fine. The only exception to this seems to be Balena Etcher. It will not open after the install, I was wondering if anyone else was experiencing this issue and knew a workaround or fix. I tried removing it and reinstalling with no success. Any advice or help would be appreciated.



Try running it from the terminal and see if there is an error there

This is the error I get:

10042:1009/112454.372841:FATAL:setuid_sandbox_host.cc(158)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that /opt/balenaEtcher/chrome-sandbox is owned by root and has mode 4755.
/opt/balenaEtcher/balena-etcher-electron: line 10: 10042 Trace/breakpoint trap (core dumped) “${script_dir}”/balena-etcher-electron.bin “$@”

That might be restricted by the hardened kernel.

Does it support passing --no-sandbox

No, it still gives the same error

In that case, use popsicle instead.


Ok, thanks for all your help!!

1 Like

I assume installing popsicle worked out just fine for you. A few weeks ago I tried to install popsicle but was unable to build in properly from the AUR. I’m just going to assume they’ve since fixed that issue. If not and you can’t install it, the popsicle-git package also from the AUR will install just fine, I’ve been using it for the last month or two no issues. Good luck!

I had the same compiling issue, I will give popsicle-git a shot.

1 Like

Why don’t you use linux’s own dd? You will find a full explanation on Endeavour’s website or just google it. I would tell you what to type, but you’ll just blame me when you format the wrong HDD/SSD!!!

I wouldn’t blame you, if I did that it would be my fault. I had to drop the hardened kernel, it broke more than I thought. I couldn’t use my mail client (mailspring) and it broke some of my steam games.


That’s all I need it to do