GRUB is not visible but is otherwise working

GRUB submenu can be navigated with the keyboard however it does not show on the display and what was there on the screen before the grub menu loaded shows instead.

With a bit of trail and error I figured it out but to test my hypothesis, I selected the endeavourOS from my UEFI boot entries. When I had installed Endeavour, I had setup timeshift autosnap with Grub-BTRFS with the guidance of the EOS discovery wiki page on it.

Here are the contents of /etc/default/grub which I had modified before to suit my tastes

# GRUB boot loader configuration

GRUB_CMDLINE_LINUX_DEFAULT='psmouse.synaptics_intertouch=0 nowatchdog nvme_load=YES resume=UUID=dda3f538-bb25-4bfb-9915-d64b5f460ba8 loglevel=3'

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.

# Uncomment to disable submenus in boot menu

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.

Here’s the output of sudo fdisk -l

Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: ST1000LM024 HN-M
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 48A93804-3E37-4500-AAD9-E444F8F009D4

Device          Start        End    Sectors   Size Type
/dev/sda1        4096    2052095    2048000  1000M EFI System
/dev/sda2     2052096 1935065087 1933012992 921.7G Linux filesystem
/dev/sda3  1935065127 1953520064   18454938   8.8G Linux swap

Partition 3 does not start on physical sector boundary.

I have tried holding down esc during boot or pressing any key during boot. I also removed quiet and splash (splash I had added previously to use plymouth)

Thanks in advance for the answers !

From inside your running system, could you try regenerating the grub.cfg?

sudo grub-mkconfig -o /boot/grub/grub.cfg

Reboot and check.

Still no luck

I missed this part :blush:

Un-comment the timeout style line and run the grub.cfg update command.

Still not appearing

So after setting


and running

sudo grub-mkconfig -o /boot/grub/grub.cfg

you are still not seeing the grub boot menu at boot? If that is the case, I don’t know what might be the cause.

By the way, just to rule out a possible cause: you haven’t by any chance used Grub Customizer?


GRUB SubMenu on Boot Working But Grub’s Graphics Not Showing Up On Boot

I am not sure what is the exact nature of the issue you are facing.

You can get to Grub submenu. So I suppose you get to the Grub boot menu first.

So what does it mean that “Grub’s Graphics Not Showing Up”?

What are you expecting to happen/see when you boot your system which does not happen or you can’t see?

Please give some more detailed information.

The grub menu (console) from which you can choose which os you want to boot into and if you want to reboot into bios.

What I still fail to see is how you can get to the submenus without getting the menu first. :thinking:

Anyways, we could try rebuilding the whole Grub environment from scratch and see if it will work:

The step 6 may not be necessary. If you still want to perform it, adapt it to match your system:

--efi-directory= ##the mountpoint for your ESP
--bootloader-id= ## the directory where the bootloader binary is installed

If your set up to boot in a saved selection or last selected won’t it boot into that selection?
I know I have done it in the past where it would boot grub into the sub menu.

Yes. It should.
However looking at the /etc/defualt/grub posted:

it doesn’t seem to be set up that way.

A bit of an intriguing issue this one, it seems :thinking:

Tried it. Problem still persists.

Then I have nothing more to add.
Hopefully some other forum members will come by and assist you on this.
Good luck!

Hi, is there some way to change the title of this forum post? If not should I create a new one. What I mean from the title is that GRUB’s menu (console version) is navigatable from the keyboard but it doesn’t appear on the screen.

Tried everything told by people in this same issue which is the same but on Manjaro.

are you mixing mkinitcpio and dracut together?
Not that I would be able to help you.

perhaps a picture showing what your trying to say. Grub is only console to start with so I think that is where confusion is coming in for some of us

1 Like

No, I think I am only using dracut. I had to learn where to add modules to dracut and then I added the module specifically for my computer following the manjaro guide to dracut.