GRUB is not visible but is otherwise working

You added this link in your post above that you followed this line by line which is mkinitcpio.


That second image is the grub menu screen and appears to 100% correct. That first image is your machines firmware loading screen which if you don’t want to see you can turn off in the BIOS. What exactly are you expecting to see?


What I mean that instead of adding the module to mkinitcpio (as the manjaro forum issue told me to), I instead added the same module for my computer this line `add_dracutmodules+=" i915 ’ which I found in inxi -Sza -Gza

in its output’s word driver under graphics information in its output to /etc/dracut/eos-defaults.conf

i915 is a kernel module. I don’t think it is a dracut module. This probably isn’t what you want.

You probably want to early load it with:

force_drivers+=" i915 "

This is also mentioned in our dracut wiki(The example is for nvidia):

Although, dracut loads after grub so I don’t think this is going to help with grub. The most common reason people add that is for plymouth.


Instead of the grub menu appearing what was there on the display before grub appears there although while it does so grub is still navigatable with the keyboard.

How do you know you can navigate if you cannot see it? I am not sure I understand the issue exactly.

1 Like

The grub menu doesn’t show but is still there so I can navigate thru it with the keyboard using my memory to know which option I am on and then I can boot into my system by hitting enter on the default entry or any other entry that allows the user to boot into their system.

Ok so are you saying while the lenovo logo is showing you can access the grub menu in the background even though you can not see it. For example when the lenovo logo is showing you can hit arrow down and enter and the advanced menu screen will be there when the lenovo logo disappears? If that is the case do as I suggested and turn off the laptops splashscreen in its BIOS. See your users manual on how to do this.

Actually I just looked you actually cant turn that off as it is part of the machines power on self test (P.O.S.T).

Yes, but when I boot EOS from the one time boot menu then the lenovo logo doesn’t appear, so then instead of grub’s graphics being displayed nothing does, however I can still navigate the grub menu. Therefore, I don’t removing the logo would help but I will try in the morning. Its time for me to sleep :zzz:

With my memory I know which options is where in the grub menu and therefore I know how many times do I need to press the arrow keys i.e the down arrow key to navigate to each and press enter to boot it.

I reinstalled my system and the exact same problem occurs there too. Must be a bug in the latest grub.

I am using Firefox and the pencil icon is not appearing for me.

Me too. Try the pencil icon in your first post and see if you can edit the title there.

Can’t do it even after clicking on the pencil icon here in Raw, HTML (code) and HTML (preview):

The pencil icon under your post:

Screenshot from 2023-12-02 15-52-57

It shows no pencil icon
No pencil icon

Ask the moderators to change the title then. Good luck!

Who are the moderators?

The pencil icon is here:

If you don’t have that, it is probably because you are new member and your trust level isn’t high enough yet.

In that case, you just need to share what you want the title to be.